1P fills in search box even though no corresponding entry exists in webform

At my bank web site (https://www.bankofinternet.com/), in addition to the username/password fields there is a search box. When I use "go and fill" my username/password are filled in, but my username also is entered by 1P into the search box, and the "auto submit" is "hitting" submit for the search function rather than the submit button for the username/password. When I look at the webform details in 1P, there are only two entries, one each for the username and password. I tried creating a new 1P login, being sure that only the username/password fields were filled, but the behavior is the same.

Is there something I'm doing wrong here?

Comments

  • I tried creating a new 1P login, being sure that only the username/password fields were filled, but the behavior is the same.

    Just to be quite clear, did you follow the exact procedure for re-creating and saving the login manually when you did that? That is the usual solution for cases like the one you have.

    Stephen

  • camnercamner Member

    Yup, I sure did! That's the first thing I try now when I have a login issue. Create a new login from scratch by manually filling in the credentials and using the "gear" to manually create the login.

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @camner,

    You certainly haven't done anything wrong. I've test both 1Password 5.3 and our current beta and they all behave the same way over more than one browser.

    I've reported the issue using our betas to show the issue is an ongoing one. Thank you for bringing this to our attention.

    What I can say at this point is despite filling in your username in the extraneous field, the submit after filling feature focuses on the correct field so it submits your login credentials rather than having the site ask a question based on your username.

    Another possibility is I find this URL which should work.

    https://www.mybankofinternet.com/tob/live/usp-core/app/login/consumer

    The disadvantage of that particular URL is the main page notified me just now of some downtime which this alternative URL didn't.

    Hopefully we can get it the new filling logic to work a little smarter as this isn't the first time I've seen this. Development on the new filling logic is happening at a terrific pace though so I'm confident :smile:

  • camnercamner Member

    Thanks! (But in my experience here, the "submit after filling" feature does NOT focus on the correct field and up pops the search results popup window.

    My workaround is to disable the "submit after filling" feature for this login and to submit manually.

    Thanks for the help.

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @camner,

    That would be another workaround, especially if submitting for you is happening on the wrong field. I wonder why you're experiencing that difference from me.

    Just for comparison's sake I'm running 1Password 5.3 for Mac with the stable Safari extension, version 4.3.1.

    Regardless, the issue with the website has been reported.

    ref: Synapse 1021

This discussion has been closed.