ScrumAlliance autosubmit goes to search page [browser autofill conflict]

edited May 2015 in 1Password in the Browser

After creating my login in 1P v5, using it went to the search page without logging in.

After reading some of the other questions in this section, I was able to fix the problem by editing 1P's login entry and changing the "submit" value to "Never submit".

1Password Version:5.3
_Extension Version:
Not Provided
OS Version: Not Provided
Sync Type: Not Provided


  • MeganMegan

    Team Member

    Hi @kgomara ,

    That's a bit of a curious issue. I've done some testing here, using, and a new Login seems to fill and submit correctly. Of course, I'm using dummy data, so I just get bounced back to the login screen with an 'invalid credentials' warning. I've got a few more questions to see if we can track down where things are getting tangled:

    • Are you using a different URL to log in?
    • Do you see your data fill before the search page is loaded?
    • Do you see any error messages?
    • How are you filling on the page? (Are you going to the website manually and then using ⌘\ ( Command- \ ) to fill in your details or are you selecting your ScrumAlliance Login from the list in 1Password mini?)

    The more detail you can provide, the more quickly we'll be able to get to the bottom of this. :)

    1. I am on the login page -
    2. Yes, the data fills in. I've experimented with clearing the username and/or password fields before using 1P mini - same results.
    3. No error messages of any kind. (Do you write a hidden log file anywhere?)
    4. I generally use 1P mini. I also tried using it from the Mac menu bar, the full app (double-clicking the Scrumalliance login in the Categories>Logins list). I tried ⌘\ and got interesting results. If I clear the username/password fields ⌘\ fills correctly but goes to the search page. If I leave those fields pre-populated by the Browser, ⌘\ does not appear to fill in or do anything at all. ⌘\ works correctly with other sites.

    I attached a screenshot showing the Web form details. Perhaps that will yield a clue.

    Thanks for the support.

    Thanks for looking into it.

  • brentybrenty 1Password Alumni

    @kgomara: Indeed! Delete the field with 'Site search' completely (this appears to be one of many hidden form fields). I think that should do the trick.

    Ultimately, when websites fill a single page with so many superfluous fields, it is often helpful to 'prune' the login down to only the ones you actually want 1Password to bother with. Please let me know what you find. I look forward to hearing back from you! :)

  • Thanks for looking into this. Unfortunately deleting site search (and all the other "superfluous fields") did not fix the problem - still goes to Site Search.

    One thing I noticed - if I manually enter my information, then click outside of any text box and hit return, nothing happens. How exactly do you "Submit when enabled"? In the form details I don't see anything identified as a submit button.

  • brentybrenty 1Password Alumni
    edited May 2015

    @kgomara: Ah, I really thought that would work. It seems that the hidden Search field (magnifying glass in the upper right) is getting submitted instead for some reason.

    Just to clarify:

    So if you have 1Password fill your login credentials, you should be able to submit the form manually...

    ..but I think I finally understand your problem. I read this differently initially:

    If I clear the username/password fields ⌘\ fills correctly but goes to the search page. If I leave those fields pre-populated by the Browser, ⌘\ does not appear to fill in or do anything at all.

    I looked at the form, and I said to myself, "Self, why don't I see the fields pre-populated like he's described? They look empty to me..."

    And then it hit me: you must have the browser (Safari?) saving and filling your login credential for this site, which is conflicting with 1Password trying to do the same. Cage match! Follow this guide to disable the browser's built-in login filling and see if that helps. :)

    prcb.jpg 563.5K
  • Thanks - that worked!

  • littlebobbytableslittlebobbytables 1Password Alumni

    I'm glad we managed to help make sense of this puzzle @kgomara :smile:

This discussion has been closed.