Bug Report (5.3): quickly typing in search field deletes every typed letter except the first

Hey you guys,

First of all: I looked everywhere to simply file a bug report of some sort but couldn't find anything. I hope I didn't miss anything. If so, please tell me.

I noticed a weird bug in version 5.3 on the iPhone (didn't check on iPad): When quickly typing something in the search field, every letter I enter gets deleted, except the first. So if I type “1Password” really quickly, every letter will be deleted (you can see the cursor jump back and forth) and only the “1” will stay. When typing slowly, this doesn't occur. Can you reproduce this? Is this a known issue? If so, I apologize.

I'm a big fan of 1Password, keep up the good work!

Best regards from Berlin,



  • ag_kevinag_kevin Junior Member

    Team Member

    Hi @albert.s ,

    Yes, this looks like a new issue. I was able to reproduce it. It looks like it only happens on the main categories screen, but works if you go into one of the category lists and search there. Thank you for reporting it. I will alert the developer team.

    ref: OPI-2547

  • I have this issue too. I love the 1Password community and how fast things are figured out, and responded to by 1P support! Amazing!

  • brentybrenty

    Team Member

    @bnpluss: Thanks for letting us know. There really is a great community here, and we can't take all the credit for that! Hopefully we will be able to get this issue resolved, thanks to the help of kind folks like you bringing these issues to our attention. And our developers. They do a great job, too. Cheers! :)

  • Thanks, @brenty and @hayesk. Glad I could be of help.

  • BenBen AWS Team

    Team Member

    We definitely appreciate it. :)

  • albert.salbert.s
    edited May 2015

    5.4.2 fixes the issue. Resolved!

  • BenBen AWS Team

    Team Member

    Great! Thanks for letting us know that worked for you!

  • I can confirm that 5.4.2 fixed this issue as well. I'm still not a fan of the way that the progress ring rotates overtop of the search icon (magnifying glass) though - it looks like a design bug - maybe an update is in the works for this as well?

  • BenBen AWS Team

    Team Member

    Thanks for the feedback, @bnpluss. I'm not aware of any specific changes planned for that but I'll pass the feedback along. :)

This discussion has been closed.