Holding command for too long opens the login page in a new tab.

When logged into 1Password (so that hitting the autofill shortcut fills automatically, without needing to enter your 1Password password), hitting the shortcut -- CMD + \ by default -- and holding command for just a second too long will open the login tab in a new page, as if you had manually clicked the "Login" button while holding command.

1Password Version: 5.3
Extension Version: 4.4.2
OS Version: OS X 10.10.4
Sync Type: Dropbox
Referrer: forum-search:Holding command


  • brentybrenty

    Team Member

    @wendy_appleseed: Strange. 1Password doesn't have a facility for opening login URLs in a new tab by holding the ⌘ key (although this is a feature browsers themselves support).

    I wasn't able to reproduce what you're describing, but perhaps if you give me the exact steps you're taking (with a specific URL as an example) we can gain some insight. Can you tell me which "Login" button you're referring to? Thanks in advance! :)

  • In Safari, you can hit CMD + \ to enter login information and automatically login. If 1Password is already logged in then hitting CMD + \ fills in your credentials without you needing to enter your 1Password password. I believe that to log you in, 1Password simulates clicking the "Submit" button, and if you are holding CMD while this happens, then it is equivalent to CMD-clicking a link in Safari, which opens the link in a new tab.

  • brentybrenty

    Team Member

    @wendy_appleseed: Ah, thanks for clarifying! Understood. It sounds like you have Autosubmit turned on, whereas I did not.

    I enabled it and tried what you describe though, but I am still not seeing this behaviour (opening a new tab if is held down as the login form is submitted). Again, are you encountering this with specific URLs you could provide as an example?

    Also, in your description, it sounds like you've navigated to the website manually. Is that the case? If you had not, and were therefore not already at the login form, pressing ⌘ \ should have no effect. Your description makes intuitive sense, except that 'clicky' Autosubmit went away in 5.3; now 1Password sends a Return keypress to submit the login form.

    Please let me know what you find. I look forward to hearing back from you! :)

  • Hi @wendy_appleseed,

    I can reproduce and Safari does the same if I manually log in too. Say you set a Login item to not submit after filling. We fill and just sit there. If I hold down the cmd key when pressing the enter key it causes a new tab to open. I make extensive use of cmd + left click or shift + cmd + left click for opening new tabs in the background or foreground in Safari so I know where you are coming from.

    I don't have a good answer for you I'm afraid. If you release the cmd key reasonably fast it doesn't happen and the only other option I can think of is to alter the keyboard shortcut away from ⌘\ for filling the current page (we don't have to worry about Safari interfering with ⌥⌘\ as it doesn't cause the AppleScript to fire at that point) as well as not using submit after filling. Unfortunately this is the sort of issue you may face if two applications respond to the same modifier key.

    I don't remember this being an issue in the past though so I don't know why it is now, unless something has been tweaked in Safari. I apologise that there isn't a solid answer beyond altering the modifier keys in the shortcut.

    It seems Safari also reacts to ⇧⌘\ to show you all the currently opened pages (Show All Tabs). I think it's easier to count the number of Safari shortcuts that don't use cmd it seems.

This discussion has been closed.