Data missing in new version of 1Password after editing using old version

This discussion was created from comments split from: How to upgrade 1Password3 (OSX 10.8.5) to 1Password4 ?.


  • edited September 2015


    I recently purchased Version 4 Mac from Version 3 Mac. However, my key chain in 1password 4 Mac was missing some important login information; whereas Version 3 has all my data.

    I also am syncing everything between the following programs using Dropbox:

    1Password 4 Mac
    1Password 3 PC (works fine)
    1Password 4 Android (works fine)

    When I downgrade back to version 3, I see all my data. Any tips on how to rectify this issue



  • brentybrenty

    Team Member

    @whatsupnow6: Rather than trying to fit you into an existing thread about Firefox 40 and 1Password 3, I've split you off into a separate discussion. ;)

    To be clear, there is no 1Password for Windows version 3. If you can tell me the actual version numbers you're using on each platform, it may prove useful.

    However, I believe I understand your confusion. If you're going back and forth between 1Password 1/3 and 1Password 4/5, data may appear to be 'missing' because 1Password 1/3 does not know anything about the newer features added in 1Password 4/5. It is best to use 1Password 1/3 as a 'reader' if you're going to add information in 1Password 4/5.

    All your data is there (as you've seen), but 1Password 1/3 cannot read or write to it, so if you make a change there it is writing to the old section and then 1Password 4/5 is reading the new section and does not see this data. I hope this helps. Please let me know if you have any questions! :)

  • Hello,

    I just verified that I am on 1Password for Windows version, the latest version.

    It may help if I give you a timeline of events. I had a Mac and everything was working fine with 1Password 4. I then reimaged the machine and installed 1Password 5, not fully knowing I didn’t have a license.

    When I was working with 1Password 5, I started to notice that I didn’t see certain pieces of data––to be specific I didn’t see some logins. I then looked through my email and realized that I had purchased 1Password 4. I then removed 1Password 5 and downgraded to 1Password 4 to see if that would recover the missing data -- it did not fix it. I then downgraded to 1Password 3 to see if that would fix it, and it did -- I could see all my data.

    So here’s an updated list:

    Android v4 (see all data)
    1Password v4 Windows (see all data)
    1Password 5 (don’t see all data)
    1Password 4 (don’t see all data)
    1Password 3 (see all data)

    I hope that helps and thank you for your time and attention.


  • Hi @whatsupnow6,

    So just to correct one small misunderstanding. If you have a valid licence for 1Password 4 for Mac then you have a valid licence for 1Password 5 for Mac too. 1Password 5 was a free upgrade for all existing 1Password 4 users.

    Here is what I would like you to try please.

    1. Follow our How do I start over with an empty vault? guide. Please be careful as 1Password 4/5 use a folder titled 1Password 4 while 1Password 3 uses a folder titled 1Password and they will both appear in your ~/Library/Application Support/ folder. You only want to remove the 1Password 4 one.
    2. Remove the 1Password 4 application and leave yourself 1Password 3 and 1Password 5.
    3. When you restart 1Password 5 do as you did before and see if the missing data is still missing.
    4. If it is can you open 1Password's preferences please and switch to the Sync tab. Where does 1Password 5 say it is syncing to?

    There are a couple of possibilities that I can see. It might be 1Password 4/5 was picking up data from somewhere other than it should or it might be the Agile Keychain is damaged. Now both 1Password for Windows and 1Password 3 for Mac have options for repairing so if we can be sure that 1Password 5 is looking in the right place then we'll look at trying to repair the Agile Keychain and see if that helps. We'll wait for you to report back :smile:

  • Hi @littlebobbytables ,

    Thank you for your response.

    I followed the instructions as you stated to a T. It still did not work, And to help the matter I’ve attached a copy of the screenshots. The left hand side has 1Password 3 and the right hand side has 1Password 5.

    Please let me know next steps to solve this.


  • Hi @whatsupnow6,

    Can I make a small request of you please, can you show us the current state of the General tab in 1Password 3's preferences and the Sync tab in 1Password 5's preferences. I'm wondering if 1Password 5 has mistakingly selected a different Agile Keychain than you want it to and this is why it's not showing everything. No matter what, it will teach us something :smile:

  • Hi @littlebobbytables ,

    Here's a screenshot of the 2 sync configurations side by side.


  • brentybrenty

    Team Member

    @whatsupnow6: I'm sorry that you're still having trouble with this, but I think we're making some headway. Thank you for sharing that!

    I do have a couple questions that will determine how we proceed:

    1. Have you edited any items in 1Password 4/5 and added custom sections/fields? If so, 1Password 3 cannot read these, only the "legacy" template data.
    2. How many items are "missing" in 1Password 4, but present in 1Password 3? It may be simplest and easiest to export these separately to later import once we're sure everything else is in order.

    Again, I'm sorry that this is proving to be a slow process. There are a number of solutions that could work, but we want to proceed cautiously to ensure that you don't lose any data permanently.

    If the answer to question 1 is "no", it may be simplest to backup your data in both apps, export everything to 1PIF from 1Password 3, start over completely with a new vault, and import the 1PIF. It seems likely that your vault is at least partially damaged, so rebuilding it may be a good idea regardless. Please let me know what you find. I look forward to hearing back from you! :)

  • Hi @whatsupnow6,

    Before going down the route of exporting it might be worth seeing if 1Password 3 can repair the Agile Keychain. There is a menu option, Help > Troubleshooting > Rebuild Data File.... I can't guarantee it will help but it has to be worth a shot.

    If you do try an export/import here is what I would recommend.

    1. Export from 1Password 3 using the menu option File > Export All > 1Password Interchange File....
    2. Create a secondary vault (for testing in 1Password 5 using the menu option 1Password 5 > New Vault...
    3. Import the 1PIF from step 1. into the secondary vault using the File > Import... menu option. There's a bug where the two buttons in the import window don't react to mouse clicks so if you use the enter key for the Open button and the escape key for Cancel.

    Compare this test secondary vault against what 1Password 3 reports. If the two match we know we're in business for creating a clean primary vault using this 1PIF. Please do keep us posted :smile:

  • edited September 2015

    Hi @littlebobbytables!

    Alright, so here goes period I tried the following:

    1. I tried the rebuild option in 1Password3. This did not work.
    2. I tried creating a new vault in 1Password 5. I then exported the data out of 1Password 3 as a PIF. I then imported it into 1Password 5, 1Password 5 crashed.
    3. Realizing that there were about five more logins in 1Password 3 than 1Password 5, I tagged all of the data in 1Password 5 with an existing tag I had. We’ll call it “dummy tag”.
    4. I then went into 1Password 3 and created a smart search that said does not contain “dummy tag”.
    5. This then showed me about five logins which were all bank related.
    6. I then exported out those five logins as a PIF and attempted to reimport them into 1Password 5, and 1Password 5 crashed again.
    7. Realizing that somehow these were five corrupt logins. I re-created them in 1Password 5 and then deleted the corrupt ones out of 1Password 3 and everything seems to be working fantastic.

    You got should pay me for this type of stuff ☺ I love your products by the way

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @whatsupnow6,

    I'm really happy you managed to determine what the problem was. Sadly we will likely never know how these five items ended up corrupted and of course there isn't any way to review the 1PIF with the corrupted items as they contain sensitive data that no sane person should ever request and no sane person should ever offer to send.

    Hopefully this will be the last you need to think about this and that going forward it works as intended.

This discussion has been closed.