Difference in password change saving between Firefox and Chrome

Hey folks, having a bit of a weird problem. First some basics, this is occurring on Chrome 44.0.2403.157 (64-bit) on OSX Yosemite. 1Password 5 for MAC.

Basically, when I save a new login, one password works fine, it will prompt me to save the login and everything is good. The issue occurs when I try to change my password. Basically, I goto the site's password change page (lets use amazon or facebook as an example since I tried with both of these). I click the password generator, it auto fills the new password, I enter my old password and hit submit...I am not being prompted to update the saved credentials.

Oddly, this works perfectly fine on my other mac, same OS, same browser. I tried rebooting, deleting the 1password extension, re-adding it etc, all to no avail. I know I can get around this by just manually updating the password, it just seems strange to me that it is working on one machine but not on the other. Is there some other preference file or something that may be interfering? Any other thoughts on how to troubleshoot / resolve this?


1Password Version: 5.3.2
Extension Version:
OS Version: OSX 10.10.3
Sync Type: Not Provided


  • Drew_AGDrew_AG 1Password Alumni

    Hi @sfb911,

    That seems a little strange - but just to make sure I understand, when you say it works on your other Mac, do you mean it works when you change your password on those same sites (like Amazon or Facebook)?

    Normally one of my first guesses is that something is blocking the communication between the 1Password extension and 1Password mini (firewalls, anti-virus software, network proxies, another browser extension, etc). However, it sounds like 1Password automatically asks you to save new Login items? Do you have any trouble using the extension to fill your existing Logins on websites? If those things work correctly, it doesn't sound like something is blocking it from detecting that you changed your password.

    Now, this is probably a long shot, but you mentioned that you filled the new password fields first, then went back to fill your old password. If you try this again, maybe try filling the old password first, then click the Fill button in the Password Generator to fill the new password fields and see if that makes any difference. (It might not help, but it's worth a shot, just in case.)

    By the way, when this problem happens and you aren't prompted to update a Login with the new password, do you check to make sure 1Password created a new Password item with that new generated password?

  • Thanks for the response. So to answer your questions. Yes, all other functionality works fine (adding new logins, passwords that are generated being saved in the password list etc). Existing logins simply don't get prompted / updated on a change. Its very strange.

    I did go back and double check on my other mac - it is also not working on chrome (same versions across the board). Firefox works just fine (But FF is not my browser of choice).

    So it appears to be a chrome specific issue on all of my macs. Does this change the approach?

    I've been consistent in using amazon and facebook for all of my testing since I would imagine you have good 'support' for those sites as far as recognizing the password change procedure on them.


  • Hi @sfb911,

    That's certainly interesting and gives us something to work with. Can I ask a favour please. Can you first confirm that your browsers across both machines are up to date and don't have an update pending (this really messes things up with Chrome). Next can you check that the extension, it should be on Chrome and I probably 4.4.2 on Firefox as we're waiting for a review. With all of that confirmed could you post the versions for both Firefox and Chrome for me please, I just want to make sure I'm using the exact same version and branch (stable/beta/dev). I have a test Amazon account that exists for the single purpose of being hammered with password changes so I will definitely investigate this.

  • Greetings @sfb911,

    I've taken the chance to move this to our Saving and Filling in Browsers forum as this is definitely in relation to the extension and the extension specific code in 1Password. Hope you don't mind (along with the title change).

  • Hi @Drew_AG

    On both mac's here is the version information.

    Below is the chrome info from both systems, neither of which is working with Chrome

    Chrome Version: Version 44.0.2403.157 (64-bit)
    1Password: Password Manager and Secure Wallet Extension Version:

    For Firefox, which appears to be working the version information on both systems is:

    Firefox Version: 40.0.3
    1Password: Extension Version 4.4.2

    Let me know if you are able to replicate / find a resolution. I'm happy to do a webex / remote
    session and show you guys the issue if you can't replicate it on your end.


  • Hi @sfb911,

    That's great, thank you :smile: I think you've supplied everything we should need to replicate the issue and I shall report back with some results soon :smile: I do apologise about this.

  • @Drew_AG @littlebobbytables

    I just wanted to check in and see if you guys had been able to replicate this issue and determine the cause at all?


  • Drew_AGDrew_AG 1Password Alumni

    Hi @sfb911,

    Thanks for checking in about this! Good timing too, as we believe we just found a bug which might explain the problem you're having. We think it might be related to using the 'Fill' button in the password generator. In that case, the next time you try to change your password on one of those sites, do not click the 'Fill' button - instead, try copying the new password from the generator to the clipboard by highlighting it and using the ⌘C keyboard shortcut. Then paste it into the new/confirm password fields (using Edit > Paste or the ⌘V shortcut). When you submit the change, does 1Password prompt you to update the Login?

  • Just registered because I'm evaluating moving from lastpass and I'm experiencing this issue too. I saw that there was no answer, however. But I can answer you, Drew, that yes, what you describe does work for me and I am experiencing what the OP described and what you describe. I use the "fill" and it doesn't prompt me to save it. ⌘C / ⌘V works, however. Looking forward to how I might fix this.

  • Greetings @avatarr,

    If I've understood your post correctly you're saying you're not asked if you want to update a password when you fill using the Password Generator but you are when you copy and paste. If this is correct then sadly there is nothing you can do to fix this - the fix has to come from us. The only way round it is to copy and paste as you already know. I apologise for this and the delay as the expected fix has to come in both the extension and the program. Hopefully the known workaround isn't too cumbersome for now and that other than this one quirk that you're enjoying 1Password.

  • Adding a comment here as well, I just had this happen when I changed my password for Namecheap.com. I was not prompted to save the new login, instead, the new password was saved by itself in the "Passwords" category. I have not tried copying and pasting yet. Hopefully this can be fixed soon.

    For the record, I'm on OS X 10.11 and Chrome Version 46.0.2490.71 (64-bit)

This discussion has been closed.