Problems with Chrome extension

I just started evaluating 1Password. I must say I use Chrome developer channel, and I'm aware it's not supported, but still I have some problems with it.

First of all: when I log into a site, the extension isn't saving my login data, or is offering to to this.
When i first use Safari to store the data, the extension does fill in the data and I can login.

Is this behaviour due to the fact I'm using the developer version of Chrome? Because when I'm debugging, I find the following:

When I debug the extension (the background page), I see three resources can't be loaded (json2.js, chrome_password_options.js and password_utils.js). See also screenshot 2.
Screenshot three shows the directory listing on my drive. According to the background_page.html, the missing files should be in this directory.

Update: I alsol found this log meesage in Console.app:
27-03-11 13:05:23 [0x0-0x13f13f].com.google.Chrome[4601] [30873] Sun Mar 27 13:05:23 2011| Cannot find resource folder '/Users/doekman/Library/Application Support/1Password/Extensions/30873/Resources'. Falling back to the main bundle.

The extension number (30873) is wrong. The only folder existing is 30884.

Comments

  • khadkhad Social Choreographer

    Team Member
    edited March 2011
    Welcome to the forums, Doekman.

    It sounds like your 1Password installation is damaged, which is likely affecting browser integration. To resolve this:

    1. Download 1Password from our web site:
    http://agilewebsolutions.com/downloads
    Click on the "Download Now" button under "1Password 3"
    2. Quit your web browser and 1Password, if it's running
    3. Open your Applications folder and drag 1Password to the Trash
    4. Install the new copy of 1Password you just downloaded
    5. Run 1Password and then your web browser

    Your information is stored in a data file separate from the application, so it will not be harmed by this procedure.

    If that alone does not resolve the issue, please uninstall the Chrome extension from within Chrome (Window > Extensions > 1Password > Uninstall), and then reinstall the Chrome extension from within 1Password (Preferences > Browsers > Install Google Chrome Extension).

    If you are still having trouble, please try the current stable build of Chrome.

    Please let me know how it turns out.
  • It looks like downgrading to the stable channel is the only way to go.
    Shame...
  • BLOND37BLOND37 Junior Member
    "First of all: when I log into a site, the extension isn't saving my login data, or is offering to to this. "

    having same problem
  • MartySMartyS AgileBits Customer Care (retired)
    BLOND37 wrote:

    "First of all: when I log into a site, the extension isn't saving my login data, or is offering to to this. "

    having same problem


    Thanks, BLOND37, we've received your e-mail about this issue. We need additional information from you so we'll cover some ground via e-mail first, and then summarize here whatever we find out.
  • BLOND37BLOND37 Junior Member
    MartyS wrote:

    Thanks, BLOND37, we've received your e-mail about this issue. We need additional information from you so we'll cover some ground via e-mail first, and then summarize here whatever we find out.



    hi - dread to ask whats going on with this?


    also i have some questions as to what 1P can and can not do.. who / where should i ask?
  • khadkhad Social Choreographer

    Team Member
    edited April 2011
    Hey Blond37,

    I have replied to you your posts in one of the other threads you started which I hope helps. I still need some more information from you there if you need further assistance, though. Just the like doctor asks, "Where does it hurt?" Please help me help you. :-)

    If you have sent us an email, we are a bit busier at the moment, but we will reply as soon as we can. I was not able to find an email in our system from the address you have registered with in the forums, though. :S

    If you need assistance beyond what I have been able to provide in my previous reply, please let me know in that thread or send us another email at [email protected] If you are sending from an address different than the one you used to register in the forums, you can send me a private message on here with the address, and I will be glad to look into it for you.

    I hope that helps. Please let me know.

    Cheers!
This discussion has been closed.