Password Prompt takes a long time to open when Internet is disconnected

Unlocking 1Password takes a long time to display the password prompt if there is no Internet access. Sometimes this also causes the shortcut Ctrl + \ to stop working until restart.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • brentybrenty

    Team Member

    @kathampy: Hmm. 1Password doesn't need internet access to unlock. Do you maybe have some sort of 'security' software doing some filtering on your computer? It may be that something else is interfering.

    After disabling internet access completely, I'm still not seeing a difference in the unlock screen either in the browser or the main 1Password app. Can you tell me the exact steps you're taking? It may help us narrow down the cause. Thanks in advance! :)

  • I don't have any security software. Just Windows firewall. What happens in my case is if my primary Internet line fails, outbound connections to public IP address will fail to connect. It may take several seconds to time out. The LAN and public DNS resolution will continue to work. So DNS resolution to public domains will succeed but the connection won't go through. This could be causing the timeout delay.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @kathampy,

    Do you only see this issue in your web browsers? What happens if you open the main 1Password program, does it unlock and show you data at a normal pace?

    In modern web browsers such as Firefox, Chrome, and Opera, 1Password extension needs to be injected in the website before it can process your command. If the site is stuck at loading and is waiting, your shortcut will not work because the command hasn't been sent from the extension to 1Password Helper, the background service on your computer to work with your extensions and your local 1Password folder.

  • kathampykathampy
    edited October 2015

    I use the Unlock on Secure Desktop option. It happens for all methods - clicking the browser icon or right clicking the system tray icon to open the menu, or double clicking the system tray icon to open the 1Password application.

    It happens even when accessing LAN web pages while the Internet is down. The pages load completely but the 1Password menu and application take a long time to show the Secure Desktop. Even right clicking the system tray icon directly has the delay.

    For the record, a lot of applications break or freeze until some timeout when DNS resolution succeeds but socket connections fail. When DNS also fails, then they won't attempt to connect. In my case, DNS resolution is done by a domain controller which has a backup line to the Internet, but socket connections from my computer to the Internet will fail.

  • brentybrenty

    Team Member

    @kathampy: Very strange. I'm not seeing this at all when I kill my internet connection. Perhaps in your case it's due to things not having switched over yet, whereas in my case there is no backup: when it's gone it's gone. Have you tried simply renewing your lease (WIN+R > cmd.exe > ipconfig /renew) to update DNS?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @kathampy,

    Is it possible it might be the update checker that's slowing this down? If you can reproduce this:

    1. Open the main 1Password app, unlock, and go to the File Menu > Preferences > Updates
    2. Uncheck the box next to Automatically check for updates: and press OK to save the change.

    Restart 1Password, is it much faster now?

  • I haven't had another outage yet. I'll try to simulate it when I have time.

  • MikeTMikeT Agile Samurai

    Team Member

    Please do let us know how it turns out.

This discussion has been closed.