Firefox Extension adds "1Password" button to right-click menu

I love the addon and I'm a paid user, but all of a sudden today I noticed that there is a new button at the top of my right-click menu in Firefox. This is really annoying. I'd love to remove it, as I use 1P by clicking a button in my browser bar, not my right-click menu.

I could not find an option to remove it in the settings.

Comments

  • brentybrenty

    Team Member

    @ndimoro: Sorry or the confusion! The 1Password extension has — as long as I can remember — been at the bottom of the right-click contextual menu across all platforms and browsers when installed.

    I'm not sure how it could be at the top of the menu for you, or why you would have just noticed it now. It's part of the extension, there isn't a way to configure it, and the only way to remove it is by removing the extension itself. We may be able to change this behaviour in the future, but I can't say for certain if or when we will. Thanks for bringing this up! :)

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @ndimoro,

    Did you add a new extension to Firefox to manage your contextual menu options or anything like that? As Brenty mentioned, we've always had this at the bottom for years and we have not changed this part of the code since then.

    This is what it should look like:

  • sprspr
    edited November 2015

    I have the same issue: today, the 1Password entry moved itself to the top of the page and link context menus. This is really annoying, because I'm used to having "Open link in new tab" in that position.

    The problem persists even if I uninstall and reinstall the addon, but restarting Firefox seems to solve it temporarily.

  • Hey everybody!

    I just retested this on two of my testing setups and it works as expected and looks like it does in @MikeT's screenshot.
    Do you use any extensions or other third-party tools that allow a modification of the context menu or have you made alterations to Firefox itself?

    Thanks

  • This occurred again today. It was still wrong after the first time I restarted Firefox, but it's correct again the second time. Some kind of race?

    I have other extensions that add entries to the menu; NoScript and uBlock Origin. Neither of them has had any problems.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @spr,

    Can you email us your 1Password diagnostic report, we'd like to grab some configuration information from your Firefox's configuration file. Use this guide to generate a diagnostic report to email to us and, in the email, also include the link to this thread along with your forum username.

    Let us know here when you've sent it, so we can look for it, and confirm we got the email.

This discussion has been closed.