Chrome and Firefox plugin not able to find 1password helper


On my laptop, whenever trying to click on the 1password extension, it says that it failed connecting to the 1password helper.
In Internet Explorer the extension works. Opening 1password works also without any issues
On my PC it works essentially with same software installed.

Tried (with no success at all):

  • restarting 1password helper
  • disabling web broswser code signature check
  • disabling Kaspersky antivirus and Defender (both latest versions)
  • uninstall + clean install of 1password
  • enabling file url access for the extension in chrome
  • looking at event logs - nothing useful there

I have attached the diagnostics report, had to rename from zip to jpg since not allowed otherwise.

1Password Version:
Extension Version:
OS Version: Windows 10 64bit
Sync Type: none


  • It seems that on my laptop the 1password extension can not connect to any websocket server + nothing from browser can connect to the helper websocket server

    I created a simple websocket server (node-js) running on port 6263.
    On my laptop and on the pc, a websocket connection from a file:/// page to websocket server (with helper shut down) worked fine
    Thu Dec 31 2015 16:32:27 GMT+0100 (Romance Standard Time) Server is listening on port 6263 origin: file:// Thu Dec 31 2015 16:34:51 GMT+0100 (Romance Standard Time) Connection accepted.
    origin: null Thu Dec 31 2015 16:49:42 GMT+0100 (Romance Standard Time) Connection accepted.

    While still not running 1password helper process, started browser instances to see if they try to connect via 1password extension.
    1. on my PC. this caused the 1password extension to connect to the websocket server
    Thu Dec 31 2015 16:32:27 GMT+0100 (Romance Standard Time) Server is listening on port 6263 origin: chrome-extension://aomjjhallfgjeglblehebfpbcfeobpgk Thu Dec 31 2015 17:41:50 GMT+0200 (FLE Standard Time) Connection accepted. Received Message: {"action":"hello","number":10,"version":"4","bundleId":"","payload":{"version":"","capabilities":["NextGenFillItem","Synapse","O"]}}
    origin: resource://onepassword4-at-agilebits-dot-com Thu Dec 31 2015 17:47:07 GMT+0200 (FLE Standard Time) Connection accepted. Received Message: {"action":"hello","number":2,"version":"4","bundleId":"org.mozilla.firefox","payload":{"version":"4.5.1","capabilities":["NextGenFillItem","Synapse","O"]}}
    2. on my laptop, there was no connection from 1password extension nor from firefox nor chrome, the background page of the extension shows that it is indeed trying to connect to all the ports including 6263 and failing on all

    I also tried to connect via websockets to the 1password helper from a file:/// page.
    1. on my pc, the connection worked when 1password helper was running and not working when not running (as expected)
    2. on my laptop, the connection did not work at all, strange that connecting to ws://localhost I am getting
    WebSocket connection to 'ws://localhost:6263/4' failed: Error in connection establishment: net::ERR_CONNECTION_REFUSED
    and when to ws://
    WebSocket connection to 'ws://' failed: Error in connection establishment: net::ERR_NETWORK_ACCESS_DENIED
    (different error code, on the PC the error code is the same)

  • Hi @girtsn,

    Can you send in a fresh diagnostic report to [email protected] please. The forums are public and so your diagnostic report has been removed. By emailing the report it will also be directed to people I think better suited to diagnosing the issue.

    Cases like this are almost invariably related to some sort of third party security but I see that you've tried disabling them already. Do they have any sort of extension based component that is installed in the browser that might be interfering? Either way, I'm hoping the people more knowledgeable about 1Password for Windows can assist here. I hope we can get this resolved for you :smile:

  • sent to e-mail. I tried to disable all extensions, no luck

  • LauraRLauraR

    Team Member

    @girtsn - Thank you for sending the diagnostics report. We will reply to you via email.

    ref: JPV-84189-189

  • At the end it was Kaspersky, even with everything disabled...

  • Greetings @girtsn,

    Thanks for reporting back and seriously, what on earth? These programs are meant to help keep our machines secure, not impede us from using them. At least we found the source of the issue :smile:

This discussion has been closed.