1Password doesn't work on one site

My credit union have just changed their web site. Previously 1Password worked perfectly, but now it won't enter member number. See attached file. I have contacted the credit union and so far no help. Please advise.

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: forum-search:I asked a question some days ago. Unable to give details because of constraints in length of questio


  • 1Password version is 3.8.22.
    Extension version is
    OS 10.11.2

  • @Bob_Huxtable as your post relates to 1P3 for Mac I have moved the post from the 1Password for Mac forum to the 1P3 legacy forum where you will get more help.

    While it may not be relevant to your immediate problem you ought to start by reading this sticky at the top of the forum—because there are known problems trying to run this rather old version of 1Password on OS X 10.11.


  • brentybrenty

    Team Member

    @Bob_Huxtable: Thanks for letting us know which versions you're using! Unfortunately without knowing the URL you're having trouble with, it's impossible for us to test it. While 1Password 3 will not be updated, it's possible that there may be a workaround we can suggest if you can tell us. Thanks in advance! :)

  • MeganMegan

    Team Member

    Hi @Bob_Huxtable,

    Thanks so much for following up with that URL. When websites get a shiny new update, there are often changes to the code of the site itself as well. Changes like this can affect 1Password's filling. (If they rename the field labels, for example.)

    The first step here is to save a new Login manually. The good news is that I just created a new Login for this site, and 1Password can fill correctly. (I tested using 1Password 6, but 1Password 3 should be able to manage this as well.)

    Let's try this:

    • Edit the login that you currently have for this website by appending an "Old" to the title.
    • Visit the credit union's site and fill the login form. Don't click the login button, just yet.
    • Click the 1Password extension, and unlock it if necessary
    • Click the + button in the corner.
    • Give the entry a unique and identifiable title.
    • Click Save.
    • Reload the page and see if 1Password fills in the site correctly.

    That should get you all sorted out, but if you have any further questions or concerns, we're here for you!

  • Thanks Megan, but it still doesn't work. After the + button, the user name field was blank, but the password field was filled. So I typed in the user name. Then did as you suggest, and it didn't work. Just as before, the member number was blank. Any ideas?

  • MeganMegan

    Team Member

    Hi @Bob_Huxtable,

    I'm sorry to hear that this is still giving you trouble. I'm not quite sure I understand where things got tangled up there. Did you type in both your member number and your password before using the + button to save a new entry? It's important that you manually fill in your information on the site, and not use 1Password to fill. Our goal here is to give 1Password a fresh start and let it re-learn the fields that it needs to fill.

  • Hello Megan, I manually typed in my user name, and pasted in my password, because it is long and complicated. And this was before using the + button. 1Password enters the password ok but doesn't enter the user name. So it doesn't seem to be a problem pasting in the password. I have tried at least twice with no success. Also when I type in my user name and get on to the web site, 1Password doesn't prompt me to save, as it normally does with other new sites.

  • Greetings @Bob_Huxtable,

    The cause of this behaviour seems to be the use of the type tel for the username field. Normally we'd expect to see a field of type text for usernames but what they've done is switch it to a tel type, I assume because they're asking for a member number and it should just contain numbers (although alphabetical characters can be typed in). If I altered the underlying page by changing it to a text field 1Password 3 would then fill both fields.

    What it means is there isn't a way that I can see to have 1Password 3 for Mac to fill this page right now. As 1Password 3 is a legacy version it also isn't receiving updates meaning the situation won't change. 1Password 6 has something called fill by HTML attribute which would fill this field but I don't know if you're running a version of OS X that supports it (Yosemite or El Capitan).

    Sorry I wasn't able to bring better news but the presence of the tel field seems to be the blocker here.

This discussion has been closed.