Renamed Vaults not propagating name change to devices

Hi,

I have created a work vault in teams, but then changed the name to the name of my company instead. Unless I remove and re-add teams the vault name change (and icon updates!) don't propagate down to the devices.

I wonder if this was something that you didn't consider might need syncing? The items within the vaults sync fine enough, just not the vault names and icons themselves.

Thanks,
Tom


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • JacobJacob

    Team Member

    Hi @smallcheese! They should be... Could you try switching to a different vault, then switching back and seeing if the changes appear then? I'd also suggest simply locking and unlocking the app. If that doesn't work, what app version are you having issues with?

  • switched vaults multiple times and restarted the app many times too as renamed the vault weeks ago. I'll grab the versions tomorrow.

  • Hey,

    Sorry for the brevity on the last post, had issues with the fancy daft keyboard on my iPhone.

    So the version on the iPhone is 621003 and it still hasn't updated the vault names. I noticed the same on my girlfriend's iPhone who has the prod release of the app, but i haven't checked on her devices recently. I did notice it come through fine on her new Mac which matches my experience - if added from fresh it's fine.

    Thanks,
    Tom

  • JacobJacob

    Team Member

    @smallcheese Thanks for the update. Could you try renaming the vault once more in the web interface? Let us know if that change shows up in the iPhone app.

  • I've just renamed the vault and it stayed the same on the iPhone. I then updated the name of one of the items in the vault and it was immediately visible on the iPhone.

  • JacobJacob

    Team Member

    @smallcheese Good to know. I've forwarded that feedback to our development team so they can have a look at things and figure out what may be happening. We'll let you know if we need you to test things out. Thanks again!

  • I ddition, since coming back to my iPad I've noticed that the name change on the vault hasn't been progagated there either, so I think it's only happening when I link the teams account for the first time on the device.

  • Further update - this works fine on the Mac - the temporary vault name change I made earlier has propagated.

  • Good morning. You'll probably not be surprised to know that the new vault name changes introduced in the latest beta haven't propagated to my iPhone or iPad.

  • roustemroustem AgileBits Founder

    Team Member

    @smallcheese This is expected. The name changes for these two special vaults will require a new version of the iOS app. We hope to get them out soon.

  • Ok thanks. Is someone still looking into why I'm not seeing my own Vault name changes propagate on the iOS apps? Or is this the same issue?

  • roustemroustem AgileBits Founder

    Team Member

    It seems that like a bug on our side.

    Are you able to see the item changes being propagated successfully?

  • roustemroustem AgileBits Founder

    Team Member

    It is certainly a bug on in the iOS app.

    It was fixed on Mac but the iOS app didn't get the fix yet. It will be available in the next update.

  • Ok awesome, great to hear. Yep, the item changes are immediately reflected, but the vault name and icon changes are never reflected.

  • JacobJacob

    Team Member

    :+1: Thanks again for getting in touch about it.

  • @roustem

    It was fixed on Mac but the iOS app didn't get the fix yet. It will be available in the next update.

    I guess you must have meant the one after the next update! ;)

  • JacobJacob

    Team Member

    @smallcheese The next stable version of 1Password for iOS. ;)

  • Do we honestly need to wait until a new full release for a fix on this? Another beta today where this is still a problem sadly :(

  • brentybrenty

    Team Member

    Unfortunately it won't be available until it's released on the App Store. I can't say for certain when. I think generally even approvals take at least a week, after all. ;)

  • You're not going to fix this problem in an upcoming beta at all? I don't follow why you would leave it until the full release, and have it potentially not work exactly as intended.

    For clarity, I'm talking about the originally reported problem where Vault name and icon changes are not propagating to IOS devices. The newest beta has renamed my "Your Vault" and "Everyone" vaults to Personal and Shared, but my own vault name and icon changes are not synced to IOS devices.

  • robrob Agile Customer Care

    Team Member

    @smallcheese sorry for the miscommunication here. We fixed the issue for both Mac and iOS at the same time, so theoretically it should have been in the last beta of 1Password for iOS, yes. However, the iOS app hadn't merged in the shared code fix yet, so it kept doing new builds without it.

    I've checked with the developers, and we'll get it pulled into the iOS app code soon, hopefully for the next beta, but it will definitely be in a beta before it's in the App Store.

    Thanks for keeping us on our toes! :)

  • brentybrenty

    Team Member

    @smallcheese: Indeed. It sounded like you were expecting an immediate update for the iOS app, and I wanted to make it clear that it would need to be released first. I wasn't assuming that you were using the beta (since most folks only have access to the stable App Store updates), and a final release does require approval after all. I apologize for any confusion I may have caused. :blush:

  • brentybrenty

    Team Member

    ..if, however, you're part of the 1Password for iOS beta, the latest release (minutes ago) addresses this issue. Hopefully we can finish testing and get this out to everyone Soon™. Cheers! :pirate:

  • I can confirm that the name change and icon for my additional vault is now propagating through, but the icons added for the personal and shared vaults which show up in the teams web app are not showing in iOS still. Should they be?

  • robrob Agile Customer Care

    Team Member

    Hmm, we'll have to look into that, @smallcheese. I've made a note in our issue tracker, thanks!

    ref: OPB-745

This discussion has been closed.