Unable to set up Dropbox sync - errors messages in log

Drew_AGDrew_AG 1Password Alumni
This discussion was created from comments split from: Cannot select Dropbox Sync for Primary Vault.

Comments

  • Hi,

    I have the same problem, here is the log message from the console:
    0x7f865c567f00):] E handleXPCError: | Problem talking to the helper: Error Domain=NSCocoaErrorDomain Code=4097 "connection to service named 2BUA8C4S2C.com.agilebits.onepassword4-helper" UserInfo={NSDebugDescription=connection to service named 2BUA8C4S2C.com.agilebits.onepassword4-helper}

  • Drew_AGDrew_AG 1Password Alumni

    Hi @lior86,

    I'm sorry you're also having trouble setting up Dropbox sync!

    Just to make sure we're on the same page: The others in this thread were having a problem where they were trying to enable Dropbox sync for a vault in 1Password, but when they chose the Dropbox option and selected an existing sync file in the Dropbox folder, they saw a greyed-out 'Continue' button and were unable to complete the setup. Is that the same thing that is happening with 1Password on your Mac? If so, it will help if you can let us know a few more details:

    • What version of Mac OS X are you running?
    • What version of the 1Password app is installed on your Mac?
    • Are you using the AgileBits Store version or the Mac App Store version of 1Password?
    • What is the name of the sync file in Dropbox you're trying to sync with your vault in 1Password? (It should have a ".opvault" or ".agilekeychain" file extension.)
    • Is this happening during the setup of 1Password on a new/different Mac, or was it already set up and you're trying to re-enable Dropbox sync between your vault and that sync file in Dropbox?
    • What happens if you try this suggestion from littlebobbytables' first response in this thread:

    If you select Dropbox sync and point 1Password to a folder that contains no Agile Keychains at all does the button change from Continue to Create New or does it follow past behaviour where it doesn't change?

    Thanks in advance! :)

  • No I have different problem, the continue button is enabled, but when I pressed on it I see the Log message in console(everytime I click on it) .

    OS X: 10.11.1
    1Password: 6.0.2
    I'm using AgileBits Store version
    Name of the file: 1Password.agilekeychain
    It happened after an Update.
    I didn't tried littlebobbytables suggestion yet, I will try later and give you an update.

    10x

  • Drew_AGDrew_AG 1Password Alumni

    Hi @lior86,

    Thanks for the clarification! Since you're having a different problem than the one from the previous thread, I've moved your messages to a separate discussion. I hope you don't mind!

    The problem you've described seems very unusual, because when setting up Dropbox sync for a vault, once you select a location or existing sync file in your Dropbox folder, the 'Continue' button should change to a 'Create New' or 'Merge with Existing' button. The problem in the previous thread was that those users were still seeing the 'Continue' button, although it was still greyed out. In your case, it sounds like that button looks like it can be clicked on, but doing so generates those errors in the log. Does anything else happen in the 1Password app when you click Continue, or are the console messages the only indication that you clicked a button?

    Do you have all your latest 1Password data in the 1Password app on that Mac? Or does the 1Password.agilekeychain file in Dropbox contain newer data that needs to be synced to your Mac? Also, are you syncing that vault with 1Password on any other devices? If so, what devices, and what version(s) of 1Password?

    In addition to the answers to those questions, please let us know how it goes when trying littlebobbytables' suggestion (i.e. select a different location in Dropbox that doesn't have any existing .agilekeychain or .opvault files). That should help us to figure out what's going on. Thanks! :)

  • lior86lior86
    edited February 2016

    Yes the log is the only indication for the button click.
    I did tried littlebobbytables solution and it work, but my 1password is on 2 different computers, on both I updated to the latest version, and on my other computer I have new data which I want to sync to the main computer.
    By the way on the other computer everything is working great, but the os version is 10.11.3.

    P.S
    I have 1password installed on android lg2, but I never used it to add data, just to retrieve data.

  • Drew_AGDrew_AG 1Password Alumni

    Thanks @lior86! On the Mac where you're having this problem, can you please try these steps:

    • Open 1Password (unlock with your master password if necessary) and go to 1Password > Preferences > Sync.
    • Change the sync setting from None to Dropbox.
    • Click the Choose button and select a folder in Dropbox that contains no .agilekeychain or .opvault files at all (then click Open).
    • Click Create New to create a new sync file in that folder.
    • Change the sync from Dropbox back to None.
    • Click the box to Delete data from Dropbox, then click Disable Sync.
    • Hold down the control key and choose 1Password > Quit 1Password and 1Password mini from the menu bar (or use the ⌃⌘Q (Control+Command+Q) keyboard shortcut).
    • Reopen the 1Password app and go back to Preferences > Sync.
    • Change the sync from None back to Dropbox.
    • Click the Choose button, then select your original/existing sync file from its usual location in Dropbox (and click Open).

    Hopefully you will see a Merge with Existing button at this point - if so, click that to start syncing. Please let us know how it all goes! If you still end up with a non-functional 'Continue' button, we'll try something else. :)

  • Same thing, the continue button is enabled(clickable) but I get no response.

  • Hi @lior86,

    Please bear with me, I'm new to this conversation and bringing myself up to speed.

    It looks like Drew just had you create a brand new Agile Keychain in a previously unused location (so you got the Create New button) before disabling sync and attempting to connect to the original and true Agile Keychain that you need 1Password to connect to so your two Macs sync. It seems as if you're saying you could create the new Agile Keychain and again, it's any time you try to connect to the existing Agile Keychain that it fails.

    Here is what I would like to try if you don't mind. Your vault isn't the Agile Keychain like it used to be in 1Password 3 for Mac. Instead the Agile Keychain has been relegated to the role of sync container and your vault(s) are stored locally inside an encrypted SQLite database file. What this means is we can completely delete the potentially problematic Agile Keychain and create a brand new one that with a little luck both Macs are willing to connect to. Here is what I recommend trying.

    For clarity I'm going to refer to the behaving Mac by 10.11.3 and the misbehaving Mac by 10.11.1 - I hope that works for you.

    1. Launch 1Password for Mac on the 10.11.3 Mac.
    2. If you're running 1Password 6 for Mac on this machine, check to see if the option Enable OPVault for Dropbox and Folder sync is enabled. You can do this by looking in the Help > Tools submenu. You want this disabled so if it's enabled select the option to disable. As you are using 1Password for Android you want 1Password to create an Agile Keychain.
    3. Use the menu option File > Backup (safety nets are never bad).
    4. Switch to the Sync tab and change the menu option from Dropbox to None.
    5. In the confirmation window tick the checkbox titled Delete data from Dropbox and click the Disable Sync button. Don't worry, it only delete the specific sync container sync refers to, not data in general.
    6. Pause for a moment to let Dropbox synchronise the deletion.
    7. Change the sync menu option back to Dropbox and point 1Password to the same folder you stored your old Agile Keychain in.
    8. The button should read Create New and when clicked allow you to create a brand new Agile Keychain.
    9. Pause for a moment to let Dropbox synchronise the new Agile Keychain.
    10. Launch 1Password for Mac on the 10.11.1 Mac.
    11. If you now try to select this brand new Agile Keychain when setting up sync does this copy of 1Password for Mac still show the Continue button or does it finally behave and change to saying Merge with Existing?

    The premise I'm working under is that there is some small, hidden and unknown aspect to the original Agile Keychain that is causing 1Password to throw a fit. The cause is unknown but I'm hoping a brand new Agile Keychain allows us to circumnavigate around it.

    How do you feel about this idea and do you feel comfortable with the steps I've outlined?

  • @littlebobbytables Thank you for your help, it worked :chuffed:

  • Drew_AGDrew_AG 1Password Alumni

    On behalf of littlebobbytables, you're very welcome! I'm really happy to hear that worked and you're able to sync correctly now. Hopefully it all continues to work correctly for you from now on, but if you ever run into problems again or just have some questions, please don't hesitate to let us know. We're here for you! :)

This discussion has been closed.