1Password 6.0.2 hangs after entering master password

When using both the menu bar 1Password mini interface and the "command + \" hotkey within Chrome, the 1Password dialog tends to hang for upwards of 10 seconds after entering the master password before responding, eventually showing the spinning beachball momentarily. The chrome extension I have installed is v4.5.3.90. Any suggestions?


1Password Version: 6.0.2
Extension Version: 4.5.3.90
OS Version: 10.11.3
Sync Type: Dropbox for Business
Referrer: kb-search:1password hangs

«1

Comments

  • That's happening to me as well. Also using Chrome, running on Mac OS X Yosemite (up to date), 1 Password 6.0.2, Extension 4.5.3.90. Sometimes it takes a full minute before it comes back, but usually 5-10 seconds.

  • That's happening to me as well. Also using Chrome, running on Mac OS X Yosemite (up to date), 1 Password 6.0.2, Extension 4.5.3.90. Sometimes it takes a full minute before it comes back, but usually 5-10 seconds.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @hifirestone and @donbkatz,

    I'm sorry the 1Password extension / 1Password mini is having some trouble!

    To make sure we understand, can you please let us know a few more details about your setup and about the problem:

    • Are you using the Mac App Store or AgileBits Store version of 1Password 6 for Mac?
    • When you try to open the 1Password extension, does it eventually work after the delay? If not, what happens after those 5-10 seconds?
    • Have you tried using the 1Password extension in Safari or Firefox to see if the same thing happens?
    • Does the same problem happen if you click the 1Password mini icon in your Mac's menubar?
    • Do you have any trouble opening & unlocking the main 1Password app?
    • How long has this problem been happening? Did it seem to start after a certain update?
    • If you restart your Mac, does it make any difference?

    Thanks in advance! :)

  • Drew, Thanks for the response. i'll try to address all of your questions.

    • Mac App Store version.
    • Yes, it always works after the delay.
    • I have tried it in Firefox (via hotkey) and the same issue occurs.
    • The same thing does tend to happen on the 1Password mini icon. I'm not sure if it's 100% percent of the time.
    • This has been happening for just a couple weeks probably. I did update quite recently to the new version, I think.
    • A restart did not fix the issue.

    Thanks!

  • Hi Drew,

    • I am using the AgileBits Store version.
    • Yes, after the delay it works fine for me also (the delay this morning was 20 seconds)
    • Yes, same problem in Safari (tried it just now, 32 second delay)
    • It started with the update to 6.0.2 I think.
    • The 1Password app unlocks immediately.
    • If the 1Password app is visible and locked my second monitor, and I enter the unlock code in the browser extension, the app unlocks immediately, but the browser extension is unusable for 10-30 seconds afterwards.
    • The 1Password mini icon in the menu bar has the same behavior as the browser extension - when I enter the password, the app unlocks immediately, but the mini icon drop down still shows the lock symbol (it turns from horizontal to vertical then hangs) for 10-30 seconds.

    D

  • I have the exact same issue.

    • Mac App Store Version 6.0.2 (602005)
    • Yes, the extension works after the delay (which varies from probably 5-20 seconds. I just tried it, and it was 16 seconds). Once unlocked, the extension is fast as usual. There is no delay if I mistype my master password; the delay happens after my password is accepted but before the extension changes away from the enter password screen.
    • I've had the same issue in Safari 9.0.3 (11601.4.4) (my regular browser) and Chrome.
    • Same behavior with the mini icon in the menu bar.
    • In the app, it unlocks immediately. However, if I unlock in the app and then go immediately to the browser, the extension does not work immediately. If I click the 1Password icon in Safari, nothing happens at all. Then after maybe 10 seconds, the 1Password extension panel opens in an apparently-random place on my screen. Then it works eventually, after roughly the same 5-20 seconds as it takes to be able to use the browser extension when I unlock from within it.
    • This has been happening for a while now; my guess is a few weeks. In that time, I'm pretty sure I've upgraded from Mac OS X El Capitan 10.11.2 to 10.11.3 (ie had the issue both before and after the OS upgrade). I can't say if it was with the 6.0.2 1Password upgrade that the issue started, but that's entirely possible.
    • Restarting the Mac does not fix the issue.
    • I'm running on a Mid 2014 13-inch Mac Book Pro with Retina display.
  • ag_kevinag_kevin Junior Member

    Team Member

    Hi @Alex Hill , @donbkatz , @hifirestone ,

    First of all, I'm sorry you are having trouble with this. We believe we know the cause.

    Can I ask, are you all syncing to Dropbox or Folder Sync using the opvault format? To check, look in your Dropbox or Folder Sync folder for the 1Password file. If it ends with .opvault then you are using that format. If so, there is a known issue where in some cases it can hang. We have a fix for this in beta right now and will be releasing an update soon.

    If you are using the agilekeychain format, please let me know and we can investigate further.

    Regards,
    Kevin

  • Alex HillAlex Hill
    edited February 2016

    Hi @ag_kevin

    I'm using iCloud to sync my keychain. I briefly used Dropbox in the past (in October-November 2014, when the AgileBits Store version stopped being able to support iCloud with Mac OS 10.10 and 1Password 5, before I switched to the Mac App Store version of 1Password) but have been using iCloud since roughly November or December of 2014, as well as before I upgraded to OS X 10.10.

    My understanding from this article is that the fact that I'm using iCloud means that I'm using opvault, but I don't know how (or if it's possible) to check that.

  • @ag_kevin, my vault appears to be in the agilekeychain format.

  • rickfillionrickfillion Junior Member

    Team Member

    For those of you who are experiencing this problem...

    If the mini becomes responsive after a period of time, then the issue is not one that we've been looking at and fixing as part of the next release. If mini never becomes responsive again, then you're probably hitting the problem that we fixed. Let us know and we can help you get setup with the beta so that you can have access to your data.

    For those of you where mini does in fact come back and behave... here's what I'd like from those of you who are having this issue:

    • Launch Activity Monitor from /Application/Utilities
    • Search for '1Password' in the top right search field
    • Select 1Password mini in the list
    • Unlock mini in such a way that mini would lock up
    • Switch back to Activity Monitor, and click the toolbar button that looks like a gear and has a downward arrow
    • Select 'Sample Process'
    • Activity Monitor will bring up a window and it'll do its thing for a few seconds. It'll create a report, and this window will have a 'Save...' button in the upper right of the window
    • Email the saved report to [email protected]

    The sample file it creates will give us a rough idea of what the app is up to during this time. We'll take a look at them and try to figure out what's going on.

    Thanks

    Rick

  • Thanks, @rickfillion. Yes, mini does become responsive after 9-27 seconds (in the times I've timed it). I've emailed you the sample process output.

  • rickfillionrickfillion Junior Member

    Team Member

    Thanks @Alex Hill.

    I've gotten a couple samples so far. The more the merrier! :)

    Rick

  • Hmm; I just saw this thread which suggested restarting 1Password Mini from the main 1Password program. That did indeed fix the issue for me, at least for now; immediately after restarting 1Password Mini, I went to unlock 1Password in 1Password Mini and Mini was available immediately; no delay.

    As I noted before, I have rebooted the machine multiple times and this issue has remained, but I'm pretty sure I hadn't restarted 1Password Mini like this.

  • brentybrenty

    Team Member

    Thanks for confirming! Hopefully you won't run into further issues, but if you do we're here for you. :)

  • Having the same issue with mini hanging/freezes but then login in after a few seconds.

    • Mac App Store Version 6.0.2 (602004)
    • Chrome Version 48.0.2564.116 (64-bit), Extension version 4.5.3.90
    • Dropbox sync, with .agilekeychain format
    • Yosemite 10.10.5
  • Drew_AGDrew_AG 1Password Alumni

    Hi @stomgb,

    I'm sorry you're also having this problem!

    Our developers have recently been looking into issues that sound similar to what you described, and I believe our update for version 6.1 might help with some of those, but I don't know for sure if it addresses the specific issue you're experiencing. We've submitted 6.1 to Apple, so hopefully that will be approved and available soon so you can update to see if it helps.

    In the meantime, have you tried restarting 1Password mini to see if that makes a difference? From the main 1Password app, go to Help > Troubleshooting > Restart 1Password mini. After that, do you still run into the same problem? If so, please also reboot your Mac, and after it restarts, try mini again.

    Please let us know how it goes, and if it's still a problem, we'll continue from there. Thanks! :)

  • I've just updated to 1Password 6 Version 6.1 (610005) AgileBits Store and the problem went away. Logging in to Mini and the app is normal again. Great job!!

  • brentybrenty

    Team Member

    Excellent! Thanks for the update. I actually just came here to mention that I'd just gotten the update from the App Store myself! I'm glad to hear that all is well. It sounds like you should be all set, but don't hesitate to reach out if we can be of further assistance. We're always here to help! :)

  • @brenty I wanted to let you know that it also went away for me but the problem has slowly creeped back. At first just a quick delay, then a couple seconds, then about 4-5 and now it's back to about 9-10 second delay. All of the same scenarios as before. I'm running 1Password 6 Version 6.1 (610005). I also find that the 1Password mini menubar icon will "depress" and turn blue without having the dropdown come down sometimes. I have to click out and try again for it come up, but it's not always successful.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @hifirestone,

    I'm sorry the problem with the delay came back again! Our developers have been looking into this issue and trying to solve it. For now, restarting 1Password mini seems to help, at least temporarily: From the main 1Password app, go to Help > Troubleshooting > Restart 1Password mini. After doing that, does the delay happen again right away, or does it seem to be speedier? As I mentioned, it's a temporary workaround, so the problem might come back again. Hopefully our developers will squash this bug soon! :)

  • Restarting 1Password mini seems to rectify it. I will see it if it temporary or permanent, like you mentioned. Thanks.

  • brentybrenty

    Team Member

    Thanks for your patience and willingness to work with us on this. The development team is working on finding a more permanent fix, but I'm glad to hear that restarting mini is working for you in the mean time!

  • I am afraid I am having this very same problem with 1Password 6.1. It's really annoying. Is there anything I can help you with to get this debugged?

  • Hello @ericb80,

    My understanding is, that we've added more logging into our current beta of 1Password 6.2. If you're interested what you would need to do is the following.

    1. Update to the beta. If you're an AgileBits Store user this should be as simple as opening 1Password's preferences and switching to the Updates tab. In there tick the checkbox titled Include beta builds and then click the Check Now button.
    2. Use 1Password as you normally do after this and wait for the issue to reappear.
    3. Once the issue has returned you would create a diagnostic report, this guide will help and send it in.

    What is important is waiting for the issue to reappear after installing the beta version because only it is creating the extra log entries that the developers are hoping will identify the cause. Given the issue seems to occur over time you may want to not let 1Password update until the issue has occurred as if it's related to 1Password running for a while each update will be a completely new start of 1Password and so the issue could be masked by the updating.

    I know the developers would love to learn anything they can to find this issue and get it fixed as it's frustrating them as much as it is all of us as the users.

  • Hi. The issue has resurfaced again. I just sent you a diagnostics report. Cheers

  • rudyrudy

    Team Member

    Hi @ericb80,

    can you confirm that you're running the release version of 6.2?

    Rudy

  • ericb80ericb80
    edited April 2016

    Hi @rudy

    I am using Version 6.3.BETA-2 (630002), as I was instructed to use the latest beta build. Hope that helps.

    Eric

    ref: ERL-75869-115

  • rudyrudy

    Team Member

    Hi @ericb80,

    Thanks, it does!

    Rudy

  • Hi @rudy,

    I want to add the the issue has slowly resurfaced for me, now using 1Password 6.2.1 (621001, Mac App Store). Once again, I have fixed it (once it got to about 4-5 seconds for 1Password to unlock with 1Password Mini) with Help > Troubleshooting > Restart 1Password mini. Of course, it's not a big deal to have to do that once every 2 months or so now that I know the temporary fix.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @Alex Hill,

    I'm sorry to hear the problem started happening again! But that seems to be consistent with what other customers have reported - after restarting 1Password mini, the problem may start again after several days (or even weeks). The time it takes for the problem to start again is part of the reason this issue has been difficult for our developers to track down and solve.

    If you'd like to help our developers, you can try the latest beta version of 1Password, which has additional logging that will hopefully help to figure out why this happens. But since you're using the Mac App Store version, there are a couple extra steps involved in switching to the beta, as that also means switching to the AgileBits Store version of the app (although you'd be able to switch back to the Mac App Store version later if you want). If you're interested in doing that, please let us know and we'll explain what you'd need to do.

    Again, I apologize for the inconvenience!

This discussion has been closed.