Auto submitting AND filling in identities

G'day guys....I'm not needing a fix...but just letting you know:

Since a recent update (can't remember exactly when it started), I'm finding many more sites that won't submit even when I have asked them to. I've read the articles, but my extension seems to be up to date, and I've set the preferences on 1Password to 'submit'.

Also, noticed that identities won't fill on the first click, but they often will on the second click.

Thanks--couldn't live without 1Password...and your support is awesome!


1Password Version: 1Password 6 Version 6.0.2 (602004) AgileBits Store
Extension Version:
OS Version: 10.10.5
Sync Type: dropbox


  • dancodanco Senior Member Community Moderator

    I have noticed that problem with identities at times also.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Hi, @Babbling and @danco. Thanks for your posts. If you're having trouble with identity filling, you've come to the right place. The most important thing to understand is if it happens on every site, which would indicate a more systemic problem perhaps with the connection to 1Password mini, or if it is happening only on a few pages. If it's just a few, it would be super helpful if you could send along the URLs and any instructions for getting to the identity form (add something to cart and click checkout, for instance) so we can test things out.

    As for autosubmit, we had a bug recently where 1Password wasn't properly reflecting the true state of the user's autosubmit preference. To make sure it's properly set, could you uncheck the preference in 1Password > Preferences > Browser, restart your Mac to make sure everything is running from a clean state, and then re-enable the preference? You might be prompted to allow 1Password to create an script for you. It's a one-liner that simply says, tell application "System Events" to keystroke return, which means for the system to simulate you pressing the enter key. The extension puts the focus in the password field and then tells 1Password to run this script. This is by far the single most reliable approach to submitting logins that we have found.

    If that is not the issue, it would be helpful, again, to know whether this is happening on every site or just a few and if it's just a few, the URLs where we could test would be great.

    I hope this helps!

    Jamie Phelps
    Code Wrangler @ AgileBits

  • Thanks Jamie. I'll run the fix you recommend and then keep an eye on things. I'll post stuff here as I come across it.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    That sounds good, @Babbling! You know where to find us if you have any other questions or issues. :chuffed:

    Jamie Phelps
    Code Wrangler @ AgileBits

  • Probably not adding a lot to the discussion but...

    I have a website that wouldn't submit. But then I thought I would try deleting my login and create a new one. And now it works.

    So maybe I'll try that with some of the ones that aren't working for me now.

  • Hmmm...Can't work out any consistent pattern. Deleting and recreating only worked the once. And then (ironically) this 1Password forum also wouldn't submit. So then I unchecked the "Automatically submit" on 1Password. Quit 1 Password, reopened it, reset to auto. Then used the 1Password mini to open and both sites worked OK.

  • Spoke to early...the new one stopped working as soon as I closed and re-started Chrome.

    The website is:

    It will not submit even though I have told it to.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @Babbling I just tested and in Chrome, it submitted the login just fine, so perhaps there's something else going on…

    When you have this failed autosubmit, are you using the keyboard shortcut to fill? If so, could you let us know what your keyboard shortcut settings are in 1Password > Preferences > General? @nathanvf and I recently worked together on a bug that affected an obscure feature of 1Password where if you have the option key pressed when you choose a login for filling, it will temporarily toggle the submit setting.

    So, if you have it set to autosubmit but for some reason you don't want it to submit when you're logging in this one time, you can press the option key while you choose the login from the list in the browser extension popup. But, if you're using the "Fill Login on current web page" and that keyboard shortcut uses the option key, it could be toggling it for you inadvertently.

    Let us know if I'm on the right track. :)

  • Thanks Jamie.

    I don't think it's a 1Password problem per se. But some sort of interaction with Chrome, maybe??

    (it's not the option key thing) I only use 1Password mini.

    Here is what I do:

    I will open a Chrome window
    Click on the 1Password mini icon
    Enter my password (set to ask for it every 5 mins of idle time)
    Type in the login in the search box
    Hit enter
    Chrome opens a new tab
    1Password enters password
    I wait (and hope!) for it to submit. If not, then I manual submit by clicking the relevant button on the webpage.

    But, sometimes (maybe 50% or more) it doesn't submit.

    All I've noticed so far....seems to work fine early in the day (after a restart overnight) or after I've quit Chrome and re-started it. I can't be certain about this (will test it over the next few days).

    I do change my Chrome Identity from work (at work) to home (at home) so maybe this is part of the problem??

    Here are the extensions I use on Chrome (maybe there is some issue here?)

    • 1Password
    • Adblock Plus 1.10.1
    • Gmail Offline Sync Optimiser 6.5
    • Google Docs 0.9
    • Google Docs Offline 1.1
    • Google Sheets 1.1
    • Google Slides 0.9
    • Google Voice Search Hotword (Beta) (never used this so I might just delete it)
    • Search by Image (by Google) 1.5.1

    Will let you know what I discover.

    Thanks again.

  • Finally...I can report something that I can reproduce. I opened this website from my email client (Apple Mail 8.2 (2014)):

    When I go to enter my identity using 1Password mini in Chrome, nothing happens. When I do it a second time, it fills.

    If I open the webpage by copying and pasting the URL it fills the first time.


  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @Babbling Thanks for that additional information. Can you let us know if Chrome was running when you opened that link from Mail or did it need to start up fresh? If it needed to start up fresh, it's possible the connection to 1Password itself wasn't yet established.

    I just tested this with Chrome needing a fresh launch and I was still able to fill an identity there, so maybe this is a red herring.

    When you are able to reproduce the issue, do you see a executeFillScript line show up in 1Password's logs in You can find in your /Applications/Utilities folder. Select All Messages and type executeFillScript in the Filter box to see these messages.


This discussion has been closed.