1Password fails with two forms on the same site

When a site contains two forms (e.g. sign-up and login) only the first form is filled in. That however is the wrong form in about 50% of the cases.

An example you can find here: http://www.pronunciationworkshop.com/account/login

This page has the additional complication, that the password field has the same name attribute in both forms.

I can think of two possible solutions:
1) Require the cursor to be in one of the forms on pages with multiple forms. Then fill in (and potentially submit) only that form.
2) Fill in all forms and disable auto submit, if the page contains more than one form.

Both solutions could be restricted to only pages, that contain more than one form with a password field.

As it currently stands, 1Password is unusable on those pages.

1Password Version: 6.0.2
Extension Version: (Chrome)
OS Version: OS X 10.11.3
Sync Type: Not Provided


  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @mbt1 Thanks for this report. I was able to reproduce the issue you reported. Even after saving a login in the Customer Login form, the fill operation happened in the Create Account form. I'm opening a bug report about this and hopefully we'll be able to investigate soon. I'm sorry I don't have a better answer for you right now.

    Jamie Phelps
    Code Wrangler @ AgileBits

    ref: BRAIN-98

  • I am bothered by this behavior, too, and I came here to suggest strategy #1 from mbt1's comment, but I was going to add that it can keep the existing behavior of filling in all the fields (which is what it currently does) if no form has focus, for those who like that behavior.

    Also, does adding the star/bookmark subscribe me to notifications on this bug?

  • brentybrenty

    Team Member

    @mdaniel: Thanks for the feedback! Hopefully we'll be able to find a solution for login/signup combo forms, but it is tricky since they're all different! In some cases 1Password is successful even. :dizzy:

    Regarding updates this discussion, it depends on your notification settings. By default, you should get a notification for any discussion you've participated in (like this one). But if you've disabled that, starring/bookmarking this discussion will notify you of new comments (provided you don't turn off notifications for those as well). Cheers! :)

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Hi, @mdaniel and @mbt1. I just wanted to post an update here. We made some changes that are available in 1Password 6.3, and I just checked on pronunciationworkshop.com and it worked fine for me with a Login saved manually I do see that it still does not work with a Login saved from the main 1Password application, so this is something we will need to improve a little further. The main reason for this in the current version is because the registration form doesn't prompt you to confirm the password for the account you're creating, so 1Password doesn't as easily see that it is a registration form.

    I hope that helps!

    Jamie Phelps
    Code Wrangler @ AgileBits

This discussion has been closed.