Form not autosubmiting on https://affiliate-program.amazon.com/

Just as the title says. The form on https://affiliate-program.amazon.com/ is not autosubmitting. I've already tried turning submit logins on and off. Other sites work I use work fine. Just not this one. I'm using the 1password mini helper app on mac not the browser extension. Although I jsut tried the chrome browser extension and it does not autosubmit either on https://affiliate-program.amazon.com/


1Password Version: 6.3.1
Extension Version: 4.5.6.90
OS Version: 10.11.5
Sync Type: iCloud
Referrer: forum-search:not autosubmitting

Comments

  • MeganMegan

    Team Member

    Hi @jtree5757,

    Thanks for including the troublesome web address in your original post - that gives us a much better place to start. I’ve done some brief testing here, and my item fills and submits correctly. (I’ve tested using both my existing Amazon Login item and a newly created test item.)

    So, I’d like to confirm a couple of small details before we dive into the more serious troubleshooting. You mention turning ‘submit logins’ on and off. I’m assuming here that you’re referring to the global setting in 1Password's Preferences > Browsers, is that correct? If so, there’s a second place that we want to check. Within your Amazon Affiliate item, there will be an item-specific submit setting:

    The default should be ‘submit when enabled’, but if your setting here is different, that would explain why your item isn’t submitting.

    If that doesn’t solve the mystery, I’d like to know a few more details about how you are accessing this page. You mention using 1Password mini instead of the browser extension, but could you be more specific? It will help us follow your steps exactly to see if we can see what you’re seeing. For example, here’s how I tested filling on the page:

    • Opened the Amazon affiliate page in a new browser tab.
    • Used ⌘\ ( Command- \ ) to fill my details.
    • 1Password filled my username and password and correctly submitted the form.
  • I actually accessed the setting in 1password mini. I use the mac shortcut (cmd + option + ) and clicked on the settings icon and unchecked and rechecked the "submit logins". But I did just try going into the main 1password app -> preferences -> browsers and unchecking and rechecking the "automatically sign in....." option. Still doesn't work

    As for the actual Amazon Affiliate item, the setting is "submit when enabled".

    As to how I access and fill the page, I use the global shortcut for 1password mini and search for the amazon affiliate item. I then hit enter and it opens the page in a new tab and fills out the fields but does not submit.

    There is no change if I manually go to the page and use the auto-fill shortcut (cmd + ). And again no change if I use chrome extension to fill it.

    I do have multiple logins for amazon, so I have to choose the correct login when using the open page manually and auto-fill (cmd +) method. But I just disabled the option for "allow filling on pages that closely match saved websites" and it still does not auto-submit. It autofills without having to pick anymore though.

    Thanks for your help

  • Drew_AGDrew_AG 1Password Alumni

    Hi @jtree5757,

    Thanks for the details of the things you've tried, it's really helpful for us!

    It sounds like the settings are all correct on your end, and since auto-submit works for you on other sites (and because it also works fine for me when I test it), I wonder if there might be something about that particular Login item which is causing it to not work. You said you have multiple Login items for Amazon - if you try filling that page with one of the others, does auto-submit work?

    Also, as a test, can you please try saving a new Login item for that site by following these steps:

    • Open https://affiliate-program.amazon.com/ in your browser.
    • Enter text in the 'Email or Phone' and 'Password' fields, but do not submit the form (for this test, enter anything you want - it could be your actual login credentials, or random text).
    • Click the 1Password extension/mini icon (enter your Master Password if prompted).
    • Click the gear icon (to the right of the Search field), then select Save new Login from the menu.
    • Give the new Login item a unique name to tell it apart from the others. When you’re finished, click Save Login.
    • Refresh the website, then use the new Login item to sign in.

    When you try the new Login, does auto-submit work? Let us know how it goes, thanks! :)

  • Tried creating the new login and it still did not autosubmit

  • I have also disabled all extensions in chrome just to make sure there weren't any conflicts

  • I just found something weird. If I autofill like normal it doesn't work. But if I autofill again it will autosubmit. This works if I autofill with any credentials the second time. It doesn't have to be the same as the first attempt.

  • PilarPilar

    Team Member

    Hi @jtree5757,

    I'm going to move your question to the "Saving and Filling in Browsers" category so the right people will be able to see it, I hope you don't mind :chuffed:

    Thank you for giving us some more information of the behaviour of 1Password with Amazon. I did some more testing and found out exactly this behaviour: If both email and password are empty, then it takes two attempts to get 1Password to auto submit.

    If the username is already there (for example, when going back after the "wrong password" message) then it works just fine at first try. Would you mind checking if this is the case for you as well? :chuffed:

  • It does not work if I enter wrong password and then use the browser's back button to go back to the page with the username already filled out. I still have to do it twice. It does work on the wrong password page though.

  • brentybrenty

    Team Member

    @jtree5757: I'm sorry of the trouble! We've improved this in 4.5.7 and it's working in the current beta. Hang in there! Hopefully we'll have a final release soon. :)

  • No worries. Just a minor issue. But cool sounds good!

  • PilarPilar

    Team Member

    @jtree5757, thank you for reporting it, we always want to see 1Password improving :chuffed:

This discussion has been closed.