1Password autofills the bank's security question - how to prevent this?

When I use 1Password to autofill the username/password for my bank, the login is successful. However the bank then asks a security question, and 1Passord autofill's this field with my username. This causes a login failure.

How can I prevent this second use of my username?


1Password Version: 6.3.1
Extension Version: 5.5.6
OS Version: OS X 10.11.5
Sync Type: Families
Referrer: forum-search:autofill security questions

Comments

  • Hi @gerhardpratt,

    One solution would be to disable Autosubmit for your bank's login only. This would allow you to manually submit after 1Password fills the username/password and then you can input your security question answer and submit as a separate action.

    To do this for individual logins go to the main 1Password app, edit the login item to set "Submit" to "Never".

    I hope that makes your login process better. It isn't fully automated, but faster than a failure.
    Margeau

  • Thanks. That is a work around.

    There must be a solution though ... I am sure there are others with this problem (i.e. any other 1Passord use who also banks with my bank (a major Canadian bank).

  • brentybrenty

    Team Member

    @margeau: Excellent suggestion! At the very least, disabling autosubmit can be useful to troubleshoot, since otherwise things may happen too fast to see the problem. Definitely a reasonable temporary workaround! :chuffed:

    @gerhardpratt: But I'm not content to leave it at that! Can you tell me the URL, the exact steps you're taking, and what's happening at each point? I suspect there may be another solution. While this isn't generally something I'd recommend doing, you may be able to fix this easily by editing the "web form details" in the login item to remove the security question information completely. If 1Password doesn't know about it, it can't fill it. Let me know! :)

  • @brenty: Thanks for looking into this. Let me have your suggestions for editing the "web form details" (which I tried, but was not sure what I was doing):

    website (URL): https://www1.royalbank.com/cgi-bin/rbaccess/rbunxcgi?F6=1&F7=IB&F21=IB&F22=IB&REQUEST=ClientSignin&LANGUAGE=ENGLISH&_ga=1.196018028.1592473929.1448731253

    Web form details:
    K1: username
    N1: blank
    Q1: password

    display: Always
    submit: Never submit (as per workaround)

    Exact steps:
    1. Click on website "open and fill"
    2. URL opens and username / password are correctly filled in
    3. Click on Sign In
    4. Sign in succeeds
    5. Sign In Protection Page opens a Personal Verification Question, and the answer is autofilled with username
    6. I have to manually correct the answer and click "Continue"

    Note: If I change submit to anything else, the steps above are the same except I do not need 3 (click on sign in) - I am signed in automatically and correctly, and the next thing that happens is the question is autofilled and entered with my username (which is the wrong answer).

  • brentybrenty

    Team Member

    @gerhardpratt: Ouch. Thanks for explaining that! That certainly seems problematic. I'm sorry for the trouble here. :(

    Unfortunately I'm not sure if there's a solution here, as I'm not able to access the "sign in protection" page you mentioned without a real account. Everything fills fine up to that point, as you describe, but I'm a a bit confused about #5. 1Password shouldn't be able to fill on a second page without you invoking it a second time. So I wonder if something else is going on here:

    • Are you actively telling 1Password to fill on the "sign in protection" page using the button or keyboard shortcut?
    • Is the browser's own autofill doing this? Which browser are you using?

    Try this: manually copy and paste your login credentials and login. Is the verification question still being filled? If so, it isn't 1Password. Try disabling the browser's autofill and see if that helps. If not, try saving a new login manually:

    1. Navigate to the website
    2. Enter your login credentials
    3. Click the 'keyhole' icon to bring up the extension
    4. Click the 'gear' icon for Settings
    5. Click Save New Login
    6. Give it a name and Save
    7. Close the webpage and select your new login from the extension to have 1Password Go & Fill

    Let me know what you find. I look forward to hearing back from you! :)

  • @brenty: Thanks for following up. Here are some answers:

    1. I am not actively telling/clicking any buttons to get 1Password to fill on the "sign protection page"
    2. I have disabled the autofill on Firefox, Safari and Chrome
    3. I have tried this on all 3 browsers, and this ONLY HAPPENS ON FIREFOX
    4. I have tried this from the main 1Password App, the 1Password Mini Icon, and the browser extension. It ONLY HAPPENS FROM THE MAIN APP
    5. I tried the manual copy and paste - the verification is not being filled
    6. I tried the instructions for saving a new login manually, and I had the same symptoms
  • @brenty: I should also mention - a similar thing happens with this URL: https://www.avis.ca/car-rental/avisHome/home.ac

    After filling in login details the rental agency web page pops up with the username filling in the date field.

  • Greetings @gerhardpratt,

    I'm pretty sure we have a Firefox specific bug here. We'll need to investigate and try and figure out what is going on. When you use open and fill we alter the URL so that when the extension sees it the extension knows what to do after the page has loaded. So unlike the other ways of filling, with open and fill we have to record the intent to fill once the browser is ready. This record should be cleared straight away and it is in Safari and Chrome but for some reason it isn't in Firefox. I don't know if we're going to find it's something specific to certain pages or simply Firefox in general but I believe we have enough to be able to reproduce which is perfect for testing and then fixing.

    Sorry about this.

    ref: OPX-1064

  • Hello @gerhardpratt,

    I'm wondering if you'd be willing to try the beta 1Password Browser Extension out? Just this morning we released 4.5.7.b5 which includes a fix to help with Firefox's open and fill (and fill). When trying to address this issue I wasn't able to test using the site you're having issues with for the same reason as Brenty. So I think we've resolved it but all the testing was done on another site but I'd love to hear if it helps you.

    If you're willing to try a beta of the extension out here is what you will want to do.

    1. Uninstall the 1Password Firefox Extension already installed.
    2. Restart Firefox.
    3. Download the beta using this link, 1Password Browser Extensions.

    The fix will eventually make it into a stable, it's just if you wanted to try it out and see if it works as well for you as it does during our testing.

  • Hello @littlebobbytables

    I followed the instructions and installed that beta extension. As far as I can tell this has solved the problem I encountered.

    Many thanks,

    Gerhard

  • brentybrenty

    Team Member

    Awesome! Thanks for the update. On behalf of lil bobby, you are most welcome! It sounds like you should be all set, but don't hesitate to reach out if we can be of further assistance. Cheers! :)

This discussion has been closed.