Chrome Extension doesn't recognize 1P 6.x (attempts to open 1P 4.x)

edited July 2016 in Windows Beta

I've previously been using 1Password 4 on my Windows machine with the 1Password Chrome Extension, and I decided to install the new 1Password 6 from the Windows Store.

Following the instructions in this post, "How do I use t browser extension with the Beta?", I killed the Agile1PAgent.exe process. I also removed the executable from the startup list.

Now, with 1Password 6 open and unlocked, I open a new Chrome instance and navigate to a login page. I right-click to open the contextual menu and click on the "1Password" entry.

At this point, I expect for a new contextual menu to appear with the possible fill-in options for the page.

What actually happens is Chrome launches a new tab as the 1Password extension attempts to find the 1Password helper. It then launches an external protocol request to onepassword4-extension://activate/Chrome:

If I click "Launch Application", it launches 1Password 4.

I originally installed the Chrome Extension through the Chrome Web Store, and I use it successfully on multiple Macs with 1Password 6 for Mac installed. My computers all share the same Chrome profile—and therefore the same extension set. I have also tried uninstalling the extension and reinstalling it, to no avail.

Let me know if there is any further information I can provide. I don't believe I've missed any steps in this process, but please enlighten me if I did. I would love to get this working since I think 1Password 6 is vastly superior to its predecessors, especially on Windows.

1Password Version(s): 6.0.161u,
Extension Version:
OS Version: Windows 10 Pro Build 10586.494
Chrome version: 51.0.2704.103 m

(seems like the drafts feature doesn't carry the signature form with it)


  • brentybrenty

    Team Member

    @davidantaramian: I'm sorry of the trouble! This may seem like a silly question, but is the main 1Password 4 app running in the background? Make sure that isn't set to start on login along with 1Password Helper (agent). And if you don't need 1Password 4, uninstalling it will avoid it trying to connect to the browser extensions entirely. However, you can also try 1Password > Settings > Options > Register Browser Extension Helper (at the bottom) in case it became de-registered for some reason. Please let me know how it turns out!

  • @davidantaramian please use 1Password 6 beta for desktop Windows. Because of some technical limitations 1Password 6 beta for universal Windows (the one that comes from Windows 10 Store) do not have browser integration and we prioritized development of desktop version over universal. That way we can help both Windows 7 and Windows 10 users faster. Universal version will receive an update some time in August with catch up on most of the progress done in desktop version and we will continue to evolve both of them in parallel.

    The warning you saw from the Chrome about running onepassword4-extension://activate/Chrome is a sure sign that your Chrome extension works, it tried to connect to the app, but there was no app running. In that case extension attempt to activate app by running that URL. Currently you have 1Password 4 for Windows registered to answer to that call, that is why you see it starting. Once you install 1Password 6 for desktop Windows, it will register itself to handle that URL and extension will use new app to connect.

    Thank you for your feedback and apologies for the confusion, we will try to make it more clear and easy to find how to setup the system right.

  • @SergeyTheAgile Thanks, that did solve it. It's way too confusing to have all these different builds of 1Password 6 floating around.

  • brentybrenty

    Team Member

    @davidantaramian: Indeed. Confusing...but very important to our friends using Windows 7 or 8.1! Glad you were able to install the desktop app. Be sure to let us know if you have any other questions!

This discussion has been closed.