URLs not being recognized by 1Password Chrome extension


I'm having issues with many urls not being recognized. I will cite the example of "overleaf.com" but the same problem occurs on many websites:

  1. I visit https://www.overleaf.com/users/sign_in
  2. I already have a 1Password saved login with url overleaf.com (call it "Overleaf Login 1")
  3. I press "ctrl + \"
  4. Nothing happens
  5. I manually copy-paste the credentials from 1Password into the browser
  6. I get a prompt from 1password asking "Save this login in 1Password"?
  7. I press save
  8. Now I have a new login in 1password (call it "Overleaf Login 2")
  9. Now everything is fine and I can login using "ctrl + \"
  10. But I have two logins for the same website. The only difference I can tell between "Overleaf Login 2" and "Overleaf Login 1" is that "Overleaf Login 2" has the url https://www.overleaf.com/users/sign_in whereas "Overleaf Login 1" has the url overleaf.com
  11. To fix this problem, I add both urls to Overleaf Login 1 and delete Overleaf Login 2
  12. Back to step 1 and the same problem is recurring

Of course, you might ask why I didn't just delete "Login 1" instead of "Login 2" -- in this case that solution would have worked, but in many cases, I need to keep Login 1, because it contains some other login urls which I want to preserve, which would stop working if I moved over to Login 2.

Thank you very much for reading through my problem. Any advice on how to resolve this issue would be much appreciated.


1Password Version:
Extension Version:
OS Version: Windows 10
Sync Type: Dropbox


  • PilarPilar

    Team Member

    Hi @parekh ,

    I'm sorry to hear that you're having some trouble with 1Password. If I understand correctly, the item Overleaf Login 1 was created when you signed up for the account, right? The first thing that I'd recommend you to try is to update the existing data on your first login, instead of creating a new entry. When you are prompted to save new login, on step 6 on your list, click on the option "Update existing" on the top of the dialogue box.

    Please let us know if you try this and how it turns out for you! :chuffed:

  • parekhparekh
    edited June 2016

    Hi @Pilar

    Yes, Overleaf Login 1 was created when I first signed up.

    At step #6 there is no option to update existing (see screenshot).

    I have tried to manually update the login, by adding the url to Overleaf Login 1, but it still doesn't work.

  • PilarPilar

    Team Member

    Hi @parekh ,

    I use Mac, so I'm just going on a hunch here: if you click on the downward arrow at the end of "Create new Login" on your screenshot, do you get the option to update that I mentioned? If you don't see it still, please let us so we can find another option to fix this for you! :chuffed:

  • Hi @Pilar ,

    Unfortunately that's not possible. The dropdown you are referring to is greyed out, and it is not possible to click the arrow.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @parekh,

    It sounds like the 1Password extension is acting as if you don't already have an existing Login item for that site, although clearly you do since you see it in the 1Password program. Going back to your original description of the problem, you said you try the following steps:

    3. I press "ctrl + \"
    4. Nothing happens

    Please try opening the sign-in page for that site again, but this time, instead of using the ctrl+\ keyboard shortcut, try clicking on the 1Password extension in your browser. Does it suggest your "Overleaf Login 1" Login item at the top? If not (i.e. it only shows "Overleaf Login 2", or 'Search' is the first thing shown in the extension), try looking for "Overleaf Login 1" in the Logins submenu of the extension, or try using the 'Search' option and type the Login name. Are you able to find it in the extension?

    If that Login item doesn't show up in the extension at all, that explains why the ctrl+\ keyboard shortcut doesn't work. This might be due to a setting in the Login item. Follow these steps to check that:

    • Open the 1Password program and find your "Overleaf Login 1" Login item.
    • Click the 'edit' button (or you may be able to double-click that Login item to open the edit window).
    • In the edit window, look for a setting that says "Display in web browser". Is that option checked or un-checked?

    If that option is un-checked (disabled) for that Login item, that's why it doesn't appear in the extension. Click the box to enable it, then click OK. Try using that Login item in your browser again - does it work now?

  • @Drew_AG -- Thanks for your guidance, but unfortunately it still doesn't work.

    "Display in web browser" is selected (see screenshot: https://i.imgur.com/8e5E3oZ.png)

    But the login still doesn't show up in the browser extension (see screenshot: https://i.imgur.com/hUxHYkf.jpg)

  • I have the same problem in Chrome on Windows 10.
    I tried the above, but it didn't help.

  • brentybrenty

    Team Member

    @Jeroen_C, @parekh: It sounds like perhaps both of you have the URL you're trying to use the login at saved as one of multiple URLs in the item, not the first URL, but don't have Enable Multiple URLs checked in 1Password for Windows Preferences > Logins. Is that the case?

    If you turn that on, then 1Password will offer you the login for any URL saved within it, not just the first one. Please note that this can slow things down considerably, as 1Password will need to decrypt additional data to search or display more than one URL per item. So it may be better to simply set the first URL to the one you use most and leave this setting off.

  • @brenty: I just turned the option on, but still no luck... (restarted 1Password & Chrome)

  • brentybrenty

    Team Member

    @Jeroen_C: Aha, so it was off! Try Help > Restart 1Password Helper. It sounds like you may have closed the app and reopened it. Otherwise restarting Windows should do the trick. Let me know how it turns out! :)

  • Hi @parekh & @Jeroen_C,

    I'm aware of a problem that we resolved in 1Password 6.3 for Mac that sounds like the same sort of problem but because I don't know the internals of 1Password 4 for Windows as well I'm unsure as to how the issue could be present here. The following is just a thought bouncing around my head that I'd like to learn the answer to. The following will sound odd but it would be great if you could humour me.

    1. From in the main 1Password window select a Login item that is displaying the problem and enter edit mode.
    2. Edit the URL stored in the item. Simply add a random character to the end of the URL. The specific character doesn't matter and you just need to add one.
    3. Save the changes.
    4. Undo the edit to the URL. This is why the character didn't matter.

    Does this change the visibility of the Login item when you click on the 1Password Browser Extension?

    What we're doing here is forcing certain actions to occur that relate to how we match a Login item to a page. This is based on how we do things on the Mac so it may be it doesn't yield anything but worst case scenario it removes it as a potential candidate for the cause.

  • Hi @littlebobbytables: I restarted the 1Password Helper and edited the URL.
    This does not change the visibility of the login items.

    I use 1Password for Windows version

  • Hi @brenty -- Enabling multiple URLs has solved the problem for me. Thanks!

  • brentybrenty

    Team Member

    @parekh: Excellent! Thanks for the update. I'm glad to hear that did the trick for you! :)

  • brentybrenty

    Team Member
    edited July 2016

    Hi @littlebobbytables: I restarted the 1Password Helper and edited the URL.
    This does not change the visibility of the login items. I use 1Password for Windows version

    @Jeroen_C: Can you tell me the URL where you're having this problem? If we can reproduce it, we should be able to fix it. Thanks in advance! :)

  • @brenty

    Hi guys -- On July 1st I commented that enabling multiple URLs has solved the problem for me. Everything was working fine, until a few days ago when the problem started recurring exactly as before, even though I still have multiple URLs enabled.

    Any idea what might be going on? Thanks!

  • brentybrenty

    Team Member

    @parekh: I'm sorry to hear that! I wonder if the recent Chrome update is just causing some odd behaviour for you. If Multiple URLs is still enabled and 1Password hasn't changed, the behaviour should be the same. But unfortunately browser updates can often interfere with the connection (due to the code signature check, usually) so that 1Password can't see what it needs to to work the way we expect it to. Please make sure you complete any updates and restart the computer, and let me know if that helps!

  • @brenty

    As randomly as it stopped working, it randomly started working after a couple of days (from my point of view). Haven't really being paying attention to the updates, so I'm not sure how that contributed. Thanks for the follow up!

  • brentybrenty

    Team Member

    @parekh: This is crazy, but I'm glad it's working for you now at least. I wonder if 1Password is simply losing the connection to the browser for some reason. Chrome had some updates recently and when there is one pending it will typically break a lot of extensions until it finishes and its restarted completely (often a reboot is necessary). If this happens to you again, please send us a diagnostic report immediately and then try rebooting after you've verified that the browser is updated.

  • parekhparekh
    edited September 2016


    Two days ago, I updated to Chrome v53, and this problem started recurring once again. The problem only occurs on logins with multiple URLs. There is no problem for logins with single URLs (just like what I described previously in this thread). As per your suggestion, I have also submitted a diagnostic report. Reboot has not fixed the problem unfortunately.

  • brentybrenty

    Team Member

    @parekh: I'm sorry to hear this issue is recurring again. I see that we've received your email, so we can continue the conversation there. We'll take a look at the diagnostics and get back to you shortly!

    ref: VXA-48267-336

This discussion has been closed.