American Airlines login

American Airlines login requires my last name to be entered in a 3rd field. 1password wants to automatically log me in before I can enter the last name. How do I stop 1password from automatically attempting to log in for this one site. It seems I have to enter my last name first before logging in or I get an error that something has gone wrong.


1Password Version: 6.3.1
Extension Version: 4.5.6
OS Version: 10.11.5
Sync Type: iCloud
Referrer: forum-search:How do I stop one site from logging in. I just want it to autofill the data?

Comments

  • brentybrenty

    Team Member

    @plambert11: Sorry for the trouble! There are actually multiple solutions to this problem. As you pointed out, one option is to disable Autosubmit. There are actually three ways you can do this:

    • Globally in 1Password itself: Under 1Password Preferences > Browsers, disable "Automatically submit logins after filling"
    • Also another way to access the global setting: Open the 1Password menu and click the 'gear' icon and uncheck "Submit logins"
    • Finally, on a per-login basis: In the main 1Password app, edit the login item to set "Submit" to "Never".

    Note that the first two options will prevent 1Password from automatically submitting the login form for any sites. So the third option is good if you only want to prevent 1Password from doing so for a specific site.

    Now those are all useful options, but in this case I think there's a better one. First, don't login at just any American Airlines page. Many of their login pages (especially their main page) are not using HTTPS. Please use this method to save the login manually instead:

    1. Navigate to this URL: https://www.aa.com/loyalty/login
    2. Enter your login credentials
    3. Click the 'keyhole' icon to bring up the extension
    4. Click the 'gear' icon for Settings
    5. Click Save New Login
    6. Give it a name and Save
    7. Close the webpage and select your new login from the extension to have 1Password Go & Fill
    8. Submit the form manually if you have autosumbit disabled

    I was able to save a new working login item in this fashion using Chrome. Be sure that your browser is updated and you have the latest 1Password extension installed in it as well. Please let me know how it turns out! :)

  • Thank you. The pre-login procedure was exactly what I was looking for.

  • brentybrenty

    Team Member

    Any time! I'm glad that helped. Thanks for letting me know!

    I'd also like to add for you or anyone else visiting this discussion that aa.com has a peculiarity that has confused myself and others:

    When you submit the form with your login credentials, the page appears to just reload. However, if you look up at the top, you'll see your name displayed to indicate that your login attempt was successful. Cheers! :)

  • sorry to open up a old thread but this somewhat works. it will auto logged you in with all the information but the site doesn't really change. you are signed in, but the site make is seems like you are not. Im assuming this is American airline fault. However how come 1password can't work with the main page?

  • brentybrenty

    Team Member

    @esf215: Thanks for reaching out! 1Password can work with the main page (following the instructions above to save a new Login item there), but unfortunately it is different enough from their other login forms that a single Login item cannot work everywhere on the various AA sites. It's changed from time to time, so it may again, but I've found that having a Login item that works in places other than the front page is more convenient for me. And we'll continue to work to see if there's something we can do to allow 1Password to work in more places. Let me know if you have any other questions! :)

This discussion has been closed.