"Please Unlock 1Password..." message too intrusive

13»

Comments

  • keninsfkeninsf
    edited October 2016

    Thanks for shepherding this forum.

    I'm glad to see that the team is working to fix this bug/feature. This almost-continuous nag screen has seriously degraded my user experience with 1Password. If the fix isn't forthcoming, or if it still leaves some disruptive machine behavior interfering with my ability to use 1Password efficiently, i'll regretfully have to find another tool that works as I need it to. And, having read through the very many comments on this thread, I suspect I won't be alone.
    This is a seriously nontrivial issue for anyone who does not wish to have their password database up in some cloud service or other. The rapidly increasing saw and number of corporate data breaches lately reinforces the wisdom of the approach. Having been the Engineering Manager for a municipal water treatment plant, security (and cyber security) were part of my job duties. And the first rule of security in that realm was to isolate the critical information physically and/or topologically. And the way to do that in the 1 Password realm is to use a secure wlan connection.

  • brentybrenty

    Team Member

    Well, your 1Password data is end-to-end encrypted, so 1Password simply doesn't depend on the sync service to protect your data. 1Password is secure by design, not by chance. Otherwise, 1Password users would need to worry about data breaches too. Not fun. Fortunately we've got that covered. ;)

    I'm sorry that the security improvements we made with the release of 1Password for Mac version 6 have caused you (and others) so much pain in the form of 1Password for iOS telling you it can't sync. If all goes well, we should have some medicine for you soon. :innocent:

  • Thanks for keeping us updated on progress with this minor annoyance. I don't even mind the alert, but when it appears three times within a minute of opening 1Password on the device, that's too much. I frequently see it twice within a few seconds, when I have not switched away from the app. Can you at least throttle it by time?

  • brentybrenty

    Team Member

    Thanks for the suggestion! That's certainly another option we can consider. :)

  • I'm using WiFi sync to sync my 1password vault to my iPhone and iPad. Everytime I use 1Password on iOS I get two alerts saying WiFi sync failed, because 1Password on my Mac is not unlocked. This is really annoying. If you have to show this "error", please show it in a way that doesen't require me to confirm it.


    1Password Version: Mac: 6.3.5
    Extension Version: Not Provided
    OS Version: OS X 10.12.1
    Sync Type: WiFi

  • BenBen AWS Team

    Team Member

    Hi @KennyFan,

    Thanks for the feedback. I've merged your request with another thread on the same subject. We are considering improvement in this area but our current focus is on our 1Password.com service.

    Ben

  • Ben, your current focus is noble, but this thread is OLD, period. You have every ability to fix these aggravating notifications that come up twice and require you to tap cancel each time before being able to use the product. This is bad user experience, bad design, and I've had this product since version 2. This problem has persisted for at least two years.

    Your team can walk and chew gum. It's time to do better.

  • BenBen AWS Team

    Team Member

    @smithwooddr,

    We do have some plans in the works that will hopefully address this annoyance. Thanks! :)

    Ben

  • For some reason (updated app?) this behavior has started happening to me as well. [iPhone app; wi-fi sync with Mac]. In the last 30m I have "confirmed" this nuisance error at least 80 times. Often 3 to 5 times per session. I'm not ready to leave 1Password, but this 'error message' renders the app almost unusable. This issue has obviously been outstanding for awhile. I understand there are other priorities, but the iPhone functionality is now broken and was poor design (i.e. intentional), not a bug. This makes me unlikely to become a monthly subscriber.

    You should also post solutions so that you don't have to read the entire forum to figure out what to do. One option I have used - turn off Wi-fi on phone, it will not sync and not relay the message. Hopefully you have cell service or whatever you're working on does not require much data.

  • brentybrenty

    Team Member

    @smithwooddr: Just to clarify a couple things, some improvements to the way lock behaves were introduced in 1Password for Mac version 6 in January of this year, which is what produces this response in 1Password for iOS. So I'm not sure where the 2 year figure comes from, since this issue is not present when syncing with older versions. And to elaborate on what Ben said, we're testing some things in the current 1Password for iOS betas which we hope will help alleviate the annoyance. If all goes well, it shouldn't be long. :)

  • brentybrenty

    Team Member

    @bollini: I'm sorry for the trouble. You can also simply unlock 1Password for Mac so they can communicate. We didn't actually change anything in 1Password for iOS, but rather we need to make some changes there to now account for the different behaviour on the server side (1Password for Mac). Hang in there. Hopefully we'll have an update available soon.

  • I look forward to a solution and I appreciate your response.

    However, please keep in mind 'Unlocking' Password for Mac only works until it resets itself again, which occurs by design at most every 5 min, or more frequently if your computer goes to sleep or otherwise times out. It means entering my 1Password twice and pressing 'Dismiss' at least once (iOS Password dialog sometimes appears several times in a row) everytime I want to use the iOS app. This behavior occurs even while syncing is occurring on a near continuous basis.

    If you are using iOS Password frequently, like I am because Apple reset my phone requiring me to enter dozens of app passwords over the span of hours this is more than a simple fix but a nearly constant annoyance and time-waster particularly if using a long string for 1Password. Using 1touch and turning off wi-fi is a more effective 'fix' for my situation than re-entering the password twice dozens of times.

  • brentybrenty

    Team Member

    @bollini: I believe the default for Auto-Lock is 30 minutes, but I could be wrong. However, you can change it in the mean time if that helps. I agree that it's a nuisance to have to dismiss that on iOS, but I wanted to suggest something that can help you in the mean time. That's a neat hack with turning off Wi-Fi, so I'm glad you mentioned it!

  • webagoguewebagogue Junior Member
    edited December 2016

    "Please unlock 1Password on your Mac to continue syncing"

    I want an option to disable this notice.

    I sync via wifi for security reasons. I also have my 1Password lock automatically for security reasons. I understand wifi sync will not work without 1Password on my Mac being unlocked. I don't add/update passwords daily so I am completely ok with the sync not occurring every time I unlock 1Password for iOS while on my home network.

    Please - make it stop. This annoying popup makes me angry at 1Password.

  • BenBen AWS Team

    Team Member

    Hi @webagogue

    Thanks for the note. I've merged your message with another thread on this same subject. We do have some improvements we're testing out with this which we hope to have available within the next few revisions.

    Ben

  • PassMicPassMic
    edited December 2016

    @webagogue I completely agree. This is the single most frustrating aspect of 1Password on iOS. The current behavior should be left the same by default, but users that know better should be able to suppress this error message from automatically appearing. It's understandable that AgileBits wants consumers to be aware when their data isn't backing up, as they might not have any other copy. But this is just cumbersome for the average user.

    There is quite an easy solution for this that will allow for everyone to be happy.

    A suitable compromise:

    1) The current behavior should remain as is by default, however, the user should be allowed to suppress the error message as a toggle option for the given Vault. This option would be available in: Settings > Sync > Vault > Suppress Unlock Server Warning Toggle Button. When toggling the option "Suppress Unlock Server Warning" on, the user should be given a further warning stating that automatic syncing can only occur when 1Password is unlocked on the Desktop.

    2) However, if the user MANUALLY attempts to sync, but a sync does not occur due to locking, the message should pop up. The problem is that the message is popping in iOS up any time 1Password is up and running, but is locked on the host computer. This is MOST of the time.

    3) The standard error message, invoked in any case, should be modified to also include: Last Sync performed: {time since sync} ago with {#itemsinvaul} Items. This gives the user a sense of urgency to sync. The information is already contained in the Vault sync page, but it should also appear in the error message.

    4) Allow the user to set up push reminders to go off after a user-defined amount of time after non having successfully synced. They should be able to enter an integer value up to around 770 for number of days since last sync.

    @Ben

    Local Wi-Fi sync was the primary reason that drove me to 1Password. The idea of not having to have my date out of my control (no matter how fundamentally secure) is a huge appeal for the particularly paranoid among us. This is a tremendously annoying behavior as currently stands, and while it's important to inform users of diligent syncing practices, this is a major hassle for anyone that's been using the Wi-Fi sync feature for any more than a day or two.

  • Or {OPI-3314} works too. Lol. The method I suggested would allow for the user to be more consciously aware of the unlock required for sync issue, though.

  • BenBen AWS Team

    Team Member

    Or {OPI-3314} works too.

    ;)

    1Password 6.5 for iOS should ease some of the pain with this. Please let us know how it turns out.

    Ben

  • MidSummer2010MidSummer2010 Junior Member

    Sorry I'm going to have to bump this.

    I've been getting this error on my iPad and iPhone THREE TIMES IN A ROW, every time I open 1password.

    Please give us the ability to either:

    A) Silence the message
    B) Sync when locked

    Thanks.

  • brentybrenty

    Team Member

    @MidSummer2010: As mentioned above, we've changed this behaviour in the latest version. Could you please clarify what you're seeing? If it's simpler, take a screenshot of this. To include it in your reply, simply click the document button in the top of the comment field, and select the file you wish to share:

    It sounds like you may simply be using an older version of 1Password, so updating should help. If you're still having trouble, be sure to let us know the iOS, 1Password, and device versions you're using. Thanks in advance!

  • MidSummer2010MidSummer2010 Junior Member

    iOS version is 6.5.1 (phone updates apps every night).

    Mac App also up to date as far as I am aware.

    I'll get a screenshot next time.

  • brentybrenty

    Team Member

    @MidSummer2010: Given that the message you're describing was removed in 6.5, I wonder if the update was not successful on your device. If you're still having trouble, the best thing to do will be to restart your device, reproduce the same issue, and then generate a diagnostic report so we can look at the logs to determine exactly what is happening:

    Sending Diagnostics Reports (iOS)*

    *In 1Password Settings > Advanced > Diagnostics > Log Settings, enable App, Sync, and WLAN Sync.

    Please send it to [email protected] with the screenshot, a link to this discussion, and your username in the email so we can 'connect the dots'. Once we see the report we should be able to better assist you. Thanks in advance!

This discussion has been closed.