Safari extension quits

I got a new iMac and installed 1Password on it with my existing license. I installed the browser extension. It worked fine. The next day when I logged back in the extension would not work (nothing happened when I clicked the icon). After restarting Safari the extension works fine. This has happened the last three days.

1Password Version: 6.6.4
Extension Version: 4.6.4
OS Version: OS X 10.12.4
Sync Type: Dropbox
Referrer: forum-search:safari extension quits


  • Drew_AGDrew_AG 1Password Alumni

    Hi @bwayne,

    I'm sorry you're having trouble with the extension! To make sure I understand, you're saying this same problem has been happening every day over the last few days? And when you say you "logged back in", do you mean you unlocked your Mac after it had been sleeping or waking it up from the screensaver, or unlocking it when starting or rebooting it? Or do you mean the extension would not work once you unlocked 1Password with your master password?

    Also, when this problem happens, does the extension button "depress" when you click on it, or does it not seem to recognize that you're clicking on it at all?

    Thanks in advance! :)

  • I'm seeing similar behaviour since upgrading 1Password last night. The icon is present in the Safari window, next to the URI, but it does not respond at all to clicks. I tried reinstalling, but the problem is still reoccurring. (Safari 10.1 on macOS 10.12.4). Firefox and Chrome plugins are working fine.

  • Hi there, just to say I also experienced this problem on Safari since downloading the latest version of 1Password

  • Hi, had the same problem (press on icon not responding) with fresh installe) 1Password 6.7.1 (Agilebits Store) and Safari extension (Apple extension gallery). Reinstall of extension helped in my case.

  • There is something wrong with 4.6.4 of the 1Password Safari Extension and we're working to understanding the cause. We now have an annoucement, 1Password Safari Extension 4.6.4 not working, that contains everything we currently know and we will update it as we learn more.

    The post currently contains a series of steps that should allow you to temporarily return to 4.6.3 of the Safari extension should everything else fail.

This discussion has been closed.