Safari can't install this extension

The Safari 1Password extension has stopped working on my two Mac computers. On both computers it stopped working within the past week. The iMac 1Password stopped last week and the MacBook Pro stopped this week. The Safari 1Password appeared in the Safari Toolbar area but clicking on the icon caused no password window or dropdown list. The1Password icon has since disappeared.

I've tried the suggestions in I tried installing from the Apple Safari Extensions page I get the Safari can't install this extension model window and Install failed. Please try again later on the web page.

If I download the 1Password-4.6.4.safariextz from, I get the same Safari can't install this extension error.

The 1Password mini is running in the Apple menu. Clicking on a login name will launch the correct web page but not fill in the ID or password.

I recently uninstalled the Avast antivirus with the hope that would help. It did not.

Safari is version 10.1 (12603.

Help! (tnx!)

1Password Version: 6.6.4 664002 - Mac App Store
Extension Version: 4.6.4
OS Version: 10.12.4 (16E195)
Sync Type: iCloud & Dropbox


  • matthew_agmatthew_ag 1Password Alumni

    Hey @JonMur,

    I moved your request to the "Saving and Filling" topic since it would appear a little more relevant here - I hope you don't mind. Welcome to the Forum!

    The Safari 1Password appeared in the Safari Toolbar area but clicking on the icon caused no password window or dropdown list. The1Password icon has since disappeared.

    This is very strange - as far as I know the only way the 1Password icon can be removed from the Safari toolbar is:

    • If the 1Password extension is uninstalled. You check if it's still there if you open Safari and from the menubar go to Safari > Preferences > Extensions.
    • If someone customized the Safari toolbar (right-click anywhere on the Safari toolbar and choose "Customize Toolbar..."

    If you found that the 1Password extension is still installed when you viewed the Safari Preferences Extension screen but the 1Password button is missing from the Safari toolbar then this would explain why filling isn't working. With the latest version of the extension - version 4.6.4 - a bug was introduced that caused the extension to break and stop filling if the toolbar icon is hidden.

    The fix is:

    1. Open the "Customize Toolbar.." view, find the 1Password icon and drag it to the toolbar again.
    2. Then restart Safari.

      This should resolve the issue if what I've described matches your set up.

    If however what I've described doesn't match up with your set up please let me know.

    Looking forward to hearing back.

    Best regards,

  • Hi Matthew,

    What you've described doesn't match up.

    When I was experiencing the issues when the Safari 1Password icon would not do anything, I then did the suggestions in and now the extension is gone and there is no 1Password extension in the /Users/jcmurphy/Library/Safari/Extensions folder.

    So I'm at the point where I cannot get 1Password to install the extension.

  • Hello @JonMur,

    What follows are the standard steps I always supply when somebody contacts us about this very generic and vague Safari error message.

    1. Open Safari and enter Safari's preferences.
    2. Switch to the Extensions tab and uninstall the 1Password Safari Extension.
    3. Restart Safari.
    4. Install a fresh copy of the 1Password extension from 1Password Safari Extension from Apple's Safari Extension Gallery.

    The uninstall and restart are both important steps to ensure you don't get this generic error message as Safari will not install a second copy of an installed extension but it doesn't do a great job of explaining that this is why. The restart is to ensure caching doesn't cause any unnecessary frustration.

    If you haven't already, restarting Safari and attempting to install a fresh copy of the extension may be enough or it may be Safari's configuration files are more messed up and we have to be a bit more severe.

    1. Launch Safari.
    2. Use the menu option File > Export Bookmarks... and save somewhere safe like your Desktop.
    3. Download the trial version of AppDelete.
    4. Copy it to your Applications folder and then launch AppDelete.
    5. In AppDelete use the menu option Tools > App Reset....
    6. Select Safari in the Finder window that pops up and click the Choose button.
    7. The main AppDelete window will change and display a number of entries relating to Safari with all of them ticked except for the top entry for the actual application.
    8. Click the Delete button.

    This will purge Safari completely, right back to a never been used state. Can you now try installing a fresh copy of the extension from our page 1Password Safari Extension from Apple's Safari Extension Gallery and see if the issue persists.

    Regardless of the outcome we will need to get your bookmarks back. Now if you sync bookmarks via iCloud I believe you should find the bookmarks are all there as normal. If you don't synchronise bookmarks (I don't myself) you can import your bookmarks after this reset of Safari by making use of the menu option File > Import From > Bookmarks HTML File... in Safari and pointing it to the file you saved in step 2. above. So whether you synchronise bookmarks or not you shouldn't be at risk of losing them.

    Please do let us know how you get along and whether this results in a working extension.

  • Bobby T - tried both of the suggestions above and I still get the same error. The "severe" 8 steps cleared everything out (it even removed the Safari icon from the Dock) but I still see the same Safari error:

  • Hi @JonMur,

    You completely reset Safari and you're still receiving this generic error? That is troubling and a first. Can we try a variation on the steps please to see what the extent of the issue is. I will assume that if it is needed, that you still have the bookmarks file you exported from last time.

    1. Ensure Safari is not running.
    2. Launch AppDelete.
    3. In AppDelete use the menu option Tools > App Reset....
    4. Select Safari in the Finder window that pops up and click the Choose button.
    5. The main AppDelete window will change and display a number of entries relating to Safari with all of them ticked except for the top entry for the actual application.
    6. Click the Delete button.
    7. Restart your Mac.
    8. Launch Safari and attempt to install the 1Password extension, same link as above.

    If you once again receive this generic error message can you see what happens if you try to install the Ghostery extension available on the Safari Extension Gallery. Is Safari refusing to install any extension from the Safari Extension Gallery or is the issue limited to just ours? I apologise, I've never seen this fail after a reset of Safari.

  • I am having the same problem. The mini is visible on the toolbar, but it does not open. I now have to manually add passwords onto websites. Agile Bites needs to fix this problem.

  • thightowerthightower T-Dog Agile's Mascot
    edited April 2017

    Just curious if any of you tried a quit of Safari, immediately after getting the error.

    For me. I noticed on the release notes an update was available but Safari itself never notified me. So I tried a manual update by downloading it directly. That attempt to update failed exactly as you all describe. I quit Safari and the update populated itself. Seams odd to me for this behavior but. I also found it odd I wasn't notified of an update available.

    Maybe I was the lucky one, sorry if its of no help to you. Sounds like many of you have already went through many various steps.

    edit: To me it almost seems if Safari had the update already cached and was simply waiting on a quit and relaunch to bring it to life. Again maybe I was the lucky one.

    edit 2: I don't know if this matters but this was on a clean install of macOS about a month old. With little to no add ons or additional apps other than stock.

  • JonMurJonMur
    edited April 2017

    @littlebobbytables - I did the Severe 8 commands (again!) and I tried the Ghostery extension and it failed. Same Safari can't install this extension error.

    @thightower - I tried a quit of Safari immediately after getting the error, and then a manual update by downloading 1Password-4.6.4.safariextz and then double clicking it to install. Same Safari can't install this extension error.

    The Mac App Store offered an update of 1Password to Version 6.7 (670008) Mac App Store. I did the upgrade to 6.7, but it did not help.

    All of the above was done on my iMac.

  • This message is about my MacBook Pro. In the first post I had mentioned:

    the MacBook Pro stopped this week. The Safari 1Password appeared in the Safari Toolbar area but clicking on the icon caused no password window or dropdown list. The1Password icon has since disappeared

    Somehow I got the 1Password back, but I could not click on it. After that, per the instructions by @matthew_ag, I removed to bad icon, and then re-added the 1Password icon. So I got one computer out of two working OK. YES!

  • brentybrenty

    Team Member

    @JonMur: That's progress at least! It may be that you're also suffering from an issue we've identified in Safari with the latest extension. Be sure to check out that announcement for further information and a possible workaround, and we'll also continue to work to get to the bottom of this.

  • any more thoughts or suggestions for the iMac? I still get the same Safari can't install this extension error.

  • brentybrenty

    Team Member

    @JonMur: While 1Password won't have any control over Safari, there may be one other thing you can try. Since you mentioned that 1Password isn't showing up in the Safari extensions folder at all, it may be that Safari's extension database is corrupt. You can try to reset it:

    1. Open a Finder window and use the keyboard shortcut ⇧⌘G (Shift Command G) to open a Go to folder window.
    2. Use the following location: ~/Library/Preferences/ and click the Go button.
    3. Drag the highlighted file to the Trash.
    4. Launch Keychain Access which you can find in /Applications/Utilities/ or using a Spotlight search.
    5. Search for safari and right-click on Safari Extensions List and select the Delete "Safari Extensions List" option.
    6. In Finder go to the following folder (using the same method as detailed in step 1) to go to ~/Library/Safari/
    7. Drag the entire Extensions folder to the Trash
    8. Then restart you Mac and Safari, which will recreate the folder and hopefully sort out any permissions issues as well

    If you're still having trouble, this discussion in Apple's forums might help, or you may need to contact Apple directly for assistance. Let me know how it turns out!

  • Hi @JonMur,

    I apologise, we've been inundated with emails and posts about the Safari extension recently and it wasn't my intention to forget about the problems you're still experiencing. Given what AppDelete does the steps about aren't going to help, all of these were already being deleted. Just earlier I wiped my Safari configuration again using the exact same steps just as a sanity check. My best guess would be something relating to user folder permissions may be the cause here. The trouble is prior to MacOS Sierra there was a way of resetting or repairing these home permissions from recovery mode (the disk utility never touched your user folder it turns out). As of MacOS Sierra though it seems there is not a way to do this. There seems to exist a utility called repairhomepermissions but my understanding is there is a rdar filed as it doesn't work.

    It saddens me to say that I'm not sure how to proceed. If you are lucky enough to be close to an Apple store it may be worth popping in and seeing if they can assist, maybe they know a trick or two that would help. My suspicion is that if you were to create a brand new user profile you would find you could install extensions as you normally would but while that may validate the hypothesis that it is user folder permissions related it doesn't bring us any closer to the fix.

    If I look at the permissions set on my own Safari folder (and subfolders) I see that I have Read & Write and that the staff and everyone groups are set to Read only. It might be worth seeing what your existing Safari and Safari/Extensions folders look like using the File > Get Info menu option in Finder.

  • @brenty - I went thru the eight steps, and I still get the same error Safari can't install this extension error. To help others going thru the repair lists:

    • in Item #2, if the item has already been deleted, then "Go to folder..." will get this error:

    • and in Item #5 the Safari Extensions List is invisible. Click on View, Show Invisible Items to see the Safari Extensions List:

  • @littlebobbytables -
    I'm not sure the permission are the same as above. For the Extensions folder I looked at the /Users/jcmurphy/Library/Safari/Extensions folder and it is different then the Safari app permissions. Is this OK?

    I have a current version of OnyX and Cocktail. I thought both had a repair permissions but I only see it in OnyX. Will OnyX repair home permissions? Or does it suffer from the same bug as repairhomepermissions?

  • JonMurJonMur
    edited May 2017

    @littlebobbytables - I can try this also:

    Resolve issues caused by changing the permissions of items in your home folder

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @jonmur Lil' Bobby is off today, but the Safari app itself should indeed have different permissions than the Extensions folder. The Extensions folder lives in your Home directory, and as such it shouldn't be updatable by another user (other than root, of course, who can do everything).

    Imagine for instance that another user account was compromised on your computer and the malware wanted to install a shady extension. If the permissions were different, there would not need to be any privilege escalation to get access to another user account.

    By contrast, everyone on the system needs to be able to use Safari, so it has broader permissions for executability, but you'll still need to be an administrator and escalate privileges to make changes to the /Applications folder.

    I hope that makes some sense of the discrepancy!

    Jamie Phelps
    Code Wrangler @ AgileBits
    Fort Worth, Texas

This discussion has been closed.