Safari Extension No Longer Working

I'm using the latest builds:

  • macOS 10.12.4
  • 1Password build 670007 (installed directly, not App Store)
  • 1Password Extension 4.6.4 (installed from the Apple Gallery)

Been a (very happy!) 1Password user for quite a few years now without a problem like this one.

About an hour ago (before I updated to 670007), auto-filling browser forms simply stopped working. My keybind is Cmd-Shift-\, which means that when it stops working, Safari does its fancy auto-zoom thing. Clicking the toolbar button directly had no effect (no menu, no error, no anything). I've had this happen before, and usually it means that 1Password Mini has gotten out of sync, or the browser extension needs updating. I did the following steps, in order:

  1. Restart Safari (no change)
  2. Reinstall extension (no change)
  3. Updated 1Password (no change)
  4. Fiddled with wifi (on the off-chance that some sockets got screwed up)
  5. Restarted 1Password Mini (no change)
  6. Restarted computer (no change)
  7. Manually remove the extension files (from ~/Library/Safari/Extensions) and reinstall. This forced a reauthorization with 1Password Mini (as expected). The results here were… interesting. A new private browsing window was able to auto-fill, but the main window was not. Nothing happened, in fact. Selecting the toolbar button showed the menu, and it detected the appropriate logins and allowed me to click, but nothing happened.
  8. Restarted Safari. At this point, even private browsing windows stopped working, and the toolbar button no longer showed the menu. Basically, right back to square 1.

I'm not entirely sure how to proceed. Hence, this post.

1Password Version: 6.7
Extension Version: 4.6.4
OS Version: 10.12.4
Sync Type: Dropbox


  • Hi @djspiewak,

    Would you be willing to consider the following?

    1. Launch Safari.
    2. Use the menu option File > Export Bookmarks... and save somewhere safe like your Desktop.
    3. Download the trial version of AppDelete.
    4. Copy it to your Applications folder and then launch AppDelete.
    5. In AppDelete use the menu option Tools > App Reset....
    6. Select Safari in the Finder window that pops up and click the Choose button.
    7. The main AppDelete window will change and display a number of entries relating to Safari with all of them ticked except for the top entry for the actual application.
    8. Click the Delete button.

    This will purge Safari completely, right back to a never been used state. Can you now try installing a fresh copy of the extension from our page 1Password Safari Extension from Apple's Safari Extension Gallery and see if the issue persists.

    Regardless of the outcome we will need to get your bookmarks back. Now if you sync bookmarks via iCloud I believe you should find the bookmarks are all there as normal. If you don't synchronise bookmarks (I don't myself) you can import your bookmarks after this reset of Safari by making use of the menu option File > Import From > Bookmarks HTML File... in Safari and pointing it to the file you saved in step 2. above. So whether you synchronise bookmarks or not you shouldn't be at risk of losing them.

    Sometimes we've seen browsers get themselves into a state where we need to purge anything associated with the extension side of things. In the past I've used manual steps but recently found that determining the right manual steps that will help with certain authorisation issues has been problematic. AppDelete was found to work with those issues and offer an easier way of resetting Safari. We don't normally recommend app cleaners because using one on 1Password would delete a locally stored vault but I like what I saw with this one so added it to my toolkit because it helped with Safari.

    If you're still having issues with the extension afterwards we'll probably go down the route of a diagnostic report and a number of questions but if you're happy to try this should eliminate a number of possibilities with Safari.

  • At least once a day, the latest version of 1Password from the Agilebits store and the latest version of the extension (both from Apple gallery and from Agilebits does load. Therefore mini has as the first line "Add Safari Extension" This is reproducible but not on any given schedule. It might be happening after wakeup from sleep overnight and then the first time you try to use it. I do not know if sending you the error log from the main 1Password would help.

    1Password Version: 6.7.1
    Extension Version: 4.6.4
    OS Version: 10.12.4
    Sync Type: iCloud(CloudKit)

  • AirbuskyAirbusky Junior Member

    Having a similar problem. After each 1Password update the extension fails in Safari. The temporary fix for me is to uninstall, reinstall and reauthorize the extension from the extensions preference panel. The extension does not seem to be effected in Firefox and Chrome.

  • For obvious reasons, I'm very leery of using tools like app cleaners. I'd be a lot happier with a series of manual steps. However, honestly just on the basis of you vouching for it (mad, mad respect for AgileBits), I'll give it a shot. I don't use bookmarks at all, though I do rely on history, so I'll have to find some time this weekend to fiddle with things to ensure that the appropriate data gets carried along.

  • I have the same issue on three different machines, all with the non MAS version of the app (6.7), Sierra 10.12.4 and the latest Safari Extension (4.6.4 > tried both, Apple Gallery and Developer). I can't get it to work again without uninstalling the extension, quitting 1Password and reinstalling the extension.

  • I have the exact same issue on three different machines. All 10.12.4, non MAS version of 1P (6.7), Safari Extension from Apple Gallery and Developer (tried both ways) one with a lot of Bookmarks, the others with only a few.
    All of them have the same issue. Safari password filling stops working after sleep or restart.
    I can get it back to work by uninstalling the extension via Safari > Preferences, quit Safari, quit 1P, launch Safari, re-install the extension, re-authorize the extension, quit Safari, relaunch Safari and then it works until the next time the computer sleeps or restarts.
    At least one other machine in our office (same versions) does not suffer from the same issues.

  • I have to add one observation to my report:
    I always remove the 1Password icon from the menubar in Safari (did this since I am using 1P which is for a pretty long time now). This seems to be the reason why the extensions stops working. Because, if I leave the icon there, the extension does not stop to work after Browser restarts, sleep etc..
    However, I really don't want that icon there. :) So, can you please fix this?

    Many thanks!



  • I have had the problem just recently. By restarting the Mac, the problem disappeared for a time. Since I am not on my Mac much of the time, I don't know how long it worked. I assume the problem is a Safari or Apple problem. I have had other strange things occur with Safari over the last week or two. KFR

  • Just some additional information. The extension does depress but nothing happens. Now, if you open the full application in the application folder, then the extension will work.

  • edited April 2017

    Update to opening the main application. That does not work all the time. :-(
    I tried opening Safari while holding down the shift key and the extension worked. Now I don't know if quitting and then reopening safari plain would have done the same thing.

  • +1 Experiencing the same issue here with the MAS version of 1Password (6.7) and Safari browser extension 4.6.4. Using Mac OS X 10.11.6 with Safari 10.1.

  • brentybrenty

    Team Member

    @Steve_H, @Airbusky, @amadeusp, @Visnetje: I hope you don't mind, but I've merged your posts with the existing discussion on this issue, to avoid having the same conversation in multiple places (with many of the same people). I want to make sure we don't miss anything — or have you folks reporting yourselves unnecessarily. :)

  • We are normally quite anti app-cleaners too @djspiewak as we've had to deal with more than one instance where it's resulted in the entire 1Password support folder being deleted. My nod towards AppDelete was after a user I was working with found that no matter what we were deleting relating to Safari it wasn't purging enough but they tried AppDelete and it worked. I haven't had the opportunity to pin down what AppDelete was deleting that we hadn't tried but I've had a few people report that it does the trick. It was certainly a lot easier for the user rather than 12 or so steps detailing how to reach hidden folders and what to delete and the way that AppDelete works meant to seemed unlikely to accidentally encourage people to delete stuff without consideration of what it meant. Of course maybe not all of my colleagues will agree but I do try to be pragmatic.

    Wanting to keep the browser history does add to the complexity a bit. I've never needed to isolate just the history so I couldn't say if it's as easy as copying a single file and dropping it back or something else. My suspicion is you're probably skilled enough to handle this though based on your comments. If you're having trouble though I can see if there is anything I can discover that may be of use. Obviously I wish none of this was needed but we've definitely seen it where the various browsers can get gummed up enough that either a full or partial reset is required. It's different for each browser and this is just what I've found to be effective with Safari.

  • @amadeusp,

    Your discovery is spot on. We've located a bug where if you hide the 1Password Safari button in the Safari toolbar it will result in the extension becoming inoperable after at least a restart of Safari and by the sounds of it if the Mac goes to sleep too. For the moment the immediate fix is to have the button kept visible and a future update should correct this. I never even knew people hid extension buttons until this bug forced people to contact us, in fact I didn't know you could hide the buttons whilst keeping the extension. I don't run enough extensions to be affected personally but it will be corrected as it was on oversight. For various reasons I won't be able to offer an ETA as to when this will be fixed I'm afraid but it would seem probable that the next stable version will include the fix.

    @Steve_H, @Airbusky, @kfr3 & @Visnetje, is it at all possible you are affected for the same reason, do any of you like to keep the 1Password Safari button hidden from the Safari toolbar? If you do you should find making it visible and restarting Safari will resolve the issue. If this is not the case please do let us know.

  • AirbuskyAirbusky Junior Member
    edited April 2017

    Just fired up my two Macs this morning and the Safari extension is not working on either. My 1 Password icon has always remained in the Safari toolbar. I have never removed it. Regarding Steve_H's posts. Quitting Safari and relaunching with the shift key worked for me. Opening the full application did not.

  • Since the last update safari mini is not working and is visible.

  • 1Password Safari button not hidden.

  • @littlebobbytables , yes, I have hidden the 1Password mini extension button from the toolbar, because I prefer not to see it as I can access 1Password from the menu bar already.

  • We now have an announcement that can be found at 1Password Safari Extension 4.6.4 not working. It contains everything we know at the moment and we will keep it updated with what we learn.

  • I was also having this issue. I had hidden the extension button. After reading through this thread, I put the extension button back, restarted Safari and the issue is now fixed.

  • brentybrenty

    Team Member

    @joshnh: Thanks for letting us know! You might try hiding it after updating to 4.6.5, as it should be working again with the latest version. Cheers! :)

This discussion has been closed.