How do I make 1Password show all options for a site?

I have multiple accounts for various websites (Google and Facebook being the most troublesome). When attempting to login to one of those sites, if I hit cmd+\, it auto-fills one of the accounts. With cmd+opt+\ it shows only 1 of the accounts with text like "Show 6 more items..." under it.

How do I make it always show ALL options?

Every accounts is set to "Display: Always" and "Submit when enabled" (which I never have enabled).
For Google, 2 of the accounts are marked as "Favorite", but those are never the ones that show up in the list.

The list shows like this:


1Password Version: 1Password 6 Version 6.7.1 (671001) AgileBits Store
Extension Version: 4.6.5.90
OS Version: macOS 10.12.5
Sync Type: folder / wifi
Referrer: forum-search:multiple accounts

Comments

  • I have just the same question, didn't find it, wanting intel!

  • beyerbeyer

    Team Member
    edited May 2017

    Hey @jvinding & @jerryinal,

    This is actually something I see quite often, so you're not alone!

    The reason this is happening is because the sign-in page you are on doesn't match the website in some of your Login Items for Google. Many of my older Login Items for Google were created with https://www.google.com/accounts/ServiceLoginAuth as the website. However, nowadays most of Google's services redirect to a sign-in page at https://accounts.google.com (with extra URL parameters). By default 1Password only shows Login Items that match the same domain and subdomain of the page you are signing in on.

    I believe if you look at the website stored in your Login Items you will see many of them don't have https://accounts.google.com listed as a website.

    One way to fix this is by editing all of your Login items for Google and adding https://accounts.google.com as an additional website.

    Another way is by enabling our 'Allow filling on pages that closely match saved websites' option on the Browsers tab in 1Password > Preferences.

    If you experience a similar situation on other websites, I recommend you try copying the URL of the sign-in page you are on and adding it to (or updating) the Login Items you use for that website.

    Let me know if making one of these changes works for you!

  • Updating the urls did the trick. Thank you.

  • beyerbeyer

    Team Member

    @jvinding: You're welcome! I'm glad that worked. :+1:

This discussion has been closed.