Sometimes the screen with user id and password comes up but have to hit enter to proceed

I experience this on many sites. Sometimes the auto logon works. At other times instead of logging on, a screen with the user id and password comes up, and to log on I have to intervene and hit enter. Then it logs in ok. I don't find a pattern to it. acts like a timing issue. Is there a timing parameter?

This is on mac os version 10.12.5 and also previous 10.12 versions.

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided


  • matthew_agmatthew_ag 1Password Alumni

    Hey @williewonder,

    Thanks for writing in. I'd like to understand a little more about what you're seeing:

    • May I ask if you're using 1Password for Mac purchased via the Mac App Store?
    • What version of 1Password do you have? You can check this using the instructions on this page:

    • Which browser are you seeing this with?


  • Thanks for reviewing this:

    1) No, I am not using the Apple Store version.

    2a) Version information:

    1Password 6
    Version 6.7.1 (671001)
    AgileBits Store

    2b) Browser Extensions:

    Firefox: 4.5.6 updated May 24, 2017

    3) This occurs in both Firefox 5.4.3 16 bit and Chrome Version 58.0.3029.110 (64-bit)

    4) Mac OS 10.12.5; problem also occurred on earlier version.

    It's unusual and random. It works sometimes; then will not work for the same site later.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @williewonder One of the things that can cause this is if the browser keeps the focus in the address field rather than allowing us to place it properly in the password field. Autosubmit works by placing focus in the password field and then telling 1Password to simulate a press of the return key. We check that the focus is actually in the password field before kicking off the return keystroke because there were situations where 1Password was pressing return but the focus was in the address field and this had the effect of apparently "refreshing" the page rather than submitting. As far as we know, there's not a way for us to acquire the focus when the browser has it in the address field. :frown: I could be off base, but since you describe it as an intermittent issue, that's where my thinking went. Does this sound correct?

    Jamie Phelps
    Code Wrangler @ AgileBits
    Fort Worth, Texas

  • It could be. I have a simple login active now. The screen showis the user name/password along with the login button. It was on this scrreen for several minutes. When I clicked the login button it logged in. The browser in this case was Firefox 53.0.3 - mac os version. Are there browser options that cause this focus problem?

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    There isn't an option that causes this, but if you launch the browser when it is not running, I think most browsers will place focus in the address bar immediately, the thinking being that you will likely want to enter a web address when you open the browser. Am I correct in thinking that this is only happening when you're using 1Password to open and fill rather than navigating to the sign in page and choosing the Login from the browser toolbar button?

  • I use open and fill. Firefox is open and I select a site from the 1Pass browser logins and let it go to the site.

  • brentybrenty

    Team Member

    @williewonder: What's the URL of the login you're having trouble with? I'll be happy to test this. :)

  • brentybrenty

    Team Member

    @williewonder: I'm just not able to reproduce this using the same versions you are. I was able to save and fill/submit logins at both pages using 1Password. Definitely try manually saving a new login for each to see if that helps:

    1. Navigate to the website
    2. Enter your login credentials
    3. Click the 'keyhole' icon to bring up the extension
    4. Click the 'gear' icon for Settings
    5. Click Save New Login
    6. Give it a name and Save
    7. Close the webpage and select your new login from the extension to have 1Password Go & Fill
    8. Submit the form manually if you have autosumbit disabled

    On the other hand, I wonder if you're just running into trouble because the page isn't finished loading on your computer yet and therefore 1Password cannot complete the action. But maybe we're just misunderstanding what you mean by this:

    At other times instead of logging on, a screen with the user id and password comes up, and to log on I have to intervene and hit enter.

    Can you clarify? Either way, you should be able to press ⌘ \ to tell 1Password to log you in once the page is finished loading. Let me know what you find!

  • I tried several tests today.

    Prepared new Seanet login:
    Deleted Seanet from login list
    Accessed Seanet
    Entered name/password
    Clicked gear icon
    Saved site to login list
    Set Seanet as favorite
    Now I should have a new, clean, login

    Test 1
    Started Chrome
    Clicked keyhole icon
    Clicked Seanet from favorites
    Seanet appears with username/password box populated and login dialog box; but no auto login; nothing further happens
    Address bar is highlighted in blue (which may reflect a focus issue mentioned by jxpx777)
    Waited couple minutes; nothing happens
    Tried click command \ key combination; no login
    Clicked login box and login successful
    Logged out Seanet

    Test 2
    While Chrome is still running:
    Click keyhole icon
    Clicked Seanet from favorites
    Seanet appears with username/password box populated and Login dialog box;
    Autologin worked

    Test 3

    Quit Chrome
    Started Chrome
    Click keyhole icon
    Clicked Seanet from favorites
    Seanet appears with username/password box populated and login dialog box; but no auto login; nothing further happens
    Clicked keyhole icon
    Clicked Seanet from favorites
    Autologin worked

    I conclude that in some cases the first site accessed from Chrome may not work correctly with autologin.

    I don't think that's the entire problem but it's interesting.

  • brentybrenty

    Team Member

    @williewonder: Hmm. I just don't understand why it would sometimes work and sometimes not only for you, but perhaps it's just a timing thing. For example, it sounds like it worked in your testing when Chrome was already open at least once. Maybe it takes too long for it to get running and load the site on the first launch, but trying to fill once it's already open or after closing and opening it again has it able to respond more quickly. Does that match what you're seeing?

  • I originally thought timing could be a cause but don't have any tools to prove it. Seems to do the same thing in Firefox. Timing does match what seems to happen.

  • brentybrenty

    Team Member

    @williewonder: Yeah, that's really the way I'm leaning. I'm not confident that we'll be able to determine the cause or have the means to fix it, but if you'll send a diagnostic report (preferably generated after a success and failure in quick succession) the logs could potentially provide some clues:

    Sending Diagnostics Reports (Mac)

    Please send it to [email protected] with a link to this discussion and your username in the email so we can 'connect the dots', and post your Support ID here so we can confirm that we've received it. Also, knowing your timezone and the date/time of the incident will help us find it in the logs. Again, I can't promise anything, but perhaps there's some insight we can use to improve 1Password. :blush:

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Thanks for sending the report, @williewonder. We got it and will be in touch soon.

    ref: FRC-31453-193

This discussion has been closed.