iOS App keeps asking for master password even though I have it setup to use a PIN

I have an iPhone 5. I've been a 1Password user for about 3 months now. I have the app configured to use a PIN to unlock my vault. Under Settings | Security, I have "Lock on Exit" enabled, Auto-Lock set to "1 Minute", and "Pin Code" enabled. Up until a few weeks ago, these settings were working as expected. The app would always ask me for my PIN to unlock my vault. It would only ask me for my Master Password if I messed up and entered the PIN incorrectly (or if I did a full restart on my phone). Some time over the last 2 or 3 weeks, it stopped working correctly. It will ask for my PIN most times I open the app, but if I haven't opened it for say a day, it will again ask me for my Master Password instead of my PIN, even though the phone hasn't been restarted. This happens at least once a day. I'm guessing that something in one of the recent software updates has caused a problem with the way this works. Any help to get it back to working the way it's supposed to would be greatly appreciated.


1Password Version: 6.7.2
Extension Version: Not Provided
OS Version: iOS 10.3.2
Sync Type: WLAN

Comments

  • BenBen AWS Team

    Team Member

    Hi @dkaplan,

    Thanks for taking the time to write in.

    Could you please check what you have set for the 1Password > Settings > Advanced > Security > Require Master Password setting? If it is already set to never, please try changing it to another value (any other value), and then changing it back to never.

    Please let me know how that turns out.

    Ben

  • It's currently set to "After Device Restart". I'm pretty sure I've tried something similar already (changing it to something else and then resetting it back to "After Device Restart"). I'll try turning it off and then setting it to "Never" and see what happens, but shouldn't it be okay to set it to "After Device Restart" or is this a known issue?

  • BenBen AWS Team

    Team Member

    @dkaplan,

    Any of the settings available should more or less work as described, but we did have an issue with an update a while back where this preference may not have been properly preserved, even if it still shows the correct selection. Selecting a different option, and then reverting to your desired selection is the fix for that.

    "Never" is the recommended setting, and is the default.

    Ben

  • Hi Ben, I tried changing the setting and then setting it back to "After Device Restart". After about a day of not using it, I opened the app again and it forced me to enter my Master Password, with no option to enter my PIN. I'm going to now change the setting to "Never" and see what happens, although I'm surprised that it didn't work with what I already tried. Just to reiterate, it was working perfectly up until about 2 or 3 weeks ago.

  • BenBen AWS Team

    Team Member

    How has it worked out with 'never', @dkaplan?

    As far as I can tell we didn't change anything in this regard within the last few updates, so it is a bit of a head scratcher as to why this would've begun within the timeframe you mentioned:

    https://app-updates.agilebits.com/product_history/OPI4

    Ben

  • With it set to 'never, it's been working fine for the last few days. I'm going to let it run like this for another few days and then try changing it back to 'after device restart' and see what happens. I'm not sure what else to try.

  • BenBen AWS Team

    Team Member
    edited July 2017

    Thanks @dkaplan. I don't have further suggestions at this point, but do please let us know how it works out.

    Ben

    ref: OPI-3575

  • Hi Ben, I've been messing around with the settings for about a week now. When it's set to "Never", the app works perfectly. It never forces me to enter my Master Password and I can always login using my PIN. However, when I change the setting back to "After Device Restart", after about a half day, it forces me to enter my Master Password, with no option to enter my PIN.

    As a side note, I also have the app installed on my iPad, and on the iPad it has the exact same behavior. It was always set to "Never" on my iPad so I never noticed the issue. But when I changed it to "After Device Restart" to test it out, it started having the same problem. So, on both my iPhone or iPad the setting simply does not work the way it's supposed to. You haven't had reports of anyone else with this same issue?

  • BenBen AWS Team

    Team Member

    @dkaplan,

    As the default is 'never' and the vast majority don't change it (as it is an 'advanced setting') it isn't all that surprising that we haven't heard more about this. I'll certainly let the development team know, but unfortunately I can't make any promises beyond that. We do appreciate the feedback, and hopefully there is a way that we can improve this behavior.

    Ben

  • This setting has been workig well for me too until one of the last updates. Now the iOS asks for the master password after a seemly random amount of time (sometimes 20mins, sometimes 3 hours)
    Can’t this be addressed/fixed?
    A setting like that should either work or be removed :)

  • BenBen AWS Team

    Team Member

    @Kawarung

    When you’re asked for the Master Password do you also see a fingerprint icon on the screen? If so tapping on that will bring up Touch ID.

    Ben

  • I believe I have a similar problem as Kawarung. When the application asks for the master password, the fingerprint icon is not present. I have not had this problem until recently.

  • @Ben no fingerprint option, I have to enter the master password. Using TouchID is possible during the mentioned timespan after I‘ve unlocked the app. It’s very weird since this feature has been workig fine for years and I havent changed any settings ever since.

    Completely disabling the need to enter the master password is not an option for me due to security reasons...

  • BenBen AWS Team

    Team Member

    Hi folks,

    There is an issue with iOS 11 not telling us when the device last rebooted in the same way that iOS 10 did. We use that information to determine if the Master Password is required, and presently iOS is telling us that the device rebooted much more frequently than it actually has. Until we’re able to find a more reliable way to check if the device has rebooted our only suggestion is to set 1Password > Settings > Advanced > Security > Require Master Password to ‘never’ (the default). That should at least make it such that when you are prompted for the Master Password you’ll also have a fingerprint icon which you can tap on to bring up Touch ID.

    Thanks.

    Ben

This discussion has been closed.