Touch ID Prompt

edited October 2017 in iOS Beta

I might be missing something...

But I’ve noticed that when I launch the app, it doesn’t automatically prompt for Touch ID sometimes. I need to press the Touch ID icon in order to use my fingerprint. It doesn’t do this every time, but it does it often.


  • MrRooniMrRooni

    Team Member

    Good morning @justingoldberg. Thanks for the bug report. This problem should now be fixed in the most recent beta (beta 6). Can you make sure you're running the latest and give it another try?

  • edited October 2017

    I’m on beta 6 on a 7+ running 11.0.3. I just opened the app and experienced the bug... had to press the Touch ID icon to get the prompt.

  • Also had this on the first run of Beta 6.

    Even worse: it then said my fingerprints changed (not true) and I had to enter my password anyway...

  • AGKyleAGKyle AgileSupport 1Password Alumni


    The fingerprints changed part is probably a result of a bug in beta 5 that won't get wiped out until you have to re-enter your Master Password in beta 6. Normal users who weren't on beta 5 shouldn't experience it. Now that you've entered your Master Password you shouldn't either.

    Given you got this error your particular situation is different than the one @justingoldberg experienced. That said, please keep your eyes open to see if it happens while on beta 6, or beta 7 which is due out later today most likely.

    As for anyone experiencing the request for Master Password (without any error dialogs) please generate a diagnostics report (Settings > Advanced > Diagnostics Report) and send that in. Once we receive it you should receive an email back with a ticket ID. Please post that ticket id in the respective thread, like here, so we can quickly investigate.

  • @AGKyle Just had it happen yet again. I sent in a diagnostics report, #RJA-55873-626. Hope that helps.

  • AGKyleAGKyle AgileSupport 1Password Alumni
    edited October 2017

    Hi @justingoldberg

    Did you reboot at all during this time? If so then what you were seeing is expected. When you reboot we will not ask for Touch ID, it'll either ask for the Master Password (if the setting is After Device Restart) or ask for Master Password but allow Touch ID (if the setting is Never) by tapping the Touch ID button below the Master Password.

    The setting I'm talking about above is Settings > Advanced > Security > Require Master Password. According to your report, this setting is set to Never, which means if you restart your device you'll see the Master Password with Touch ID icon below it.

  • @AGKyle Thanks for looking at my report. I haven’t rebooted at all today.

  • please keep your eyes open to see if it happens while on beta 6, or beta 7

    No problem with Beta 7 indeed.

    Unrelated: why is there a square around the fingerprint icon?

    My impression: looks like an accessibility feature has been turned on. I would prefer just the icon.

  • ag_kevinag_kevin Junior Member

    Team Member

    Hi XIII,

    I believe it was a design decision, but I'll pass your feedback along.


  • Installed beta 7 last night. Just ran into the same issue again this morning launching the app.

  • edited October 2017

    Updated to beta 8 last night and even changed the ask for master password to after device restart. Just opened the app this morning and it required my password. I’ve noticed that this is happening when I’m first opening the app after an extended period of time. I definitely haven’t restarted my device. Should I be sending more diagnostic reports @ag_kevin ?

  • AGKyleAGKyle AgileSupport 1Password Alumni


    I'm afraid we don't have an answer for this issue at this time. I have provided another response here that may provide some more context.

    Something seems to have changed in iOS releases that makes this behave differently. We've tried about 4-5 different things now to try to get things working properly again and none of them seem to be working so we've settled on trying to reduce the impact. In that above link I stated we allowed a difference of 5 seconds, we've bumped this up to 15 seconds, which we hope helps a vast majority of users, however we are well aware that there are users who will fall outside this. But if we go any more beyond 15 then it starts to concern us about real reboots not being detected properly and that's a whole different can of worms.

    We aren't necessarily done working on this issue, we know enough about the problem to not need more data from users, but we don't have a fix for this I'm afraid.

    The easiest solution is to set the option to Never under Settings > Advanced > Security > Require Master Password, it will then just require you tap the "touch id" icon below the Master Password to get Touch ID back. But this does mean that after reboots of the device you'll still be able to use Touch ID. This may or may not be a concern for some users so they need to make a decision based on their needs. But at this point in time we don't expect our next stable version to fix this issue I don't think. It may help alleviate the problem for many users, but not fix the issue for everyone.

  • Thanks for clearing it up @AGKyle, hopefully it’s something y’all can eventually fix. Least now I know why it’s happening... makes me feel less crazy.

  • AGKyleAGKyle AgileSupport 1Password Alumni

    Oh yea, it's definitely an issue and we would like nothing more than to fix it. It bothers us as well. A colleague of mine managed to spot something new today so I'm going to see if I can't work through the problem a bit more and perhaps get another potential solution ready to roll. I'll try to update all the various threads if we find a solution as well.

    That said, I am really sorry you're having trouble with this. We want to make people's lives easier and better, and problems like this very clearly do not do that so we all feel really bad that this is happening to our users. We'll keep trying to find a solution though.

  • thightowerthightower T-Dog Agile's Mascot
    edited October 2017

    Today I tried opening the latest 1P beta (release candidate) and received the message of something like "Your master password is required as your finger prints have changed since last used"

    Found that a little bit odd, and gave me pause to think more than once, if I wanted to provide my fingerprint.
    It could be from Apple but no other app I have used with a touch id has done this. I was on 11.1 and 1P was the first touch id app I used. But I would have thought Apple would have provided a message upon unlocking the phone vs when trying to use 1P.

    Any feedback from you all ? Just saying... In my personal opinion it was a little ominous and may need to be re worded some. Just my 2¢

    I suspect it likely tied to Face ID on the iPhone X, but thats a suspicion at this point.

    1Password Version: 6.10
    Extension Version: Not Provided
    OS Version: 11.1
    Sync Type: families

  • thightowerthightower T-Dog Agile's Mascot
    edited October 2017

    Merged my own post into this topic once I found it delt with my question.


    Do you need a report as I was on the release candidate of 1P. Released on 10/25

    I thought I had previously entered my MPW prior to this, but can't be certain.

  • AGKyleAGKyle AgileSupport 1Password Alumni


    This can happen on the latest beta if you:

    1. were using a previous beta that had the bug (beta 5 would be the last to have it)
    2. only used the extension and had to enter your master password there
    3. updated to a newer beta than beta 5
    4. opened the main app (boom, error would appear)

    At this point the next time you launch the main app it will give you that error, reset the settings, then shouldn't appear again.

    Does this sound consistent with what you ran into?

    If you send a diagnostics report in (Settings > Advanced > Diagnostics) then tell me the ticket ID I could take a glance as well.

  • thightowerthightower T-Dog Agile's Mascot


    Looks like I cross a lot of those.

    Sent a report just Incase. No reply from bitbot with ticket ID as of yet.

    Edit [#WEI-43253-733]

    1 yes
    2 no
    3 yes
    4 yes

  • AGKyleAGKyle AgileSupport 1Password Alumni


    Confirmed! The previous run was from 1Password 6.10b5, the very next run was 6.10b8. So this could be all kinds of wonky as a result of that.

    Keep your eyes open to see if it happens again though. If it does, send a new report and reply here or something like that and I'll take a look asap. But so far it looks like you encountered more or less what we would expect having used the beta that was kinda broken :)

This discussion has been closed.