Field type selector doesn't show up until typing in field label or value

I wanted to try out the new TOTP code scanning on Windows but I couldn't figure out how to add a one-time password field. On macOS, there's a button with an ellipsis on it next to the empty "new field" boxes in edit mode. On Windows, there isn't any such button:

Then I accidentally discovered that if I type something in the "label" or "new field" edit boxes, the ellipsis button shows up, and I can change the field type:

This isn't very discoverable. It seems like it ought to work the same as it does on macOS, where the ellipsis button is visible by default on the blank lines for new fields.

1Password Version: 6.8.473
Extension Version: Not Provided
OS Version: Windows 10
Sync Type: Not Provided


  • MikeTMikeT Agile Samurai

    Team Member

    Hi @ted_mielczarek,

    Thanks for the feedback.

    We do absolutely agree and we are planning to change this entirely. There is a weird UI glitch we saw when we tried to replicate macOS experience, it just shift the entire view out of its place. That's why this is the way it is at the moment, I'll nudge our team to get this fixed sooner.

    One idea is that we want to try is the iOS method, where there is a single button called Add One-Time Password and you click on it to start scanning. This will simplify the entire process while being quicker.

    With that aside, how did you fare with the new TOTP scanner, what do you think about it?

    ref: OPW6-1521

  • Re: TOTP scanner - I was able to test the new 'screen scanning' functionality and it worked well for me. I have three monitors and it even picked up the QR code from two monitors away. Nice! :)

  • Sweeet, Thanks for letting us know @jhamer! There are many improvements coming to the item detail and item editor views, so we look forward to making this even better for you.

This discussion has been closed.