1Password says syncing but doesn't open

have an issue that seems to have happened to others, but for whatever reason cannot find a solution or even figure out what's going on. Here goes:

My wife and I share a computer running OS X 10.9.5 with separate logons. Safari is our main browser. All versioning for 1Password and extensions can be found in the additional info. About 2 weeks ago, my wife tried using 1Password from within Safari, and after entering the password, all she had was the message "syncing" and an incrementing counter. Confused, she tried starting the regular application, only to see it ask her for the location of her agile keychain. For whatever reason, it seems as if the application cannot locate her keychain. I cannot imagine that she deleted this file by mistake. Unfortunately, she doesn't use any sort of cloud sync. We do have a backup via Time Machine that runs periodically.

I imagine that a couple solutions could be:

  • restoring (copying) the file from an old Time Machine backup -> any hint as to where i could find her keychain?
  • performing a restore from within 1Password of an old backup? Is there any reason i shouldn't do this?

I also have a 1Password Diagnostics Report that I ran - is there a Support Jedi to whom I can send this for analysis?

Within my own logon account, everything is fine and I have no issues whatsoever.

Any help here would be greatly appreciated!

1Password Version: 3.8.22
Extension Version: 3.9.20
OS Version: OS X 10.9.5
Sync Type: Not Provided


  • LarsLars Junior Member

    Team Member

    Hi @ferkel -- the Agile Keychain in 1Password 3 for Mac is located in your ~/Library/Application Support/1Password folder, unless you've chosen to sync it via Dropbox (in which case it would be in your Dropbox folder). If you want to get an idea of what that looks like, just open that location on your own login on your Mac, and you'll see what I mean.

    Re-login using your wife's account (or have her do it), and open 1Password's Preferences > General and you should see Data File at the top with a file path underneath. That should tell you where 1Password thinks its data file is. Try opening that file path in Finder and making sure everything's where it should be. Note: the keychain doesn't HAVE to be in the 1Password folder, inside Application Support, but that's the default. Each time you open it, 1Password looks for the keychain in the place it expects to find it. What can cause problems is if the actual Agile Keychain was moved or deleted in Finder, when 1Password 3 for Mac wasn't running, as it won't be able to find the keychain.

    However, assuming your wife uses her login account relatively frequently, that means she should have relatively good backups available using 1Password's own backup feature (you can check in Preferences > Backup if you want to). If there's a recent backup, just go to the File menu > Restore Data File from Backup and you should be all set. If that doesn't work, then yes, we should probably get into a diagnostics report. But let's try this first. Once you've completed the backup, check that file path again in Preferences > General. Good luck!

  • OK - there was indeed no keychain located at the directory noted in Preferences->General.

    We were however able to restore a backup and get things working again. BUT - the only backup available was from 2013 (!!). This struck me as more than a little odd because on my account there are easily 50 available, going back a couple of months. I admit that I don't know what my wife had setup as a default setting, but I cannot recall having actively set this up on my account to run a back up at every login. I cannot imagine that she had anything different than I did, so I'm very confused and a little frustrated here.

    I've searched our Time Machine backup on her account for anything "agile" or the likes, but have only come up with the backup file mentioned before from 2013. Surely the current file needs to be on the backup somewhere?! Is there another name or synonym that it could be found under? Would the diagnostics report give any insight here?

    We restored the file, but like i said, it's an old file and there are many out of date passwords in there. Unless anyone has any other ideas, I fear we're going to have to restore everything one by one.

  • LarsLars Junior Member

    Team Member

    @ferkel -- I wish you hadn't restored so old a data file; it may just be that your wife (or someone else with access to the computer) moved her data file somewhere else. I'd like you to do a search in Spotlight for .agilekeychain files on the hard drive (in your wife's account). Since you restored the file, you should see at least one - the one you restored. My question is: are there others? If so, check what the modification date on those others is. Let us know what you discover. We're looking for the missing Agile Keychain. There's no guarantee we'll find it...but if you come up with a different .agilekeychain file in a location other than the one your wife is using now, then we might want to see what that looks like.

  • did the search - both on the drive and on the time machine backups. the result: nothing except the newly created keychain in the default location, the backup file (from 2013), and a new backup that was created yesterday evening.

  • LarsLars Junior Member

    Team Member

    @ferkel - sorry to hear your search didn't turn up anything more fruitful than that. I'm not sure what can be done at this point -- it will depend on what you have available in terms of your wife's data. In order to get a better idea of what might be possible, I'd like to ask you to create a diagnostics report from your Mac:


    Please add the following code (including the square brackets) to the Subject line of your diagnostics email before sending it:


    This will link your diagnostics to our current discussion. We'll take a look and let you know what we find out.

    For anyone else reading, please note: this ID is for @ferkel only. If you’re experiencing the same issue and need help, please ask us for your own ID.

    ref: NIS-17541-733

This discussion has been closed.