6.8.469 wont update to 6.8.473 [Isolated issue]

edited November 2017 in Windows Beta

In 6.8.469 automatic update or pressing the button to update to 6.8.473 doesn't work for some reason. Any ideas?

1Password Version: 6.8.469
Extension Version: Not Provided
OS Version: Windows 10
Sync Type: Not Provided


  • Same issue here. Worked on one machine (windows 7) did not work on Windows 10 Creators Update. Had to log in to the hockey app to get it.

  • Yep, ill just do that. FYI team.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    Thanks for reporting this.

    When you said it doesn't work, do you mean that the button itself is ineffective or it did download/install but took you back to the same version?

    If yes, that means the installer has failed and it didn't replace your build.

    @Spaldo, if you haven't overwritten the current build yet, can you email us your 1Password installer log files? You can find it in the %TEMP%\1Password directory, send us the log for 6.8.473.

  • did not download, said it was up to date.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @AlwaysSortaCurious,

    Thank you for clarifying that for me.

    If it says up to date, can you check to to see if your Hockeyapp email address is included below the beta update like so:

  • I believe I did and that it was there (that was how I upgraded the first time I think), but I will double check when I get home.

  • MikeTMikeT Agile Samurai

    Team Member

    If it didn't work, let me know and we'll check to see if maybe your HockeyApp account isn't configured correctly with our beta settings.

  • edited November 2017

    @MikeT It was filled. Other systems did update btw.

    Edit: After doing something for another thread.
    Wondering, didn't you guys have server issues a day or two ago? Would that have impacted this? I did a full reinstall for the SGX issue I experienced as well tonight, but this time I was able to upgrade in-app between the older and newer beta.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @AlwaysSortaCurious,

    No, the outages wouldn't impact HockeyApp at all. It would've prevented signing in or syncing with 1Password.com backend but the updates are not related to the 1Password.com service issues.

    I'm glad it is working now but that does beg the question what it could've been. The only thing I can think of is a network glitch on your side as well, if it can't connect, it'll say up to date rather than "not able to connect". It's one small detail we need to fix in a future update. The reason I said on your side is that when I checked HockeyApp, we already had thousands of beta downloads, so it couldn't be an outage on HockeyApp either.

  • Not a problem, could have been a million things, agreed, but can't connect sets the right tone when it can't! lol


  • MikeTMikeT Agile Samurai

    Team Member

    No problem, thanks for investigating this with us.

  • Sorry @MikeT I updated the app the manual way @AlwaysSortaCurious mentioned above, by downloading & installing. Rather than update.

    It was the same thing 1Pass did a few builds ago, where it constantly tried to update itself and was popping up on the screen then going away. It just wouldn't automatically update. The version identified it was old and just was unable to install the new build. It happened over & over again, regardless if I manually pressed the update or let it automatically do it.

    I am not sure if that helps, as the update log looks like it has gone now that I did the manual install/update.

  • brentybrenty 1Password Alumni

    @Spaldo: Do you have "security" software that might have been interfering? A lot of times it can lock the temp folder or delete the update package, which causes this type of behaviour.

  • It has happened twice, the other updates have been fine. I have Bitdefender

  • brentybrenty 1Password Alumni

    Thanks for letting us know. If it happens again, see if you can grab the logs from Event Viewer as well as send a diagnostics report:

    Save a log from Event Viewer on your Windows PC

    How to send a 1Password diagnostics report

    Hopefully won't be necessary, but we're here if you need us. :)

  • @Spaldo @brenty I have BitDefender, and its Ransomware protection can interfere with lots (didn't happen in my case), but sometimes it fails to notify with a popup. If it blocked you there should be a reference to it in its events log (the bell icon in the console view).

  • bundtkatebundtkate

    Team Member

    @AlwaysSortaCurious: Thanks for sharing! We have a complicated relationship with security suites as they do tend to cause us some fuss now and again, so we really appreciate y'all sharing your experiences. It can save us some testing at times to be sure. :+1:

This discussion has been closed.