v0.2: op list items no longer works?

We have a workflow based on the CLI tool. That broke sometime this morning with a message saying something like "API Deprecated: update to the latest version". So I upgraded to v0.2 of the CLI tool (macOS 10.13.2). I can signin, I can list vaults, but if I try to list items it always returns an empty array. This is true of 'op list items' and 'op list items --vault='. Yes, I have access to the vaults (and, as mentioned, 'op list vaults' shows them to me). I can see the items in my 1Password app or on the web app.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: macOS 10.13.2
Sync Type: 1Pass for Teams
Referrer: forum-search:op list items


  • AGAlumBAGAlumB 1Password Alumni

    @ryank: Thanks for reaching out. I’m sorry for the trouble! Are you certain you have read access, not just the ability to manage the vault? I'm not having trouble getting op list items to work here. Are you an admin on your team?

  • cohixcohix 1Password Alumni

    @ryank let me dig in to see what could be happening here, I'll let you know what I find.

  • @brenty : Yes, I have read access. I can see/read/write the items in the desktop 1Password app, as well as via the web app. This worked up until roughly yesterday morning (January 19 2018, PST) using v0.1.1 of the CLI. No changes were made to users/permissions in our account from the time it worked until now, when it no longer works.

    @cohix : Thank you.

  • And just now, when I try to op signin, and carefully verify I'm typing the correct password, I get:

    [LOG] 2018/01/20 19:44:38 (ERROR) invalid character '<' looking for beginning of value

    And that's not just a spurious error; the signin appears to have failed:

    $ op list vaults
    [LOG] 2018/01/20 19:44:50 (ERROR) You are not currently signed in. Please run op signin --help for instructions

  • I am also having difficulties. I can use 'op list items' which used to list all items in all vaults but now only returns items in the private vault. If I use 'op list items -vault=Shared' then I get back;
    [LOG] 2018/01/22 12:40:07 (ERROR) User does not have read access to vault Shared

    This was working up until last Friday, my permissions have not changed and I can still access items in the Shared vault from the mac OS 1password GUI.

  • rickfillionrickfillion Junior Member

    Team Member

    We've reproduced this issue and are looking into it.


  • cohixcohix 1Password Alumni
    edited January 2018

    @mr_ses @ryank we've identified the issue and we're preparing a 0.2.1 release that fixes it.... I'll update you when it's released :)

  • cohixcohix 1Password Alumni

    @mr_ses @ryank And just like that, it's live! Please let us know if this fixes the issue for you :)


  • @cohix (and all others involved) Love your work!

    All working well again.

    Thanks so much for your help.

  • cohixcohix 1Password Alumni

    @mr_ses glad to hear it :)

  • Also confirming that 0.2.1 fixes the issues we encountered. Thank you for the quick response and fix!

  • AGAlumBAGAlumB 1Password Alumni

    Likewise, thanks for bringing this issue to our attention — and for participating in the beta! :chuffed::+1:

  • lantrixlantrix Junior Member
    edited October 2019

    I'm getting the same error when using v0.6.2

    $ op signin 1password.eu [email protected]
    Enter the Secret Key for [email protected] at 1password.eu: xx-xxxxx-xxxxx-xxxxx-xxxxx-xxxxx-xxxxx
    Enter the password for [email protected] at 1password.eu:
    [LOG] 2019/10/09 01:01:14 (ERROR)  invalid character '<' looking for beginning of value
  • cohixcohix 1Password Alumni

    @lantrix make sure you include your subdomain in the sign-in address, which would be my.1password.eu if you have an individual or family account.

This discussion has been closed.