VoiceOver problems in 7.0b4

Hello team!

here are a few things I found after installing and starting to use the latest 1Password 7 beta.

  1. The button to unlock next to the master password field has lost its AccessibilityLabel. VoiceOver only speaks it as "button".
  2. In the main screen, the two tables for the object filter and the vault selection could use AccessibilityLabels, too, so they can be easily identified. The other tables such as the object list and object details already have labels, so the same technique should be applied to these two.
  3. If you have an item with an OTP, the button next to that is unlabeled as well. This is also a problem in 1Password 6, so not new, but what better time than this to tackle the problem? ;)
  4. Also, last time I used that button in 1Password Mini, it actually didn't copy the OTP to the clipboard. I used Ctrl+Option+Space (VoiceOver command to activate) on the button, and it didn't copy the OTP.
  5. In 1Password 7 mini, the button next to the search field is unlabelled as well.

That's it for now.

Marco


1Password Version: 7.0.BETA-4 (70000004)
Extension Version: Not Provided
OS Version: OS X 10.13.4
Sync Type: 1Password account

Comments

  • JacobJacob

    Team Member
    edited April 2018

    Hey @MarcoZ! Thanks for letting us know about this. I'll forward the feedback to the team so we can get things improved for VoiceOver. :)

    In the main screen, the two tables for the object filter and the vault selection could use AccessibilityLabels, too, so they can be easily identified. The other tables such as the object list and object details already have labels, so the same technique should be applied to these two.

    Just to make sure I forward the right stuff, could you post a screenshot of an example for this?

    If you have an item with an OTP, the button next to that is unlabeled as well. This is also a problem in 1Password 6, so not new, but what better time than this to tackle the problem? ;)

    The field title for it, or the Copy button when you hover over it?

    Also, last time I used that button in 1Password Mini, it actually didn't copy the OTP to the clipboard. I used Ctrl+Option+Space (VoiceOver command to activate) on the button, and it didn't copy the OTP.

    Does this happen every time you try to copy a OTP? I'll take a closer look if it does.

    ref: apple-391

  • Hi @Jacob! Sorry for the delay in replying to this!

    In the main screen, the two tables for the object filter and the vault selection could use AccessibilityLabels, too, so they can be easily identified. The other tables such as the object list and object details already have labels, so the same technique should be applied to these two.

    Just to make sure I forward the right stuff, could you post a screenshot of an example for this?

    Oh, these are spoken labels by VoiceOver, they actually do not appear on screen anywhere. So a screenshot will not show them.

    If you have an item with an OTP, the button next to that is unlabeled as well. This is also a problem in 1Password 6, so not new, but what better time than this to tackle the problem? ;)

    The field title for it, or the Copy button when you hover over it?

    The button. Again, this is a spoken label for VoiceOver, there should be no visible change on the screen when this is fixed. But VoiceOver will say "Copy Button" instead of just "Button" or something similar.

    I so far could not reproduce the OTP not actually copying. This seems to work in the latest beta now.

    Marco

  • BenBen AWS Team

    Team Member

    Thanks, @MarcoZ. It looks like we've already got code written that should hopefully address this. You should see a note about it in an upcoming beta release. Please re-test and report back after you see that.

    Ben

This discussion has been closed.