1password x and firefox

msantamsanta Junior Member

I have 1Password X version 1.67 installed on Firefox 60.0 b16 and for some reason the keyboard shortcut doesn't work. I am using Mac OS X 10.13.4.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • msantamsanta Junior Member

    Keyboard shortcut not working

  • msantamsanta Junior Member

    I have it set to open with control +shift+ x and it opens with control+command+x

  • brentybrenty

    Team Member
    edited April 2018

    @msanta: Thanks for reaching out. I’m sorry for the confusion! Indeed, if you're trying to use / Ctrl Shift X, that cannot work in Firefox. So currently it is set to / Ctrl ., and there is not yet a way to customize this in the beta. I hope this helps. Be sure to let me know if you have any other questions! :)

  • msantamsanta Junior Member

    Originally that was the keyboard combination, I changed it to shift+control+X and it didn't work. However with the shift+command+X it works, but it shows on the settings as shift+control+X.

  • brentybrenty

    Team Member

    @msanta: Ah! Well you're a step ahead of me then, because I apparently missed the memo on that in an earlier beta. However, on macOS, the key used in lieu of Ctrl, which is what's used on Linux, Windows, etc. But you're saying Firefox is displaying it as Ctrl anyway in your case? Are you able to change it again to show ? It does seem like something weird is going on, as it won't even let me change it.

  • msantamsanta Junior Member
    edited April 2018

    I am able to change it back to the default, but like you said, it still recognizes the the control key as the command key. In other words in the settings it shows ctrl but it only works when the command key is used.

  • brentybrenty

    Team Member

    Yeah, the reason I'm doubly confused is that here it shows ⌘. I'm not sure why it would be different for us given we're using the same versions of everything, but perhaps we'll be able to solve this mystery as we continue to work on the keyboard support in the Firefox beta. IN the mean time, I'm glad that the ⌘ key is at least working for you as expected, even though Firefox isn't showing it as such. Thanks for bringing this to our attention!

This discussion has been closed.