1Password does not fill passwords

This discussion was created from comments split from: Open and Fill Not Working Consistently for 1Password 7.0.1 for Mac.

Comments

  • edited May 2018

    Cannot let the extension fill in any passwords.

    I have Extension version 4.7.1.90
    Chrome Version 66.0.3359.181
    Mac OS 10.13.4

    Bu when I use the password generator it does fill in the passwords on a registration form.

    Seems to work now, after some uninstalling and restarting...

    And now it doesn't work still for Chrome Canary...

  • littlebobbytableslittlebobbytables

    Team Member
    edited May 2018

    Hello @rodideboer,

    If you use Chrome Canary there are additional steps that are required before the extension will work there. We cover the required steps on our support page If you see “1Password can’t save or fill” when you open your browser. If you follow the steps do you find the extension now works in Chrome Canary?

  • Yes, this works! Thank you very much.

    I actually think I did this once for an earlier version, but forgot about it.

  • No worries, just happy everything is working again for you :smile: Should that change for any reason please do let us know but hopefully everything runs smoothly for you now.

  • YannYann Junior Member

    I just installed 1password app and firefox and extensions on a fresh Macbook Pro of our CEO. Advertised and convinced him into your subscription model, only to not have the Firefox extension working ... the greyed out symbol problem on 1password 7.0.1 and most recent extensions. What a shame.... It was bloody embarrassing.

  • Hi @Yann,

    I can't say with any degree of confidence what might have happened but possible reasons for the extension in Firefox not working can be:

    1. 1Password 7 and any browser you wish to use with 1Password must reside in the system-wide /Applications/ folder.
    2. Firefox was damaged for some unknown reason and wasn't passing the code verification step. Deleting Firefox and downloading a fresh copy has helped some people.
    3. Launching Firefox from a Terminal prompt to use the profile manager. This is related to 2 as 1Password is unable to verify the code signature when launched this way.

    or it could have been something else entirely. If you would like us to troubleshoot the issue we will probably need to review a diagnostic report. Let me know if that is something you would like to do and I'll post what to do.

  • YannYann Junior Member

    Hi lbt!
    Thanks for the suggestions, I'll try them out and hope not to find me in need to bother you any further.
    Best regards, Yann

  • Hello @Yann,

    We're here to be bothered so if it isn't resolved in full please do say. We want 1Password to work as well for you as it does for us.

  • YannYann Junior Member

    Ok, I tried it on my own machines. While on an late2012 MacBook Pro, it didn't cause trouble on FF58 and FF60.0.1 (after update, it worked well). On my new late2017 MacBook Pro, it didn't start working, although I downloaded the extension fresh. I downloaded FF plugin 4.7.1.90 from safari and from within FF and reinstalled to no betterment. Symbol kept greyed out in FF

  • YannYann Junior Member

    While being greyed out, the 1pw FF-plugin logo is flickering, like being active for 1/10th of a second every three seconds.

  • littlebobbytableslittlebobbytables

    Team Member
    edited May 2018

    Hi @Yann,

    That sounds like a connection issue. Let's see what a diagnostic report reveals. This link will guide you through the steps and has sections for the various supported versions of 1Password.

    How to send a 1Password diagnostics report

    Please do not post your Diagnostics Report in the forums

    The email address you will want to use is [email protected].

    Once you've sent the report you should received an automated response from us with a ticket ID. If you can post that ID here it will help us locate the email and see what it turns up.

  • YannYann Junior Member

    I did as recommended and the ticket number is: #SVM-57956-245

  • Hi @Yann,

    I've replied and hopefully you'll have things working in Firefox in no time :smile:

    ref: SVM-57956-245

  • Did anything come of this? I’m having the same problem with my work machine (also a newish Macbook Pro on latest Sierra with Firefox Nightly), but everything’s working fine on my home machine (2012 Macbook Air, High Sierra, Firefox Nightly).

  • Hi @robinwhittleton,

    There are multiple possibilities as to the cause so what helped Yann probably won't help you. In Yann's case something very weird had happened with a very particular support folder belonging to Firefox but whatever caused it I'm suspecting it won't be the case for most people.

    Can you create a diagnostic report and send it in please using the post from above. Given the number of diagnostic reports I've looked at recently I'm confident it will reveal the issue and we can get things working properly for you.

  • Thanks! this is ticket #SVW-84899-184

  • Cheers! You should have a reply in your inbox :smile:

    ref: SVW-84899-184

This discussion has been closed.