Lock screen issue: 1Password X for Firefox on Ubuntu 18.04 🐛⚠️


Team Member
edited January 2019 in 1Password in the Browser

We are currently tracking a bug with Ubuntu 18.04's ibus package which causes password fields to not focus correctly in Firefox. The 1Password X popup (which is opened by hotkey or by clicking the 1Password logo in your toolbar) can't remain open without maintaining proper focus. This is preventing 1Password X from being able to be unlocked from the popup in Firefox. So far we've only seen and reproduced this issue using Ubuntu 18.04.

This bug was reported to Ubuntu by one of the Firefox contributors and in our testing affects all versions of Firefox on Ubuntu 18.04.

There are a few ways you can bypass this issue until Ubuntu 18.04's ibus package gets appropriately patched:

  1. Change the Keyboard input method system to XIM: In the Language Support app, change the "Keyboard input method system" setting from iBus to XIM.
  2. Use the Wayland based display server: This issue appears to only be affecting X (the default display server). To try Wayland out, choose Ubuntu on Wayland from the cog on the Ubuntu log in screen.
  3. Downgrade or patch the ibus package (advanced): If you're the type of Linux user that knows their way around the terminal, you can downgrade or patch ibus. A user on Mozilla's bug tracker (bugzilla) has a Debian package with a patch included which has worked for us and other 1Password users.
  4. Unlock 1Password X by signing into your account at https://start.1password.com/signin: Any account that you have added to 1Password X will be unlocked by signing into it using 1Password.com.

Please let us know if you see this issue on any other distribution or version of Ubuntu. We are proud to support Linux and rely on our amazing Linux users to help weed out OS specific issues.

We will keep this thread updated with any pertinent information that may arise.


UPDATE (1/10/19): Ubuntu has reported that this issue has been resolved.



  • josegfvjosegfv Junior Member

    I just tried using the Wayland server and it works well. I will keep it like this until Ubuntu sends a fix for X.

  • Signing in on the web page works - but is far from practical. Not keen on using Wayland as it is slower on my system than X. Will try it and report back

  • brentybrenty 1Password Alumni

    Sounds good. :):+1:

  • Signing in on the web page works. Its good enough for me until a definitive fix is released. Thanks!

  • brentybrenty 1Password Alumni

    Likewise, thanks for the update. Hopefully a fix won't take too long.

  • Tried the ibus downgrade too, much better workaround than singing in the web page... The bug was affecting the overall performance of Firefox whenever a page had a password input. Firefox was sluggish.

  • brentybrenty 1Password Alumni

    Ouch. Glad that made a difference for you then! When my browser is sluggish, it really cramps my style. :dizzy:

  • If you go to Language Support -> Keyboard input method system -> change from ibus to xim it works around the issue

  • brentybrenty 1Password Alumni

    Glad to hear that helped! Thanks for letting us know. :)

  • Thank you so much for this. Besides making 1PX work, it also made my Firefox so much faster! I'm using the XIM input method workaround.

  • brentybrenty 1Password Alumni

    I guess I hadn't considered any other benefits, but I'm glad to hear that it's helping with that as well as with 1Password X in Firefox. Cheers! :chuffed:

  • I think it's worth noting that the XIM and Wayland workarounds can both cause incompatibilities with other applications.

    XIM currently causes display bugs in Gedit (the solid background isn't drawn). I'm not sure if other applications are affected. Relevant links: Ask Ubuntu question, Launchpad bug

    Wayland is still incompatible with some applications also, which is among the reasons why it isn't the default in 18.04 after a trial run in 17.10.

    Of course, these only matter to people who use the affected applications.

  • brentybrenty 1Password Alumni

    Good point. Thank you for mentioning that! Looking forward to more of this getting smother out in future releases. :)

  • lodelode
    edited July 2018

    Just wanted to let you know I'm affected as well, using GNOME Shell 3.28.1 on Ubuntu 18.04. The XIM keyboard input does not fix the issue for me. Switching to Wayland does work. As does the first workaround of first signing in on the website.

  • brentybrenty 1Password Alumni

    Interesting. Thanks for letting us know!

  • dajonkerdajonker
    edited August 2018

    I find that running a "vanilla" Gnome Wayland session on Ubuntu 18.04 is much more stable than anything else I've tried.
    You have to install the "gnome-session" package, restart, and choose the regular "Gnome" session (not Gnome Xorg) when logging in.

  • brentybrenty 1Password Alumni

    I tend not to prioritize stability necessarily, but that could be a good option for those who do. Cheers! :)

  • I just updated to Pop!_OS 18.04 LTS and I have this issue. I wish I read this before I did a fresh install :(

    Any update on a fix yet?

  • brentybrenty 1Password Alumni

    @prime: Since the bug is in ibus it's not really something we have control over. However, one of Beyer's suggestions or another user's may help. It's worth a shot!

  • @brenty
    I’m using the 1st option for now. I’ll check out the keyboard input next to see if I’m able to change this. I’m still a newbie on Linux :)

  • brentybrenty 1Password Alumni

    I hear you. I still feel most at home on Windows myself, in spite of not really liking it and using both Linux and macOS for decades too. Just what I grew up with. Old dogs and new tricks, as they say. :)

  • Hey guys,
    I'm glad I found this discussion. I wasn't having focus issues on forms (it was saying I needed to log in correctly) but I was having issues with the popup. My OS version is Ubuntu 18.04.1 LTS and I'm using Firefox 61.0.1 (64-bit). I was able to solve the popup issue with suggestion #2. Thanks for keeping us updated :smile:

  • brentybrenty 1Password Alumni

    Glad that helped! We'll continue to update this thread when there's more info. :)

  • I don't see a "subscribe" button so I'm just commenting to get notifications on this thread. Ignore me.

  • brentybrenty 1Password Alumni

    @fritzophrenic: No worries! But I did want to mention in case it helps you or anyone else in the future that clicking the "star" icon at the top of the thread will bookmark it so you can be notified of new posts, even without commenting. Cheers! :)

  • Any updates on the permanent fix here?

  • Just wanted to mention that this issue seems to have gone away after upgrading to Ubuntu 18.10. Not sure exactly what changed, though.

  • Thank you @pokemaniac , upgrading to 18.10 solved the issue for me too. Input method configuration currently set to use ibus btw.

  • CethskkyCethskky
    edited October 2018

    I recently updated to the most current stable version one or two nights ago, and that seems to have broken all 1PasswordX functionality. There's an outstanding bug where Ubuntu users can't simply use the extension's little popup to authenticate, so we have to use a workaround where you log in to the web app directly or go through the extension's context menu -> settings -> add an account/your account -> log in page. The bug and workaround are both documented in another post: https://discussions.agilebits.com/discussion/90011/lock-screen-issue-1password-x-for-firefox-on-ubuntu-18-04-️

    Since the workaround is no longer a viable solution, I can't unlock 1PWX and use it to fill in forms, search for logins, etc. I tried changing myinput method and that hasn't worked either. I'm unable to use Wayland as a display server since it's in compatible with much of the software and games I use daily. I haven't tried downgrading or patching iBus yet, but I think I shouldn't have to in order to get back basic functionality with 1PWX.

    1Password Version: Not Provided
    Extension Version: 1.12
    OS Version: Ubuntu
    Sync Type: Default

  • @beyer The webapp login workaround no longer seems to function for me. On 18.0.4 and FF 62.0.3. 1PWX is basically nonfunctional.

    @pokemaniac @mmohamed Does 18.10 uses wayland as a default?

This discussion has been closed.