1Password X Beta causes Zendesk macro menu to hide

Here's how to reproduce:

  1. Enable the 1Password X Beta (Chrome extension)
  2. Go to a Zendesk ticket (zendesk.com)
  3. Click the macro menu
  4. See that the menu immediately hides
  5. Click the macro menu again
  6. See that it remains visible this time
  7. Disable the 1Password X Beta (Chrome extension)
  8. Refresh the Zendesk ticket page
  9. See that the macro menu stays visible on click

1Password Version: Not Provided
Extension Version: 1.8.4
OS Version: Chrome on macOS
Sync Type: Not Provided

Comments

  • daltondalton

    Team Member
    edited August 2018

    Welcome to the forum, @nbolton! Thanks for taking the time to report this behavior. I'll need to set up a Zendesk account in order to test this, but in the meantime, can you try disabling the inline 1Password icon? Here's how to do that:

    1. Open 1Password X from the browser's toolbar.
    2. Click on the gear icon in the top right corner and select Settings.
    3. Turn off "Show 1Password icon in forms".

    I don't expect you to keep this option disabled permanently for the sake of preventing any interference with Zendesk, but I am curious whether temporarily disabling it has any affect on the behavior you're seeing.

    ref: b5x-549

  • Finally got round to trying. That workaround is very useful, thanks. Of course, it makes the extension less useful, but it's interesting to see that the "Show 1Password icon in forms" feature is what causes the bug.

    I think it has something to do with 1Password extension focusing the textbox when replying to a ticket; when Zendesk detects that the textbox has focus, it hides the macro menu. I'm assuming that the 1Password extension is mistakenly causing the textbox to focus when I press the Ctrl+Alt+M Zendesk key combo.

  • when I press the Ctrl+Alt+M Zendesk key combo.

    Correction: this also happens when I click the Zendesk macro menu... so maybe it's whenever the DOM changes.

  • MitchMitch

    Team Member

    Thanks for the update @nbolton. I think your experience makes a good case for adding the ability to hide 1Password on specific sites/pages. Some sites just won't get along with our extension and vice versa.

    Mitch

  • Yes! I would love to be able to add an exclusion for zendesk.com.

    +1 for that feature.

    Nick

  • daltondalton

    Team Member

    Glad you think so, @nbolton! It's difficult to make 1Password X work on every single page, so I think having some extra preferences there would quite helpful.

This discussion has been closed.