1password x - input field only allows a signal character at a time

On version 1.8.9 of 1password-X noticed that when changing an email field it only allows 1 character at a time and looses focus after each characterr. The field I'm entering data is email addresses field and the bug is reproducable on multiple websites.


1Password Version: 1.8.9
Extension Version: Not Provided
OS Version: POPOS 18.04
Sync Type: 1PasswordX

Comments

  • daltondalton

    Team Member

    I'm sorry that 1Password X is interrupting you like this, @cswebserver. We just became aware of this behavior ourselves and have narrowed it down being present only in input fields where 1Password X doesn't suggest any items. We're working on getting this patched up, but in the meantime, I recommend trying the following workarounds:

    1. Open the inline menu by clicking the 1Password icon and select "Password Generator". You don't need to actually use the password suggested here, but having it displayed in the menu should allow you to type in the field without being interrupted.
    2. Prevent the inline menu from displaying automatically. Here's how to do that:

      • Open 1Password X from your browser's toolbar.
      • Click on the gear icon in the top right corner and select "Settings".
      • Turn off "Always show logins when a field is focused".

      This is a more general workaround that will, unfortunately, likely affect your use of 1Password X on websites where this issue isn't present, so I suggest trying the first workaround before this one.

    I'm hopeful that we'll be able to release a fix for this soon. Let me know if you run into any trouble with those workarounds.

    ref: b5x-481

This discussion has been closed.