Copy Google Authenticator 2fa to clipboard or auto-fill with 1Password X


Team Member
edited April 2018 in 1Password X (beta)
This forum post was merged.


  • Hey,

    Not sure if that does not work or it is just a missing feature, but I miss that a lot. Copying the OTP into clipboard after password filling is super great feature and it would be great if that worked in 1Password X as well.

    1Password Version: Not Provided
    Extension Version: X 1.6.4
    OS Version: Not Provided
    Sync Type: Not Provided

  • beyerbeyer

    Team Member
    edited January 2019

    Hey @ondrejfuhrer,

    Thanks for bringing this up!

    I'm a pretty big fan of copying OTPs to the clipboard as well. Unfortunately, this is harder for us to do without being a native app like 1Password for Mac & 1Password for Windows. More specifically it's harder for us to restore your previous clipboard state after a set amount of time.

    Instead, 1Password X takes what I believe is the better path of filling your one-time passwords for you. Once prompted for your OTP, just click the 1Password logo and fill the Login item containing your TOTP secret. We have a bunch of ideas to improve OTP filling (like showing our inline filling menu on OTP fields as well as Login forms), but I think this is a step in the right direction to making OTPs even easier to use!

    Your browser does not support the video tag.

    I hope that helps! Please let me know if you have any questions or if you find a website that filling OTPs doesn't work on for you.

  • Thanks @beyer ,

    Yes, this helps, didn't know that it works that way, I tested it for my sites and (so far) worked, eventhough it's one more step to do (I usually use shortcuts, so in this case I have to go with cmd+. twice and then select the login, but that is fine I guess).

    Thanks a lot :smile:

  • With 1Password for iOS in Safari/integrated apps, 1P copies the second factor number onto the clipboard so all I have to do is hit paste to enter it. Would it be possible to have this same behavior happen with 1Password X? As it is, I have to drill down into the menu to find the second factor, then copy/paste it manually.

    1Password Version: 1Password X 1.6.x
    Extension Version: Not Provided
    OS Version: OSX
    Sync Type: subscription

  • beyerbeyer

    Team Member

    @alanhoyle: I hope you don't mind but I've merged your question here as I believe my post above should answer your question. Please let me know if it doesn't and I'd be happy to provide some additional information. 👍

    @ondrejfuhrer: You're very welcome! We have some improvements planned for the future that I think you'll love! 😁


  • Thanks, this works for me in a tiny amount of testing! Is there any way to get the 1PX icon to appear in the OTP boxes too? and/or have it say "fill OTP" in the menu when it's in that context?

  • beyerbeyer

    Team Member
    edited April 2018

    @alanhoyle: We don't display the inline menu in most OTP fields yet, but that's certainly one of the improvements we want to add in the near future. It's a slight challenge as there is very little standardization to how websites implement OTP fields. That's unfortunately somewhat true with login forms as well, but luckily most contain at least one field with the type of password. We have a few ideas and I can't wait to see those added soon.

    Currently, as you've stated you use macOS in your first post, you can use Command+Shift+Backslash (\) to display the inline menu and 1Password X logo in any field where it's missing.

    I hope that helps but please let me know if you have any additional questions.


  • @beyer: That's great. Thanks!

  • beyerbeyer

    Team Member

    You're very welcome! I hope you have a pleasant week. 😁


  • Hey @beyer when trying to get the 2fa on It doesn't fill the 2fa even if clicking second time


  • beyerbeyer

    Team Member

    Hey @n_tal,

    I sincerely apologize for the delayed response. Thanks for providing this URL so I could improve our detection of one-time password fields in 1Password X. I've submitted a quick fix for this site which should be in our very next beta release.

    Please let me know if you have any further issues filling one-time passwords after your next update. Thanks again!


  • GortGort Junior Member
    edited August 2018

    Hi. When I click 1Password X in Chrome to fill the 6-digit code (on dropbox), it fills in my account name instead of the 6 digit code. What have I done wrong?


  • brentybrenty

    Team Member

    @Gort: I'm not able to reproduce that here, but I tend to think it's not you since there have been a number of odd issues with Dropbox. Can you tell me the URL where you're having trouble, give me the exact steps, and -- this will seem odd -- let me know what language your Dropbox account is set to? We've had some trouble with that because of 1Password getting thrown off by different field names than it expects.

  • RichyreadRichyread
    edited October 2018

    edited to remove account names & emails ('doh!)

    @brenty I'm not certain whether you were able to resolve @Gort issue, but I've been seeing this on and off recently too. Anyway...a picture speaks a thousand words as they say and I was able to capture this today which hopefully may help? :-)

    Hopefully (if my screenshot skills are working) what this should show is that >> for a pre-existing site, within a vault, where 2fa/OTP has been previously activated & successfully saved >> 1p X successfully prompts for the 'Fill One Time Password' but instead merely adds the account password once more.

    Opening side by side and comparing them, it seems that whilst 1p X is aware that the vault at has an entry for the 2fa and should offer to 'fill' it, it doesn't seem to actually load the 2fa codes into the 1p X container. I.e. when you compare them side-by-side, my 'local' 1p V7 clearly shows the 2fa code and the 1p X plugin/container doesn't even have the field to display.

    Win 10 (1803)
    'local' 1p v 7.2.581
    plugin 1p X 1.10.4

    Hope this makes sense?


  • brentybrenty

    Team Member

    @Richyread: I'm not sure we're on the same page here. This discussion is about 1Password copying TOTP codes to the clipboard. That's not a feature 1Password X has ever had because we've taken a different approach: 1Password X fills the TOTP code when you login in most cases. Certainly if you've found a website where it isn't though, we'd love to know the URL and steps to reproduce so we can improve it.

    Given that context, I may be in entirely the wrong frame of mind to understand the issue you're having. Can you break it down for me? What are the exact steps you're taking, and what is (or is not) happening as you expect? I'm sure the screenshot should be telling me something, but I'm not sure what I'm looking for at this point I'm afraid. Thanks in advance!

  • @brenty No we're on the same page....just that mine is the children's picture book edition :p

    I've gone back through to double check the issue and I think I'm actually able to pin it down further still;


    • Logging in to an existing account with Google
    • URL: ... {{etc.}}
    • Google Account(s) details previously registered within 1password
    • TOTP/2FA codes previously generated & stored within 1password
    • 1Password Win10 desktop client (v7.2.581)
    • 1Password X Chrome client (v1.11.0)

    Main Issue:
    1Password X does not auto-fill TOTP/2FA codes into sites when prompted, despite the TOTP/2FA codes being visible and available when viewed within the desktop client and/or portal.

    Observed Behaviour:
    1. Google Chrome -> click [Sign In] or [Add Account] if you've already a Google profile signed in.
    2. Screen navigates to -> ... {{etc.}} and requests an email address for the account
    3. Click the 1pX icon and/or choose from the drop-down list if you've multiple Google accounts
    4. 1pX auto-fills the associated email address at the prompt
    5. Click [NEXT] to navigate to the 'Password' screen
    6. 1pX auto-fills the associated password at the prompt
    7. Click [NEXT] to navigate to the '2-Step Verification' screen
    8. 1pX should auto-fill the associated TOTP code, however in a number of instances it is failing to do so;

    When I wrote my original note I was on v1.10.4 it was filling/attempting to fill the email address into the TOTP field. In v1.11.0 it is simply not returning any values. No amount of selecting the account again from the 1pX icon or the plugin in the address bar has any effect.

    To test further I went through all of my Google accounts (I've a few! :-) ) to double check that it wasn't just a specific issue with my Google account itself - what I discovered was that it actually does work correctly but only for a seemingly random selection of accounts at a time.

    Specifically it appears that the 1pX extension fails to read/access/import the TOTP codes into its local cache etc. and so is therefore unable to provide the required codes when prompted.

    Gratuitous screenshots to demonstrate.....

    This 1st image shows 1p7 on the left side of the screen VS 1pX on the right. The account details match and specifically the TOTP code is visible and stored in both clients.

    When attempting a login with this account 1pX successfully provides the code at the prompt.

    This 2nd image again shows 1p7 on the left side of the screen VS 1pX on the right. The account details are also a match except the the TOTP field is clearly missing from 1pX, despite being available as 1p7 shows.

    When attempting a login with this account 1pX fails to provide a code and (since 1.11.0) returns a blank/null value instead.

    Hope this helps.



  • brentybrenty

    Team Member

    No we're on the same page....just that mine is the children's picture book edition :pirate:

    @Richyread: That sounds pretty nice, actually. I'm in. :lol:

    Main Issue: 1Password X does not auto-fill TOTP/2FA codes into sites when prompted, despite the TOTP/2FA codes being visible and available when viewed within the desktop client and/or portal.

    Hmm. There's probably something I'm missing here. Maybe we're getting hung up on semantics. Can you clarify the "when prompted" bit? Here's what I'm seeing in Chrome 69 with 1Password X 1.11.0:

    1. Open Chrome
    2. Go to
    3. Click 1Password X icon in "email or phone" field
    4. Select Login to fill
    5. (email address is filled)
    6. Submit the form (I pressed Return)
    7. (password is filled, no interaction)
    8. Submit the form (pressed Return again)
    9. (TOTP code is also filled without me doing anything):

    Is there something different about your case?

    It sounds like maybe the issue is that you've got different accounts setup in different places, something else is preventing data from being sync'd, or you've made changes to your account and haven't updated your credentials in 1Password X. So I'm not sure this has anything to do with TOTP at all, but rather something that needs to be addressed in your specific setup, as it's definitely been working here. Let me know what you find!

  • @brenty Sorry the when prompted perhaps wasn't the best use of the phrase - I'm seeing that pre-existing accounts where 1pX should be auto-filling the field, fails to do so, even if I manually prompt it too (by pressing the icon).

    I've got a screen capture which might help - do you have an address I can PM it too?

    Only issue I can think of is having 1p7 and 1pX installed/running at the same time - assuming this shouldn't be causing any conflict as they are wholly separate tools??

    My 1p7 + browser extension works fine on the same accounts - I removed the browser extension just to make sure no conflicts/my sausage sized fingers clicking the wrong button ;)

    It's not a major issue, just that the workflow should be working and for reasons that aren't obvious to me, it isn't in this instance.

    Thanks for your time.


  • @brenty forgot to add that whilst I might have more than one Google account, I do only have a single 1password account;

    All my logins/TOTP codes should be being maintained by my single subscription and (if I understand correctly) no matter if I use 1p7, or 1pX or even just log in to, all of the interfaces/clients - irrespective of the host OS/platform - should be accessing this same single back end data set.

    This is certainly what I am seeing when using 1p7 client - if I connect/update on my iPad, I can see the changes on my Win10 laptop, or the MacOS server at work etc.

    What i'm seeing with 1pX is that (certainly for the TOTP codes) these don't seem to be being accessed/updated correctly and in some instances, the TOTP field within 1pX is missing entirely.


  • dtearedteare Agile Founder

    Team Member

    Thank you for the screenshots, @Richyread. There's very helpful!

    Your one screenshot shows the one-time password in the Windows app, but not in 1Password X. This got me to wondering if maybe things have stopped syncing to 1Password X for you. If so, that could explain all this confusion.

    Could you please log on to your account using and verify that your 1Password account has the one-time passwords like your Windows app does? If so, this would prove 1Password for Windows has successfully uploaded the change. If not, we can dig deeper there.

    I'm going to assume that the changes are already in your 1Password account and say that the issue is likely on the 1Password X side. We had some recent fixes in 1.11 that addressed these but it's possible you have gotten stuck in a bad state and syncing cannot recover. So assuming that the changes are on, could you please uninstall 1Password X and reinstall it? There's no need to worry about data loss as 1Password X will only ever show you data that it downloads from the server. In other words, once you install 1Password X again it will download all your items once again.

    Please give that a go and let us know how it turns out.



  • @dteare thanks for taking a look - after reading your note I felt certain it was just a 'switch it off and back on again' error with 1Password X and thought a reinstall would resolve....but I'm a little taken aback about what I actually found tbh;

    The issue it seems though is not in fact that 1Password X can't sync, but that my source account itself is in error. :(

    Example account 1]

    Example account 2]

    So it's pretty clear now why 1Password X wasn't able to fill the TOTP codes for some accounts - they simply have corrupted entries stored on

    Very unsettling to read and comparing against the values in 1Password 7 client it seems to suggest that they were synced on separate dates & times, over the course of the last few weeks at least. I use the tools daily and have easily moved 50+ login, notes and licence key files over to 1Password in that time frame; I'd desperately struggle to recover & reconcile missing or corrupt entries if this is a sign of something more serious :'( ?

    Perhaps it's my lack of understanding how the setup works compared to the older Master/Slave style of earlier editions, but I'm struggling to see why I would have different values stored in different clients (iPhone/Win10/Mac/iPad) --all linked back to the same, single account.

    I can appreciate the 'how' as it were ((multiple sync's/multiple network connections/system timeouts etc)) that could generate one client or another being behind or out of sync with the main file on an odd occasion, but I would have assumed that at next successful connect the local client compares/reconciles against the master ( and has a workflow to subsequently syncs the changes.

    Where there are clear differences --or as in this instance 'deletions'-- I would have expected the system to have a workflow to flag up and prompt for user input?

    So for example the 1st account shows a last modified date of September 10th; I have no doubt used 1Password in one guise or another, daily since then therefore making (at a minimum) 30 or so successful connects & syncs - should there not have been some form of alert prompt/red flag/email in the affected client(s) that the stored credentials differ and require action etc?

    To give another analogy - I process the books for my wife's small business. Throughout a month the bank processes multiple transactions (deposits, withdrawals, standing orders etc.) and these flow through to an accounts software package via a number of different system clients & interfaces (e.g. Paypal invoices, Petty Cash, Till Receipts etc.) and combine together to produce the associated reports and Tax files etc.

    Whilst most accounts software is largely automated these days and syncs with the bank/back end at regular intervals, it is standard practice/common sense to run a reconciliation report to compare the bank statement(s) to the accounts system and ensure it is correctly in sync. If there are value mismatches within the accounts software VS the bank then these can usually be identified by an error in the feed(s) or corruption in the data sets.(e.g. duplicate invoices)

    Giving this some thought I think what I'm worried about is that this reconciliation step isn't obvious from a 1Password user perspective and would show up issues like this where the values on a client differ greatly from the source. The recent Watchtower/'HaveIbeenpwnd' API interaction is a great example where the system is proactive and highlights issues where the credentials stored require user intervention, I guess I'm perhaps expecting that it would perform a broadly similar function against the source and highlight errors.

    Again I may be over thinking and/or misunderstanding how the revised system works but fingers, toes and legs crossed it's something the team can resolve.

    Appreciate your time.


  • dtearedteare Agile Founder

    Team Member

    Thanks for the update, Richy.

    The different timestamps you are seeing there related to formatting.

    10/9/2018 00:14 is a short hand for the 10th day of the 9th month at 14 minutes past 0:0, or in other words, September 10th, 2018 at 12:14 AM. It's not overly obvious having one date in short form with a clock in 24 hour format and the other in a longer format using 12 hour format. But they are the same dates. So long story short, it looks like it is syncing fine.

    The issue appears to be the Error you're seeing for these values. What ever it is that is tripping up is likely causing the fill issue for us. As such I'd be very interested to see the value of those fields to see what's unique about them.

    Can you enter edit mode on Windows and copy the value of your one-time password to your clipboard? Then email a slightly modified version of it to me at [email protected] It should look something like this:


    You should edit the secret before emailing it to me to X it out like I did in the example. I'm asking you to email it instead of posting it here on the forums as it's too easy to get wrong and post private information.

    Once I see the value there hopefully we'll be able to figure things out! 🙂



This discussion has been closed.