Microsoft log in

Hi

1P autofill doesn't seem to work on MS website, it doesn't fill email even when I click on the extension and login (fill) tab.

It fills the password ok though.

Latest version of 1p on Mojave.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • littlebobbytableslittlebobbytables

    Team Member
    edited September 2018

    Hi @telUK,

    Can you try saving a new Login item for me please and see if you find that works. They seem to have changed the page subtly in regards to the field for the email address but I do find a new item works. Our support page How to save a Login manually in your browser can show you how to do this.

  • telUKtelUK
    edited September 2018

    hi @littlebobbytables

    If I understand correctly I should enter the same email and password and then click save new login, so it basically duplicates?

  • Tried saving a new login but it never worked, email section still does not fill even if it try it manually.

  • Hi @telUK,

    Did you update an existing Login item or save an entirely new one? The update feature is more aimed at change password forms and won't capture the required details to fill. It will require an entirely new Login item saved on the first page.

  • Hi @littlebobbytables

    I tried both ways I believe.

    Just to confirm to save another duplicate new login on this site, I attempted it as follows

    Microsoft.com website
    Login goes to the login.live.com
    first area I enter email
    click next
    enter password
    click next

    After this I'm greeted with 2fa so I can't go any further or it will log me in, so at this stage I click the 1p extension and save a new login.

  • Hi @telUK,

    I apologise, I wasn't clear enough in describing the required steps. Any saving done by 1Password can only save what is on the current page so if you wait until you reach a 2FA prompt the required information is almost guaranteed to be lost.

    1. Reach stage where you're asked for you email address. Fill in field and save Login item before proceeding.
    2. Once on password page fill field and update new Login item saved in step 1.

    What I should have done is point you towards Sign in to websites with username and password split across multiple pages rather than the manually saving a Login item, it's more suited for the style used by the Microsoft sign-in form so that's on me for not picking the most appropriate support guide and mudding things - sorry.

    If you're running 1Password 7.2 for Mac (staged rollout starting with Mojave users) you may be interested to learn that 1Password can now fill 2FA codes using the standard fill command ⌘\ We do still copy the 2FA code to the clipboard though if you prefer pasting.

    Now that I've linked to the better support guide though do you find the new item works once it's initially saved on the page requesting the email address?

  • hi
    @littlebobbytables

    The above worked, thanks very much.

  • Hi @telUK,

    Sorry for the rambling path to the solution and I'm glad you're able to fill the Microsoft sign-in form again. If you come across any other troublesome sites please let me know.

  • edited October 2018

    I'm having the same problem as telUK but your solution doesn't work for me. I am using 1PW 7.2.1 with Mojave. I created Microsoft login in 1PW using the procedure in https://support.1password.com/create-multi-page-login/. Created a new 1PW login from the username window first, then updated the login with the password as instructed. When I look at the 1PW login, it shows both the username and the password just as I entered them. But when I log out of my Microsoft account and then attempt to log back in, clicking Fill in 1PW when I'm in the Username window does nothing. I have to enter my username manually or click copy in 1PW and then paste in the Microsoft window. When I get to the Password window, however, clicking Fill DOES work, the password dots appear, and when I click Sign in it does indeed sign me in.

    When I look at Saved Form Details, the name of the Username field is "loginfmt" if that helps you figure out what's going on. The Password field is named "password".

  • Hi @harrisonklein,

    I'm surprised to learn that, so far that has been a reliable way of correcting whatever is going on. What browser are you using and what version of the extension?

  • Safari 12.0, Extension 1Password 7.2.1

  • Hi @harrisonklein,

    Odd, that's the combination people were having trouble with but that saving a new Login item helped. It's the one I tested because it Safari was the common denominator. Try this instead.

    1. Download this 1PIF (1Password Interchange Format) file to your Desktop.
    2. Drag the 1PIF file to the 1Password icon in the macOS dock to import into the active vault. If All Vaults is active it will use the default vault for saving (Vaults tab in 1Password's preferences).
    3. Locate the imported item, it will have a tag with the import date.
    4. Edit the item and replace the username and password with your real account credentials.
    5. Save.

    If the item works you may also want to update the URL in the website field so that if you use open-and-fill that it logs you into the desired service which the parameters encode and that I've removed from this template item.

    I can't figure out why a new item didn't work for you as I tried again and it still works for me. This is just slightly modified so I'm hoping it achieves the right result.

  • When I download the 1PIF file and drag it to the 1PW icon in the doc, it creates a new Secure Notes item with the title "microsoft.1pif", with the contents of the Secure Note being the contents of the text file. I get the impression that the file was intended to create a Login item for the login.live.com website, with a default username and password that I could modify. That didn't happen and I don't know what to do next.

  • Hello @harrisonklein,

    It looks like when the file was downloaded Safari decided it needed to have .txt appended to the filename. That doesn't happen in Chrome or Firefox (thanks Safari).

    If you still have the file, when you look at it in Finder does it display as microsoft.1pif.txt or microsoft.1pif? If it displays as microsoft.1pif.txt can you try editing the filename and removing the .txt. If you drag that file to the 1Password icon does it correctly import?

    It took me a while to reproduce the odd behaviour you were seeing. Partly because Safari isn't my default browser but also in part because 1Password was silently creating the Secure Note and it wasn't showing at the top of the item list pane like any other new item would. I don't know what 1Password is doing there but it's definitely weird behaviour.

  • That did it. I should have noticed that the file to be downloaded didn't have the .txt extension but once Safari downloaded it, it did. Until recently I used Firefox as my primary browser but decided to switch to Safari on the new computer to cut down on the amount redundant software. But as you pointed out, I wasn't used to this kind of problem with Firefox. All is working properly now. Thank you very much for your perseverance.

    I'm pretty sure I have noticed the same "username doesn't fill from 1Password" behavior on one or more websites in addition to live.com, but I can't remember them at the moment. If I run into this situation elsewhere, can I either duplicate the existing login and change the website, username, and password, or edit the microsoft.1pif file directly showing the problematic website, and is that likely to solve this problem on other websites? Or is this file only going to have the desired effect on the live.com website?

  • Hi @harrisonklein,

    We both learned something from this as I had no idea Safari was altering the filename either.

    This item will only work for the live.com site I'm afraid but if you find any other sites where you're having trouble and manually saving a new Login item doesn't help either then please let me know and I'll happily work through each one with you until we get them all figured out.

  • brentybrenty

    Team Member

    @sphen: Interesting. I've got some that work and some that don't. What field name are you seeing for the username/email address saved in "web form details"?

  • brentybrenty

    Team Member
    edited February 2019

    @sphen: My guess is this has changed a lot over time, as has Microsoft/Live/Skype/etc. :lol:

    Anyway, I've filed an issue for this since it seems like this shouldn't be necessary, but I've found a workaround:

    1. Create a new Login in 1Password for Mac — not in the browser
    2. Enter your login credentials into the username and password fields at the top and save
    3. Edit and scroll down to web form details
    4. Change the "username" field to say "login"*
    5. Change the field type on the right to "email"*

    Then it should fill for you.

    ref: apple-2400, x/b5x#629

  • brentybrenty

    Team Member

    @sphen: Honestly I have no idea. It's worth a try, but it's a mystery to me why the workaround I found works at all, or why it should be necessary.

    As far as the Safari thing, we're using a new technology there that Apple is requiring going forward, so it is technically different than what we're using in other browsers, even though it's based on our same filling engine. So I'm not sure if this is a limitation or quirk of Safari App Extensions, of our new implementation for that, or just a bug where we're going down a wrong code path or something.

    Anyway, I'm curious as heck about all of this, but I think we'll be happy if we can just get it working better. ;)

  • brentybrenty

    Team Member

    Hey, thanks for bringing this up! It might have ben a while before I used those other logins and noticed myself. :)

This discussion has been closed.