App Generates Invalid 2FA Codes

Community Member
edited November 2018 in Android

Lately I'm trying to migrate all my active 2FA enabled sites (GitHub, Dropbox, Origin, Microsoft, etc) from Authy to 1Password for Android.

I'm doing the following on these accounts:
1. Login to the said account
2. Remove the existing 2FA
3. Add new 2FA using 1Password for Android
4. Scan the QR code and enter the code (it worked)
5. Done!

But to my surprise, when I'm trying to login to those sites afterward (well they asked for the 2FA code) none of the code generated by 1Password Android nor 1Password browser extention worked. Not even the 1Password Windows or macOS application.

Is this a known issue? I've googled this issue and could not find any meaningful solution, there are several threads of people experiencing this but no real explanation of why and how to solve this.

Small update: after multiple testing the Dropbox 2FA works if I put the code generated by Android app, Windows and macOS app will give unusable codes (always invalid). For other account (GitHub, Origin, Microsoft) none of the code generated by the mobile app, Windows, nor macOS app works.

1Password Version: 7.2.581
Extension Version:
OS Version: Windows 10, macOS 10.14, Android 9
Sync Type: 1Password Account


  • periperi

    Team Member

    Hi @delfianto. Thanks for reaching out! It sounds like your devices may not be syncing the right date and time. Can you please check the date/timezone settings on each of your devices? Disable automatic date/time and then reenable it. Does that help?

  • delfiantodelfianto
    Community Member

    Hi @peri thank you for your reply, I spent few hours troubleshooting this and the issue seems to be mismatch time between the devices. I have another Linux workstation with proper time (synced with NTP) and my 1Password X OTP code works fine there.

    I've re-sync the time on my MacBook, and it works too. Windows is a little bit finicky on time synchronisation but that's not my primary workstation so it does not really matter now.

    You can mark this post as solved, thanks for your response.

  • periperi

    Team Member

    Thanks @delfianto. I'm glad to hear it was a timing issue, and you were able to get it sorted out. Let us know if you need anything else!

This discussion has been closed.