Not sure what happened

I was using 1Password 4 for Windows. This morning when I opened it up, instead of prompting me for my password, it gives me three options: Create new 1Password Vault; Open existing 1Password Vault; Restore 1Password Vault from Backup.

So I checked my backups and it shows that I had 896 passwords until three days ago, and for the last three days I've had 14. So I restored from the backup that had 896 passwords, but I am wondering what happened in the meantime. Should I be worried? Is there a way for me to now see what the 14 are from the last three days, or do I just lose any new ones that I added since the backup I restored from?

1Password Version:
Extension Version: Not Provided
OS Version: Win 10
Sync Type: Dropbox


  • MikeTMikeT Agile Samurai

    Team Member

    Hi @lina,

    Thanks for writing in.

    If you're using Dropbox, check your Dropbox history on to see if it was deleted by anyone. It sounds like Dropbox deleted the vault, which would cause it to propagate to all of your Dropbox-connected machines as it is a sync service. Check this guide from Dropbox:

    As for the 14 items, you have to do a bit of back and forth with that; basically you have to go back to that vault and export these 14 items to reimport it into the current vault you're using. Here's how:

    1. Create a new backup via the Backup menu to save the current vault
    2. Restore to the previous backup with 14 items, unlock, select them all (or review to select what you want to keep) and go to File Menu > Export, select 1Password Interchange File and All Items. Save it in a secure place on your desktop, don't use Dropbox since this file is not encrypted
    3. Now, restore to the new backup you created in step 1, unlock and use the File Menu > Import to select the file you saved on the desktop
    4. Trash that export file on desktop and empty the trash.

    You should be up to date now with all items in your vault.

  • linalina
    edited November 2018

    Hi @MikeT -- I think you are right, this has something to do with Dropbox but I haven't figured it out yet. The other day I was prompted to download Dropbox Desktop again and I did without thinking. That must be when this happened. What's strange is that in Dropbox online and on my desktop the old files are still there.

    When I try to restore from the 14-item backup, I get a message that says:

    1Password has encountered a problem.

    "...\1Password\1Password 5.agilekeychain" is not a 1Password Vault.
    Changing your master password in the Mac version might correct this problem."

    Do you have any suggestions? I am not using a Mac. It looks like it has created a new folder each time I try this, but I can't actually open it in 1Password.

  • bundtkatebundtkate

    Team Member

    @lina: Is it possible you ended up with the Windows Store version of Dropbox in addition to the version from Dropbox's website when you saw that prompt? I won't pretend to have any amazing ideas as to how that might have happened, but if the old files are there in the two locations you mention, two separate Dropbox apps might explain the oddities.

    As for the error you're seeing, that tends to mean some component of that vault is missing, but it's odd that this is happening when restoring a backup. I'm used to seeing this mostly when opening an existing vault that's damaged in some way. You mentioned you saw a few days where you only had those 14 items – any chance restoring backups from a different date works for you?

  • linalina
    edited November 2018

    I don't think it's the Windows Store version, although I'm not sure how to tell. I never open the Windows Store and was quite diligent about deleting all of the apps there when I got Windows 10 because I'm afraid of things I don't understand. My Dropbox lives at C:\Program Files (x86)\Dropbox, so I think it's just the regular one.

    I've tried restoring from backups for all of the days that were only 14 items, but I get the same error message for each one.

    I also notice that in my local and online Dropbox folder there are two folders:

    The first has 17 files in it, and the 'legacy' folder has more than 1,000. Can I just move the files from the "main" folder into the legacy folder and rename the legacy folder to make it the main folder?

  • brentybrenty

    Team Member
    edited November 2018

    @lina: It looks like you converted your vault to the OPVault format on another device (that's the only reason a .legacyagilekeychain would exist). It would have been helpful to know that. In (Dropbox)\Apps\1Password\) you should see the new vault, ending in .opvault. Open that in 1Password for Windows from the File menu and let me know if that helps.

  • Hi @brenty, I didn't know that or I would have told you! At some point a few months ago my 1Password stopped updating on my phone and it made me change something to get it to work again, but it was just a prompt on my phone without a lot of information so I didn't understand that it would change my vault on my computer as well.

    In my Dropbox\Apps\1Password\ folder there are the following folders:


    in the 1Password.opvault folder is a folder called default, a file called .ws.agile.1Password.write, and 18 Javascript files. I don't see any files ending in .opvault

  • bundtkatebundtkate

    Team Member

    @lina The .opvault folder is what brenty was after. What actually happens here is that it changes your vault on Dropbox to OPVault format. This means you need to point your computer to the new vault so it keeps syncing. It sounds like you probably didn't and, since the vault you were using at the time had been renamed and wouldn't have been something your PC app recognized, "something wonky" happened. If you hop on your PC and choose File > Open 1Password vault, then select that .opvault folder on Dropbox, click OK, then enter your Master Password. All your data there? Everything looking good? Fingers crossed!

  • Okay, so I have opened the .opvault folder, and it has all of my passwords up to two months ago. It appears that all of my more recent passwords are in one of the other vaults, which I can't seem to open.

  • brentybrenty

    Team Member

    @lina: In that case, it seems like it would be to use the data you restored from the most recent backup containing the data you want, which you referenced in your original post:

    So I checked my backups and it shows that I had 896 passwords until three days ago, and for the last three days I've had 14.

    Which vault is that, out of the ones you listed above? Or is it a different one?

  • I can open those when I restore this file from backup: 1Password 3 2018-11-17 201235 (897 items).agilekeychain_zip

    I'm getting the feeling that I am running several different vaults. I am using 1Password on my computer, laptop, and Android phone and using Dropbox to sync them. How can I consolidate all of these vaults?

  • bundtkatebundtkate

    Team Member

    @lina: That's a tough one with 1Password 4 for Windows and 1Password for Android being the only devices in the mix. What I'd likely do is choose a vault as the "master". Open each additional vault in 1Password 4, one-by-one, and export each additional vault's data to 1PIF format. Import those 1PIFs into your "master" vault, then use that vault moving forward. To be extra safe, you can tidy up those extra vaults on Dropbox and either delete them or move them to an archive folder so you don't confused about which to use down the line.

    That's a purposefully brief overview because without having a list of those vaults in front of me with an item count for each and a clear indicator of which have data you need in them, I don't feel that comfortable giving you detailed steps. It might be best to take a moment and review so we know we've got all the details straight:

    -You have the opvault open which has everything up to two months ago.
    -You have at least one (maybe more?) additional backups that you can't restore with a smaller number of items in them.
    -You have a .legacyagilekeychain folder on Dropbox.

    Am I missing anything?

  • On Dropbox (both online and on my computer) I have:


    On my computer in Documents/1Password I have:


    Most of those were created last month while trying troubleshoot this issue.

    I have just gotten a new Android phone and loaded 1password.opvault, but now it won't sync and gives me an error message, which I've just sent in to the support email address. I also have a laptop that is using 1password.opvault.

    I'm going out of town and won't have access to my computer so this situation is difficult! It looks like the passwords up updating to Dropbox, but then on the devices not all of the passwords seem to sync. For example, only one password of the 5 that I can see in my dropbox from the past week has updated on my laptop, and there doesn't seem to be any obvious reason why. Is there a way for me to force it to sync?

  • I just restarted 1password on my laptop and now 3 of the 5 from the last week are there. Maybe I just need to start it and restart it a bunch of times??

  • Is there a way for me to force it to sync or is that not possible in 1Password 4?

  • brentybrenty

    Team Member

    @lina: 1Password doesn't sync the data; Dropbox does. So nothing you do in 1Password will affect that. Howeverm it is inportant to make sure that you're using the same vault in 1Password on each device. Otherwise they'' each be syncing, but with different data. Once you determine which vault you want to actually keep, based on the one you're using on (a) device(s) where you have all of your data, it would be a good idea to remove the rest to avoid further confusion. Let me know which one has all of your data.

This discussion has been closed.