1passwordX doesn't unlock correctly on new firefox 65

Hello everyone,

A curious thing I noticed after I updated to the latest firefox (65):
When trying to unlock the 1passwordX via entering the password and hitting enter on the keyboard, it doesn't work. It doesn't say wrong password, it just refreshes, clearing the password field and waiting for another input without losing focus.
It does work though, if I enter the password and instead of hitting "enter" on the keyboard I click on the unlock button.

Just though I should let you know.

I'm on a Ubuntu 18.04.01 machine, DE: Gnome 3.28.3, running firefox 65 with 1PasX 1.13.2.

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided



  • littlebobbytableslittlebobbytables 1Password Alumni

    Greetings @eventz,

    I only have Linux Mint set up at the moment and after getting Firefox 65 up and running I've been unable to reproduce the issue. It might be it's something specific to Ubuntu and I know we had trouble there in the past.

    In the thread we had on Ubuntu I stumbled upon the following post where the key part is

    This bug was fixed in the package gnome-shell - 3.28.3-0ubuntu0.18.04.4

    Could it be you're a minor update behind in something and that updating might resolve it? I'm basing that just on the 18.04.4 but I won't pretend to know Ubuntu well enough to know if that's meaningful or even related.

  • Thanks for the quick reply @littlebobbytables

    I'm not sure about the update thing, everything seems to be up to speed and everything worked smoothly right before ff 65 showed up.
    I downgraded to 64 and the issue was gone. Upgraded again to 65 and the problem came back haha. So it must be something quirky here.

    I'll look into it a bit more and see if I manage to point any fingers exactly.

  • JayschwaJayschwa
    edited February 2019

    I concur that the problem seems to be with pressing the Enter key after typing the password. On both the extension prompt and my.1password.com, pressing Enter has no effect. I must press the corresponding Sign In button to get it to work. I am using Firefox 65 on Ubuntu 18.04.

  • littlebobbytableslittlebobbytables 1Password Alumni

    It looks like maybe it is something about the specific combination of Ubuntu with Firefox and 1Password X. Looks like I'll need to set up an Ubuntu VM.

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hello @Jayschwa & @eventz,

    It looks like the supposed fix in Ubuntu didn't resolve everything completely, the one we detail in Lock screen issue: 1Password X for Firefox on Ubuntu 18.04 🐛⚠️.

    I just set up a copy of Ubuntu and could reproduce the issue using Ubuntu's default settings. After adjusting the keyboard input method to XIM and restarting Ubuntu I found I could unlock 1Password X using the enter key to submit in the pop-up. So Ubuntu have at least managed to stop the pop-up from disappearing but there are still issues. I'm guessing you both have the keyboard input method set to the default of IBus, can you see if you find the same as me and that changing it to XIM makes things behave better.

  • Thank you very much @littlebobbytables !
    That fixed the problem.

    Apologies if I was hasteful to "sound the alarm", I don't know why I didn't think of changing it :)

  • littlebobbytableslittlebobbytables 1Password Alumni

    Greetings @eventz,

    I'm glad you wrote in. The other thread suggested the issue was fully resolved and what we've discovered from your post is that isn't true. Always good to learn this sort of thing!

  • "It does work though, if I enter the password and instead of hitting "enter" on the keyboard I click on the unlock button."

    Nice! I don't know why it never occurred to me to just try the padlock button. This problem popped up for me around Firefox 63, maybe even a bit earlier than that. Since then I've just been going to 1password.com to unlock (which unlocks 1PX as well), but now knowing this works I can skip that step.

    If it's Ubuntu specific, I've been planning a migration to Manjaro soon anyway, so I can chalk this up to one more reason to switch.

  • ag_sebastianag_sebastian 1Password Alumni

    @jay_gunn: Sometimes the most obvious things can escape us when we face an issue, I know it happens to me all the time. :p If changing the input method isn't a viable solution, switching to Manjaro might help. If nothing, you'll get to work with a different distro. :)

  • Can confirm this issue still persists on Firefox Beta 66, Ubuntu 18.10 Cosmic, gnome-shell 3.30.1-2ubuntu1.18.10.2, and XIM. Whatever fixes Ubuntu released still don't address the issue for these versions :(

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hello @JustinBull,

    So you've already switched from the default of IBus and are using XIM and you're still seeing an issue? I only ask because after I switched and restarted Ubuntu I found things behaved for me. This wasn't with the beta Firefox and I was running the LTS Ubuntu so there are differences in our setup. If switching to XIM wasn't enough it sounds like it has regressed.

  • @littlebobbytables I'm sorry I misspoke! I meant iBus, not XIM. That is, without applying any of the workarounds described in Lock screen issue: 1Password X for Firefox on Ubuntu 18.04 I experience the issue that Ubuntu's bug report claims is fixed.

    Having applied 1Password's workaround of changing iBus to XIM and rebooting I can confirm it now works. Obviously I would hope the upstream Ubuntu issue is resolved.

    What's the difference between iBux and XIM anyhow?

  • littlebobbytableslittlebobbytables 1Password Alumni

    Greetings @JustinBull,

    Phew, that means our results tally and I do like consistency :smile: I'm afraid I have absolutely no clue what the difference is. Linux isn't my primary operating system and while I can use Linux I'm far from being a power user. All I know about iBus and XIM is that weirdly one allows things to work with 1Password X and Firefox and the other doesn't. That wasn't very helpful, sorry! I do't remember seeing posts from people suggesting the use of XIM was completely impractical so whatever the differences I don't think they're glaring ones.

  • I hope this helps narrow down the issue more. I think it might be related to Firefox more than Ubuntu. I have my keyboard input method currently set to iBus and not XIM since I wanted to check something.
    The 'Enter' key does not work specifically in Firefox 65 for me. It works great on Chrome, no issues. Note that I'm using the Chrome official release repo, not Chromium.

    • Ubuntu version: 18.10
    • Firefox: 65 (stable branch)
    • 1Password X (FF): 1.13.2
    • Chrome: 72.0.3626.81
    • 1Password X (Chrome): 1.13.2
  • littlebobbytableslittlebobbytables 1Password Alumni

    Greetings @chin7an,

    I do think Ubuntu is still part of the issue though, even though you find it is limited to Firefox and not Chrome. My first attempt to reproduce saw me install Linux Mint and everything worked fine there from a default install, it was only after installing Ubuntu that I could reproduce. From the little I know of the bug I believe the fix was made to the IBus package and Ubuntu uses this by default which would explain why I found switching to XIM and restarting Ubuntu helped. I can only assume that Mint and maybe others don't default to IBus.

  • Thanks @littlebobbytables, I'll see if there's any debug data I can help pull for this issue over on the Ubuntu bug. I'm not very experience with Linux desktop but have been experimenting with it since a few months.

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @chin7an,

    You say you're not very experienced with Linux but there's a very strong possibility you're like a sysadmin compared to me :lol: I'm still quite wed to my Mac and macOS :smile:

  • hi @littlebobbytables,

    what happened to your extension at firefox market? its missing

    link found by google - https://addons.mozilla.org/en-US/firefox/addon/1password-x-password-manager/

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hello @northys,

    We're suffering a small technical hiccup but I can at least say that the developers know and are working on rectifying the situation. Hopefully it won't take us too long to reinstate our presence and I apologise for the disruption.

  • thanks for an update

  • BTW, it's not just in Ubuntu. I'm seeing that exact same symptom on Fedora 29. Stranely, one of my installations began working again but the other does not. I wish I'd thought to try the click vs Enter approach. But alas, I tried uninstalling the addon and re-adding it (since one Fedora29 install was working properly... both on same patch level)... but then I tripped over the addon having been dropped entirely from the mozilla store.

    Don't try reinstalling the addon for now! Fair warning. Anyone got a copy of the addon package so others can still install it? :-1:

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @btaroli,

    Once we get 1Password X back into Mozilla's extension store can you see if any of the tricks in Lock screen issue: 1Password X for Firefox on Ubuntu 18.04 🐛⚠️ work. I don't know how many are specific to Ubuntu or may translate to other variations. All I can say with any confidence is everything worked fine with a stock install of Linux Mint and in Ubuntu after I altered the keyboard input method.

  • @littlebobbytables can you please upload the package somewhere so I can work? :unamused:

  • littlebobbytableslittlebobbytables 1Password Alumni

    Hi @northys,

    We'll keep 1Password X missing from addons.mozilla.org updated with anything we have to report which at the moment isn't anything useful. The developers are still trying to rectify this as quickly as possible.

  • Oh, another workaround. I found that if I Tab+space, the login button works as well. Right now, on Linux, I have one installation where Enter works and one where it doesn't. Still not sure why exactly, but at least there is a keyboard workaround.

  • ag_sebastianag_sebastian 1Password Alumni

    Thanks for sharing a workaround, @btaroli. :)

  • ZikoZiko
    edited February 2019

    I face with the same issue on Ubuntu 18.04 LTS and Firefox 65. Thank you @btaroli your workaroud is working for me! I hope the problem will be solved but meantime this is not much bad to do!

  • ag_sebastianag_sebastian 1Password Alumni

    @northys I have an update for you: 1Password X is back in the Firefox Add-on store. :smile:

    Thanks for confirming the workaround, @Ziko. It's good to know that it works for others as well.

  • @ag_sebastian thanks for pinging me :)

  • I installed the 1 Password Extension version 1.14 on the new version of Firefox 65. I am running 1 Password 6.8.9 on an old iMac running El Capitan.

    I can't get the Extension to unlock. I can't get it to connect to my 1 Password database. Please advise.

This discussion has been closed.