Strange problem

Just solved my apple problem with 2 home directories after hours with Apple tech support. Great support from Apple.

Now the 1P app is still functions from both the app & Safari but it will NOT open any sites. Also will not allow copy paste.

Should I uninstall 1P and reinstall my family plan?


  • ag_anaag_ana

    Team Member

    Hi @hawk713!

    Can you please clarify what you mean when you say that the app works in Safari but doesn't open any sites? If you could let me know the exact steps you are following, I can better understand the problem.

    Thank you!

  • When I ask 1P to open and fill a web site, a new window appears in Safari but I am not taken to the web site. 1P also does not allow me to copy the site address. I have an annual subscription to 1P family plan and use multiple Apple devices. After I deleted a bogus Apple user from my iMac, 1P stopped working on both my iMac and by MacBook.

    Both my iMac and MacBook computers now are missing the Safari helper app. I suspect reinstalling the Safari helper app will solve all my problems with 1P. Will try to do this on my own but any instructions are appreciated.

  • LarsLars Junior Member

    Team Member

    @hawk713 - can you be more specific about what you mean by Safari Helper App? Do you mean the 1Password extension in Safari? Something else? So we have a better idea of how to help you (and what might be wrong), can you tell us:

    1. What specific version of 1Password you have installed on the Mac in question?
    2. What specific version of macOS you have installed?
    3. What specific version of 1Password extension you have in Safari's Preferences > Extensions and whether it is enabled (turned on).
    4. What method you use to sync your data
    5. Anything else you think might be important for us to know.

    Thanks! :)

  • Lars,
    1. 1Password is great product. In trying to solve my problems I am even more impressed with Agile.
    2. I have: installed Firefox on my iMac, installed the 1Password extension for Firefox and everything works fine. If only I could install the Safari extension in the same way, all would be well.
    3. My system: 1Password version 7.2.5, MacOS Mojave Version 10.14.3, I do not have any version of the Safari Extension installed (I accidentally destroyed it. This was my problem not yours.), believe that my 1Password family plan is synced via iCloud.
    Thanks for your help.

  • LarsLars Junior Member

    Team Member

    @hawk713 - OK, thanks. Apple made some big changes in Safari 12, which ships with macOS 10.14 (“Mojave”). The biggest is completely changing the extension format. In the past, any app that wanted to interact with Safari had to offer a separate extension (.safariextz) that must be downloaded and installed by users independently of the main app. In Safari 12, they switched to the new Safari App Extension format, and the big difference is that there's no longer any separate extension to install; the extension is built right into the app. That's why it will have the same version number as the app (unlike in the past). If you have 1Password 7 for Mac (7.2 or later) installed, then you already have this extension. If you don't see it in Safari's Preferences > > Extensions, then you'll need to quit both Safari and 1Password 7 for Mac and restart them -- or better yet, restart your Mac. Then check Preferences > > Extensions again, and make sure it's there, and activated.

  • I have shutdown and rebooted my iMac. The 1P extension is there and opens 1P normally. When I select Safari Preferences I am immediately sent to the Apple app store. So Safari has the extension, knows 1P helper is there but wants me to grant permission for Safari's use of the extension. I am unable to do that.

    Is the my only option remaining deleting 1P, going to Agile website and subscribing to a new family plan, and then linking Safari to my current family account. I will have to do this for both my iMac, my MacBook, my iPhone and my Watch 4. If it is, I would appreciate any information on how this should be done. Links to web information are fine.

    Since I currently can use Firefox with 1P on my iMac, I will use this extreme step only as a last resort.

    Thanks for your help in proving a superb product.

  • ag_anaag_ana

    Team Member


    When I select Safari Preferences I am immediately sent to the Apple app store.

    What happens when you open Safari and press the Cmd + , keyboard combination (command key + comma key)? That keyboard shortcut should take you directly to your Safari Preferences without sending you to the App Store. Once you are there, you should see something like this:

    Is this what you see when you reach Safari Preferences?

  • Apple tech support solved the problem which was caused by a missing checkmark which is shown in the screenshot of Safari Extensions. So the helper app was installed but the permission was revoked. Once the problem was demonstrated to Apple the missing check mark was identified. This permission is critical to 1Password working with Apple hardware. I love both companies.

  • brentybrenty

    Team Member

    Very odd. Thanks for the update! Just glad it's working for you now. :)

This discussion has been closed.