when clicking EDIT on a 1PX displayed password, nothing happens :(

it doesn't pop anything. :(

1PX 1.15.8
1Password 7
Version 7.3.BETA-11 (70300011)
AgileBits Beta

1Password Version: 1Password 7 Version 7.3.BETA-11 (70300011) AgileBi
Extension Version: 1px 1.15.8
OS Version: macOS 10.14.4
Sync Type: 1P Account


  • Hi @lrosenman,

    For me I'm switched to 1Password for Mac and a pop-up window in edit mode appears. Can you see if Chrome is reporting as up-to-date or if there is a pending update. I'm just wondering if the issue of Chrome's code signature mid-update is causing a problem here or if it's something else.

  • It's up to date.

  • Hi @lrosenman,

    So something not as simple, that's a pity. I wonder if you can check a couple of logs for me please, see if we can pin down what's going wrong.

    For the 1Password X log the steps detailed on the following support page, Save a console log for 1Password in your browser should help. To give you an idea of what you should expect to see here is what I find after I successfully access edit mode using a combination of 1Password X and the 1Password for Mac betas.

    Sending encrypted <editItem> message to native app

    The other place to check is to see what 1Password for Mac has logged. For this you'll want the Console application that comes as part of all copies of macOS. It won't display the log file we're interested out of the box but use of Finder and drag and drop will take care of that.


    That's the log file that will record something and as the Library folder is hidden by default I like to use Finder's menu option Go > Go to Folder... as it will highlight the file in a new Finder window and then you can use drag and drop onto the Console application in the dock.

    What I'm seeing there with a successful edit operation is:

    ... [EXT_NMH:...:OP7NMB5XClientHandler.swift] S process(message:reply:) | 📩 Received 'encrypted' message
    ... [EXT_NMH:...:OP7NMB5XClientHandler.swift] S process(message:reply:) | 📩 Received 'editItem' message

    I'm wondering if you see either set of messages or maybe an error being logged, something that might explain why things don't seem to be playing nicely for you. The ... in the last two log messages was simply to try and make it easier to see the full message without too much scrolling and was mostly a timestamp.

  • I'm not seeing ANY traffic from 1PX...

  • I'm happy to do a screen share session with you if that would help.

  • Hi @lrosenman,

    Can we do a quick sanity check. With the background console log still available, if you lock 1Password for Mac does 1Password X behave as if it is locked and do you see messages such as:

    Received lock message 1 autolock
    🌈 Sending encrypted <lock> message to native app

    In the 1Password X console?

    If you then unlock 1Password for Mac does 1Password X become unlocked and are there messages such as:

    Unlocking with secrets from native host.
    Unlocked 2 account handlers. Dispatching unlock event.

    Even with everything working perfectly I also get a bunch of error messages about MFA so don't be shocked to see red in the console log. I'm just trying to see if it's that 1Password X isn't communicating with 1Password for Mac at all or if the issue seems to be weirdly limited just to editing. From your other recent posts I inferred native unlock is working but sometimes it's best to make absolutely sure.

  • I can't see ANYTHING from 1PX in the dev tools, but if I tell 1PX to lock, the Mac App locks.
    I'm now very confused.

  • brentybrenty

    Team Member

    I'm sorry for the confusion. Just to clarify, I would expect both the 1Password desktop app and the extension to lock due to the integration. You have that enabled, right?

  • Hi @lrosenman,

    Nothing being logged seems odd to me, while we are careful about what 1Password logs to the console it is reasonably chatty for those times where maybe we need to troubleshoot.

    Let's take a slightly different route. Just as a quick sanity check, if you add a dummy item to 1Password for Mac does it correctly appear in 1Password X? All we're doing here is making sure everything appears to be hooked up properly so that we know there's zero risk to removing 1Password X temporarily. Here are the steps I'm thinking about.

    1. Uninstall 1Password X.
    2. Restart Chrome.
    3. Install a fresh copy of 1Password X, the direct link 1Password extension - Chrome Web Store will help.
    4. For me I found I was immediately presented with an unlock screen for 1Password X but I had to restart Chrome once to get everything settled and playing nicely - not sure what that is about.
    5. Try to edit an item and see what happens.

    It's basically force a reset and see if a clean install performs the same. The only thing that will be lost are 1Password X's settings, there's no risk to actual data so hopefully it won't feel too onerous to try.

  • Did the above and still no reaction to edit at all.

  • @brenty that's correct both lock.

  • Hi @lrosenman,

    I'm really sorry, it looks like a change we've made since we released BETA-11 is why it's working for me. It should mean when the next beta is ready and available that you should see this work properly. I do apologise that for the moment you can't initiate editing directly from 1Password X.

  • I do understand (I work in the software/tech industry as a Site Reliability Engineer). Thanks! (so, I'm not crazy :) )

  • brentybrenty

    Team Member

    Well, maybe a little! ;) Anyway, you're in good company. :lol: Seriously though, thanks for your feedback on this. We'll get it sorted. :)

  • BETA12 fixed it :)

  • And ALL involved in SW/Tech are a little crazy :)

  • kaitlynkaitlyn

    Team Member

    I'm glad to hear that, @lrosenman! Enjoy your weekend. :)

This discussion has been closed.