Disable the 1Password icon from appearing in form fields.

Is it possible to turn off having the icon appear in the form fields? I'm fine just using the mac app or chrome extension to autofill and sometimes the button as gotten in the way of other functionality that is inserted into those fields (such as a "view password" toggle.

Thanks!


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • Here's an example. I don't want to see the 1password icon in the field.

  • kaitlynkaitlyn

    Team Member

    Hey @jpaw! For sure – you can disable the "Offer to fill and save passwords" option on the 1Password X settings page. To get there, click the 1Password X icon in your browser toolbar, then click the gear icon, then click Settings. Triggering that option off will disable the inline menu, but you'll still be able to fill your credentials using the 1Password X popup. I hope that helps!

  • @kaitlyn awesome, thanks!

  • kaitlynkaitlyn

    Team Member
    edited July 2019

    No problem! :+1: Have a great weekend.

  • It looks like this option is no longer available? (on 1.16.7, integrated)
    I just want to hide it because I prefer using 1Password (X) via keyboard shortcuts, with everything else being 100% hidden (it just feels clean). However, the icon does very occasionally obstruct functionality and visually tweak fields as well.

  • kaitlynkaitlyn

    Team Member

    Hey @camtech! You bring up a good point. It looks like the "Offer to fill and save passwords" setting is removed when Desktop App Integration is enabled (currently a beta-only feature). I went ahead and brought this up to my team so we can figure out what we're going to do there. In the meantime, disabling the "Show autofill menu on field focus" setting will cause the inline menu to only appear when you click the 1Password X icon inside fields. I know that's not a perfect solution, but it may help for now.

    ref: x/b5x#1408

  • Whoops, I should have put that in the beta forum, thanks for the answer @kaitlyn!

  • kaitlynkaitlyn

    Team Member

    @camtech – no worries! Thank you for getting it on our radar. :chuffed:

This discussion has been closed.