What do I need for Firefox 7?

I'm currently running Snow Leopard 10.6.6, Firefox 5.0.1, IPassword 3.8, (not sure which extension, don't know where to find the number, but it works seamlessly, so I haven't upgraded to the newer, more problematic extensions).

If I were to upgrade to Firefox 7, what would I need to do in terms of 1Password, and what issues would I expect to have? Are there still problems filling and saving logins, etc. Or has most of this been cleared up? Tried to find the answers on the board, but I couldn't wade through the myriad of threads re: other browsers and problems.

Thanks so much. I really do rely on this product, so I'm reluctant to change what I'm using, but I'm wary of being so far behind the curve here.

Robert

Comments

  • NikNik 1Password Alumni
    Hi, Robert! Upon upgrading Firefox to version 7, visit our extensions page to install the latest version:
    https://agilebits.com/extensions/mac/index.html

    We believe that most outstanding issues with the new extensions have been cleared up. There is, as yet, no contextual menu in the Firefox extension, and there is no support for HTTP auth, either:
    http://help.agilebits.com/1Password3/http_auth.html
  • Thanks Nik, I was wondering if others on the forum had made this transition, and what their experiences were thus far...? In other words, what "outstanding issues" remain to be cleared up? :) (I wouldn't be so cautious were not 1Password so important to my daily workflow.)
  • BenBen AWS Team

    Team Member
    Hi quietthunder,

    The only "outstanding issues" that I have seen with the Firefox extension are the two Nik mentioned above:
    * No contextual menu items (right click menu)
    * No HTTP basic authentication

    Everything else should work at this point. If not, there is nothing stopping you from going back to your current version of Firefox, though we generally recommend moving forward rather than backward.

    Thanks!
    Ben
  • bwoodruff wrote:

    Everything else should work at this point. If not, there is nothing stopping you from going back to your current version of Firefox, though we generally recommend moving forward rather than backward.


    I agree. Going backward sucks. So, how's that Basic AUTH support coming? Seems kinda backward to release without it. :)

    -Chris
  • NikNik 1Password Alumni
    Chris, currently none of the supported browser extension frameworks give us access to HTTP auth.
    http://help.agilebits.com/1Password3/http_auth.html
This discussion has been closed.