1Password Windows 7.3.684 slow performance/unresponsive UI.

I am currently using the Windows 1Password standalone app version 7.3.684 and I have about 1,000 entries in 1Password. The main issue I have is that if I modify an entry, hit save, and then quickly click on another entry, the program will often hang and become unresponsive for 5-10 seconds. Additionally, overall I just find the Windows program to be very unresponsive. I can reproduce this behavior on multiple machines and in different locations. It's slow enough that unfortunately it's making me consider other options. After searching the forums I do notice others are reporting similar issues. Does anyone have any ideas?

1Password Version: 7.3.684
Extension Version: Not Provided
OS Version: Windows 10 1809
Sync Type: Not Provided



  • GregGreg

    Team Member

    Hi @oiglesias,

    Thank you for getting in touch!

    It is possible that you bumped into a known performance issue in the current version of 1Password 7 for Windows, which is limited to a narrow range of setups (the majority of our users are not affected by this issue).

    We believe the upcoming 7.4 update will address the remaining delay issues but, we won't know for sure until we release its first beta first. Please let me know if you want me to send you an additional follow-up email when we have more news.

    If you have any other questions, we are always here for you. Thank you!


  • Hi @Greg,

    Thanks for your reply. Is there a ballpark timeline for the release of version 7.4?

  • LarsLars Junior Member

    Team Member

    @oiglesias - unfortunately not. We've learned, through experience, not to pre-announce release dates for new versions/features/updates, as many factors (some beyond our control) affect them. However, it's the next update, not "someday, maybe," so it shouldn't be too much longer. Please stay tuned. 😀

  • @Lars I completely understand and appreciate for the response!

  • GregGreg

    Team Member

    @oiglesias: On behalf of Lars you are very welcome! :)

    While you wait for the update, you can also give 1Password X a try. 1Password X works entirely in your browser, so it should not be affected by the issue you bumped into. Let us know if it works better for you. Thanks! :+1:


  • I'm experiencing the same, very annoying issue with 7.3.684 with basically any interaction with 1Password or the browser plugin (Chrome, IE, Fiirefox). I'm at about 1,300 items and 2 vaults.

  • bundtkatebundtkate

    Team Member

    As mentioned above, @xtremetoonz, this is most likely an issue we're already aware of and working on resolving. It's a high priority, but not a quick fix. As Greg mentioned, 1Password X can help if your primary struggle is with filling, but it isn't available in Edge. I know you said IE, but 1Password 7 doesn't support IE at all, so I assume you meant Edge there.

    If you'd like, we can absolutely take a look at some diagnostics to confirm, but these sorts of symptoms generally mean this known issue has bit you and using 1Password X, if it's an option for you, is going to be the most helpful thing you can do until we've got it fixed up. :+1:

  • My reason for posting here wasn't to suggest it's a different issue, it's more to communicate that it seems I'm in this same boat and hoping there will be some communication as to when there's a resolution. More of an up-vote and to follow the progress. And yes, Edge, not IE though it's not a frequently used browser. Primarily Chrome. Thanks for the reply and attention to this as it does impact day to day productivity and sanity. :)

  • bundtkatebundtkate

    Team Member

    No worries, @xtremetoonz! If Chrome is your primary browser, I'd definitely suggest giving 1Password X a try. It's a different experience from the standard extension and does require a 1Password membership, but it should definitely ease the pain. Plus, I genuinely love it. I've avoided this issue thus far, but I use 1Password X anyway just because I'm such a fan of how it fills, so who knows? Maybe you'll never go back. :wink:

    As for an update, we generally don't share ETAs, but particularly shy away from it in cases like this. This is a complex issue and, although we understand the cause and know what needs to be done to fix it, it's a pretty big project which makes it tough to guess at when we might have a beta ready. I always hope for soon, of course, but there's often no telling until it's all but out the door. Hopefully, 1Password X can mitigate the struggles for now, but definitely keep an eye out for improvements in upcoming versions. :+1:

  • @oiglesias regarding to what you said, I can't reproduce this behavior on my Win 10 64bit, version 1093 with all the latest updates.
    Try to update to the new version. You are using older version: 1809

  • bundtkatebundtkate

    Team Member

    A few of us are stuck on older versions of Windows as a result of hardware incompatibilities with the latest, @r1ma. I'm actually still on 1803, if you can believe it, with no updates available. Regardless, the issues folks here are seeing aren't related to their Windows versions. It's a known issue that just so happens not to impact everyone using 1Password and we're working on a fix. :+1:

  • 1PasswordX works very fast but 1Password addon for Chrome is not working. Long delays, missing fields like generating new password on new user fields, etc are not working properly or works delayed.

  • bundtkatebundtkate

    Team Member

    I'm not sure I'm following what's not working for you with the companion extension, @Naxterra. Things like suggesting a new password on an account creation page are exclusive to 1Password X – the companion extension with 1Password for Windows won't do that at all. Instead, you generate a new password in the extension pop-up and copy/paste that generated password to the password field. But, perhaps I'm just not quite grasping what you're expecting here. Could you set me straight with some additional details?

  • Sure

    If I understand correctly there are two extensions. 1Password - works with only desktop app is installed, 1PasswordX - standalone, works without desktop app.

    When using 1Password, username password fill menus are not showing up instantly. It is taking a bit time, sometimes it is not even showing anything. Selecting entry manually from addon itself (click on addon icon on top right of Chrome, then select entry) doesn't work or works after a while. It is also not recognizing password changes or password generation fields properly.

    1PasswordX works fine, it is fast but there is issue with constantly have to login when I close Chrome.

    Not addon related. 1Password is not recognizing desktop apps to fill passwords. For example my Final Fantasy 14 game launcher has 3 fields. Username, password and 2FA token field. It didn't recognize Origin too. At the moment I have Outlook, Chrome, Origin, Spotify and FF14 Launcher running in the foreground, 1Password only shows Outlook, Chrome and Spotify to fill via desktop app.

  • bundtkatebundtkate

    Team Member

    Starting with the desktop apps, @Naxterra, that's essentially expected. There are numerous reasons 1Password may not be able to see those windows ranging from those windows being elevated to deliberate choices by those apps to hide their window from other processes. In cases where the window isn't visible to 1Password, it won't display in Type in Window and your best bet will be either to copy/paste or drag and drop from 1Password X.

    I'm still not totally clear on what you're referencing when you mention fill menus not showing up for the companion extension. If you're referring to the inline menu that 1Password X uses, that isn't available at all with the companion extension. That extension can fill two ways – as you described by selecting the item you want to fill from the extension pop-up and by pressing Ctrl + \ to fill (or show mini in the case that there's more than one matching item). Are you using this extension with 1Password X still enabled, by chance? That could be a potential explanation as the two really aren't meant to be used together and could run into conflicts.

    As for signing into 1Password X, if you're talking about needing to enter your Master Password any time you close Chrome, that's expected. 1Password X runs just within Chrome (as you noted) and thus discards its unlock keys and quits when the browser is closed. We have some ideas as to how we might improve this in the future, but those changes are still a ways off and not worth speculating about at this point. If you're having to enter more than your Master Password (Secret Key, etc.) then that's another story and something we may be able to address now. :+1:

  • I am not sure what hidden windows's are. 1Password is not copying my passwords into app windows. I tried iTunes now, it shows in right click menu of 1Password mini. I right clicked on password, selected password then iTunes but nothing happened.

    Apps that I mentioned before were game launchers. I need to enter my username and password, and some of them requires 2FA tokens too. I expect 1Password at least fill in username and password fields of these apps.

    For filling issues. I am enabling only one for testing purposes (I am still on trial version). I enabled either 1Password or 1PasswordX or 1PasswordX Beta, never enable two or three of them at the same time. Example of filling issue. I am trying to enter amazon.de. 1Password addon shows no icon on username and password section. I select manually amazon.de on Chrome addon, then it waits for several seconds, then fills it. After that I log out. Enable 1PasswordX, disable 1Password. It shows icons on username and password field and exact website to fill as a dropdown menu. I click on it and it fills out without issues.

    I hope this make clear of my problem

  • bundtkatebundtkate

    Team Member

    I expect 1Password at least fill in username and password fields of these apps.

    I understand your expectation here and we are working on making Type in Window more reliable, but as it stands, there are a lot of stars that need to align for it to work well. 1Password needs to be able to see the window (this is what determines whether that app shows as an option for filling or not) and even when the window can be seen and does show up, the app needs to accept 1Password's input. In apps where Type in Window works well, you can select a field in the app, press Ctrl + Alt + \ to bring up 1Password, search for the item you want to fill, then right-click and fill as you have been, but we don't currently expect this to work everywhere. There are hurdles to filling in apps the feature has yet to overcome and we hope to make improvements on that front in a future version.

    1Password addon shows no icon on username and password section.

    This is expected with the 1Password extension. Only 1Password X will show icons in fillable fields. This is the inline menu I was talking about and isn't available with the desktop app's companion extension. It sounds to me like 1Password X has more of the types of features you're looking for and works well for you, though, so I'd honestly encourage you not to worry about the companion extension and to stick with 1Password X. If there's something about the companion extension that makes you want to use it instead but for the issues you've seen, then absolutely let me know and we can take a closer look, but I get the distinct impression 1Password X is your preferences and that's totally fine. I don't have any genuine issues with the companion extension, but I use 1Password X myself anyway. I find the inline menu makes it much easier on me to stick with keyboard navigation and generally enjoy the filling experience with 1Password X more. You only need one extension, so if 1Password X works well for you, I'd say stick with it. :+1:

  • Well, I can use 1PasswordX but entering my master password again and again after each time I close my browser is not something what I want.

    It would be good if it supported Windows Hello authentication methods or detect if Windows app is unlocked or not.

  • bundtkatebundtkate

    Team Member

    That's something that we do plan to add in the future, @Naxterra. What it will require is integration with the desktop app, though. This integration is in beta on Mac, but not yet on Windows as we have a few issues taking a higher priority (the performance problems you're seeing being among them). In all likelihood, the performance issues will be sorted out well ahead of the introduction of desktop app integration for 1Password X, so it's best to think of using it as a stopgap until that's done. If and when desktop app integration makes it to Windows, you can reassess if you prefer that filling experience overall and make a full switch then. :+1:

  • I reported this issue back in June 2018. There were some improvements in 7.3 but still experiencing slow performance. Not sure why my old topic was closed, but I'm still very unhappy with the performance in Windows compared to MacOS. Everytime I unlock or edit a login data, there's a huge lag between actions which freezes the UI. I really do like 1Password, but this issue is starting to make me look for alternatives since it hasn't been fixed for over a year.

  • brentybrenty

    Team Member

    @komocode: Sorry about that. If the discussion had no inactivity for more than 6 months, it should be closed automatically, as otherwise there can be a lot of confusion as things change over time.

    Would you be able to send a video of what you're experiencing? It can be slow sometimes on my underpowered Surface, but nothing that I would describe as "huge lag" or "freezes". I'd love to get a sense for what you're experiencing, and some current diagnostic information.

  • @brenty the topic still had activity in April (my last comment was in January signifying I sent updated diagnostics) but was closed in May. Here's the thread. https://discussions.agilebits.com/discussion/91202/slow-performance-in-1password-7-2-7-2-580-update-will-be-out-soon-more-improvements-coming-in-7-3#latest

    I've sent videos and diagnostics before (see the previous thread). But here's another video. Running 7.3.684 on a Skylake Intel® Core™ i7-6770HQ processor and Samsung SSD 960 250GB. I also have another desktop PC running a 6700k skylake processor on a Samsung 951 NVME drive encountering the same slow performance. I play heavy video games on both machines with 0 issues.

    In the video, notice when I click save at 8 seconds and then wait about 22 seconds before it successfully saves into my vault. Every single modification to my vault takes about 20-30 seconds to do.

    Video: https://www.icloud.com/photos/#0Dx3Z8GhkTVtV6wrb1x0b9sNg

  • brentybrenty

    Team Member
    edited August 2019

    @komocode: Ah, thanks for the context. Indeed, you created that discussion regarding version 7.0.558, more than a year ago, and as you said yourself subsequent updates helped. So whatever problem you were having at the beginning will not be the one you're having now. And, frankly, it can confuse things further when others are talking about different versions and issues as well. The only activity there after March was from someone else with a completely different issue, so I closed it.

    Are you running the beta? If not, I'd suggest that as a starting point since, even if the current beta does not help with your particular issue (I don't have any reason to believe that it should), you'll get the 7.4 betas as soon as they're available. I don't have a time frame on that, but we're working hard to get it ready, since there are some significant changes under the hood.

    Regarding the video, that's very helpful. I've never seen anything like that, even on my oldest, slowest devices, and I can imagine that would be incredibly annoying. What type of vault are you using in 1Password?

  • @brenty
    I just switched over to 7.3.705 beta channel. Still laggy performance but I guess I'll wait for the 7.4 update.

    Previously the update helped a bit, reducing from 30 seconds to 5-10 seconds, but as my vault grew, the performance got slower and slower and now it's back to 20-30 seconds of freezing.

    I'm using a Dropbox .opvault

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @komocode,

    Can you try the Help Menu > Tools > Optimize Database in the main 1Password window to see if it helps a bit?

  • @MikeT Just tried Optimize Database. Had no effect.

  • GregGreg

    Team Member

    @komocode: Sorry to hear that!

    If you shared a new diagnostics report from 1Password 7 on your computer, it would be really helpful. Please attach that report to an email message addressed to [email protected] and we will take a closer look.

    Do not post your Diagnostic Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your report in our inbox. Thanks!


  • bundtkatebundtkate

    Team Member
    edited September 2019

    I came across your message in my email rounds today, @komocode, so I went ahead and replied there. You should have it waiting in your inbox for you so we can continue the conversation over email. :+1:

    ref: KFD-66755-745

  • Hi, I haven't read the whole thread but most of it. I do confirm that I do have severely performance issues to the windows version too. When I do login and search for a password, or when I want to edit sth etc. I thought it has to do something with encryption or similar. I am glad that it seems to be a known bug. I do have since the beginning of version 7 for sure. I don't have that problem on Android.

    Off-topic ON:
    Btw, any chance to offer storage space on your server for 1Pass single license holders? I do have licenses for the OSes I am using and don't want to move to subscription model, but my work blocks Dropbox and since for some reason u don't have alternative cloud services (like box.com google drive, mega etc) I would like an option to use the server just for storage (not licensing)
    Off-Topic OFF

This discussion has been closed.