Can't copy passwords on Mac - Chrome extension

Title pretty much says it all - I open the Password Manager, go to the desired login, click on Copy (or Reveal then Copy). Either way, when I go to paste the Password, it pastes whatever was the last thing on the clipboard, it never copies the password. Frustrating.

Copy seems to work on the main 1P app, just not in the browser extension. FWIW, I am using the Chrome extension in the Opera browser. The copy function has worked perfectly well for at least a couple of years, now it doesn't. Thanks!

1Password Version: 7.3.2
Extension Version: 1.16.1
OS Version: 10.12.6
Sync Type: Not Provided
Referrer: forum-search:Can't copy passwords on Mac - Chrome extension



  • Oh, and I see this has come up in the past - I don't use any clipboard manager (I think). I've had some installed in the past but I don't think any of them are running anymore.

  • ag_yaronag_yaron

    Team Member

    Hey @btessler ,
    Sorry for the delayed response. Are you still having this issue even after the update to 1Password X that was released a week ago?

  • Yes, it's still an issue. I'm using 1.16.2.

    No matter what I do, it just repeatedly pastes the PRIOR clipboard content and never adds a password.

  • Slight clarification - I re-booted, then opened 1PW and selected a random password. Clicked on Copy, then Paste (in a blank document) - nothing. Then I clicked on Reveal first, then Copy, then Paste - and this Password shows up. BUT - that's it. I tried over and over with different accounts and it just pastes this first password repeatedly - clipboard only updated that one time.

  • ag_yaronag_yaron

    Team Member

    That is strange. I just tested it on Windows 10 with Chrome and 1Password X 1.16.2.
    I clicked on the 1Password X icon, selected a random login from my list, clicked the COPY button on the password field and pasted it successfully everywhere I tried.

    It does sound like something is preventing 1Password X from populating your clipboard. Can you please try booting in Safe Mode, then see if you are able to copy usernames / passwords from 1Password X?

  • brentybrenty

    Team Member

    @btessler: I'm seeing what you're describing in the following configuration:

    macOS 10.14.6, 1Password X 1.17.1, Opera 63.0.3368.88

    But only sometimes. It works fine in Chrome, but something in Opera seems to be interfering with copying information to the clipboard on occasion. Thanks for letting us know! We'll see if we can find a way to work around it. Is there a specific website this happens to you on? I wonder if there may be some Javascript interaction. I'm seeing some other odd issues only in Opera though, so it may just be the browser itself.

    ref: xplatform/xplatform#100

  • You're right, Copy and Paste works fine in Safari, not in Opera.

  • Sorry, it's not limited to any specific site. Even just opening 1Password and trying to copy random passwords doesn't work.

  • kaitlynkaitlyn

    Team Member
    edited September 2019

    Thanks for the additional info, @btessler! I got the same results as Brenty, where some values copy and some don't in Opera although I haven't found a consistent pattern. We've got an issue filed now, so our developers will take a look. In the meantime, I found that the drag and drop feature still works for me. If you're unable to autofill your information, you can click on the username/password (or any value for that matter) in the 1Password X pop-up and drag it to the field you'd like to fill. I hope that helps!

    I do want to clarify for you and anyone else who stumbles across this post that 1Password X isn't available for Safari. What you're seeing in Safari will be the Safari App Extension that depends on the 1Password for Mac app. :)

  • Hi, I started to have a similar problem. I am not exactly sure if it is related but it started right after I installed and made full clean up with CleanMyMac. I tried to uninstall and reinstall 1Password X but the problem is still there. Copy Paste works fine for username but not for passwords or one time tokens. Did you make in progress since September?

  • ag_anaag_ana

    Team Member


    What version of 1Password X are you using, and on which browser?

  • Hi @ag_ana I am using 1Password X 1.18.0 on Chrome 82.0.4085.12 with macOS 10.15.3

  • ag_yaronag_yaron

    Team Member

    Hey @btutal ,
    Chrome is currently on version 80 on desktop computers. Are you using a different build of Chrome (such as Chrome canary)? If so, please try installing the official stable build and see if that works properly for you with 1Password X:

  • Hey @Yaron ,

    That solved the issue, I was using Chrome with dev channel. (

  • ag_yaronag_yaron

    Team Member

    Ah, good to know @btutal.
    I'm glad we got this down :)

  • Does it make sense to try to reproduce it to avoid this when 82 or whatever change that causes this issue goes to the stable channel?

  • ag_yaronag_yaron

    Team Member

    Our devs are on it ;)
    This should be fixed for Chrome Canary as well soon.

  • I've been having the same problem on Edge Dev for some time now and it's super annoying. Any ETA for the fix?

  • ag_yaronag_yaron

    Team Member

    No news to share at the moment, but our developers are aware of the issue and we're all hoping it will be fixed soon.

  • I am using version 1.18.1 on Opera Mac and have the same issue, it doesn't copy passwords 99% of the time, and hasn't ever as long as I've been using it (a year to two).

  • kaitlynkaitlyn

    Team Member

    Thanks for the report, @peterdeep! I haven't heard of the copy button not working for a year or two, but I'll definitely pass your report along to the rest of the team.

    ref: dev/core/core#1127

  • XiaxingXiaxing
    edited April 23

    Hi @Yaron, @kaitlyn . I am a 1Password X user and I am a developer in Opera. I think the issue starts around Chromium 82/82 (Opera 68/69).
    I am not a Blink expert. But if you could share the API for writing the clipboard. I can have a look. Feel free to contact me via email.

    Never mind. I found it. Clipboard.writeText() is called when the copy button is pressed.

  • It seems that the extension popup is closed too soon, which results in the copy issue.
    When Clipboard.writeText() is called, some IPC calls should be performed from the renderer process to the main browser process in order to write the clipboard. Those IPC calls never reach the main browser process.

    And I can see that the issue is reported to chromium already: extension close&can=2

    Good luck!

  • kaitlynkaitlyn

    Team Member

    Thanks for digging into that, @Xiaxing! I'll pass the info along to our developers. Keep an eye out for future updates. :)

  • oliverdunkoliverdunk

    Team Member

    Hi @Xiaxing! It was actually me that opened that bug. It's always nice to contribute back to the browsers when we can.

    In this case, we have a workaround, so you will hopefully see a fix soon! It would be great to see a change in Chrome, too, but that bug may still be open after we've released the fix on our end.

  • I have the same issue for Chrome Version 83.0.4103.24 (Official Build) beta (64-bit on Windows 10.

  • kaitlynkaitlyn

    Team Member

    Thanks for letting us know, @LagPick! We've got a fix coming for you soon, so make sure you've got automatic updates enabled. :)

  • Any update? A major bug for such many months?

  • kaitlynkaitlyn

    Team Member

    @LagPick – Thanks for checking in. The issue was resolved in the 1Password X beta that was released a couple weeks ago. You're welcome to install it here if you'd like the fix now.

  • Hi @kaitlyn The link you prefer sent me to a 404 page (

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file